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AN-SOF Antenna Simulation Software

Fast and Easy-to-Use Software for Antenna Modeling, Analysis, and Design

Welcome to AN-SOF!

Congratulations on choosing AN-SOF, the best combination of ease of use and accuracy
you can find in an electromagnetic simulator for the modeling and design of antennas and
wire structures in general. This User Guide describes AN-SOF and its many features in
detail. Here, you will also find step-by-step examples and tips to help you quickly progress
with your antenna modeling projects.
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Enhancing Antenna Design Through Simulation Software

An antenna model is a representation of a real-world antenna in a computer program. This
type of model should not be confused with a scale model, which is sometimes built to
measure the radiation characteristics of a larger physically-sized, identical antenna. Due to
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the mathematical complexity involved in modeling, computer software is often programmed
to predict and analyze antenna performance.
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Computer simulation in the industry is used to overcome challenges and drive innovation in
the product creation and development processes. A computer model offers the advantage
of being easily modified, redesigned, broken, destroyed, and rebuilt multiple times without
wasting materials. Therefore, the design process can achieve a significant reduction in the
cost of building successive physical models with the aid of simulation software.

AN-SOF is a comprehensive simulation software suite for antenna modeling and design. It
facilitates the design of various wire antennas, such as dipoles, monopoles, yagis, log-
periodic arrays, helices, spirals, loops, horns, fractals, phased arrays, and many other
antenna types. Additionally, AN-SOF supports the modeling of feeding systems using
transmission lines, allowing for a detailed analysis of antenna configurations. The software
is capable of simulating antennas positioned above lossy ground planes or broadcast
antennas above radial wire ground screens.
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Moreover, AN-SOF’s calculation method has been expanded to include single-layer
microstrip patch antennas and the computation of radiated emissions from Printed Circuit
Boards (PCBs). Consequently, AN-SOF can be effectively utilized for Electromagnetic
Compatibility (EMC) Applications. The software accommodates passive circuits with
lumped impedances and non-radiated networks, enabling a comprehensive analysis of
antenna systems.

Note

In the realm of antenna applications, AN-SOF proves invaluable as it empowers users
to achieve the following:

Design superior antennas.

Predict and optimize antenna performance.

Fine-tune antenna parameters for optimal results.

Account for environmental effects on antenna performance.

Employ script-based optimization to refine designs.

Gain valuable insights into antenna behavior.

Experiment multiple times prior to physically building the antenna model.
Deepen understanding of antennas and their properties.

Facilitate knowledge sharing and collaboration with colleagues.

Embrace the excitement of this fascinating field with AN-SOF at your disposal!

With AN-SOF, the possibilities for antenna analysis and optimization are extensive, providing
a comprehensive toolkit for antenna design and performance evaluation.

Note

AN-SOF enables us to perform a wide range of tasks, including:

Describing the antenna’s geometry accurately.

Selecting appropriate construction materials.

Specifying the environmental and ground conditions.
Determining the antenna’s height above the ground.
Analyzing the radiation pattern and front-to-back ratio.
Plotting directivity and gain.

Evaluating impedance and SWR (Standing Wave Ratio).
Predicting bandwidth.

Obtaining numerous additional parameters and plots.
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The structure’s geometry can be easily drawn in AN-SOF using the mouse, menus, and
user-friendly dialog windows. Wires are drawn in a 3D space, where tools are available to
zoom, move, and rotate the structure.

To plot the results from a simulation, a suite of integrated applications allows us to display
graphs: AN-XY Chart, AN-Smith, AN-Polar, and AN-3D Pattern. These tools can also be
executed independently for subsequent graphic processing.

With AN-SOF and its software suite for displaying graphics, we have all the necessary tools
to guide us through the stages of an antenna design process.

Learn more

Introduction to AN-SOF: Antenna Simulation Essentials

AN-SOF performs computations of electric currents flowing on metallic structures, including
antennas in transmitting and receiving modes, as well as scatterers. A scatterer refers to
any object capable of reflecting and/or diffracting radiofrequency waves. For instance, wave
scattering analysis can be conducted on the surface of an aircraft to determine optimal
antenna placement, on a parabolic reflector to examine gain in relation to the reflector
shape, or on a car’s chassis to predict interference effects.

The Method of Moments (MoM) stands as one of the most widely validated techniques for
antenna simulation. AN-SOF incorporates an enhanced and advanced version of this
method called the Conformal Method of Moments (CMoM) with Exact Kernel, which
addresses various challenges associated with traditional MoM approaches and achieves
unparalleled accuracy.

Interested in learning more about the CMoM implementation in AN-SOF? Read this article
>,
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Fig. 1: Computer models of a car, a parabolic reflector, an airplane, and a ship using wire grids.

According to the MoM, any metallic structure can be represented using conductive wires,
as illustrated in Fig. 1. These wires are subdivided into small segments, which assume the
shape of cylindrical tubes. To obtain accurate results, the length of each wire segment
should be comparatively short compared to the wavelength, as depicted in Fig. 2. However,
this concern can be alleviated during the initial simulation since AN-SOF automatically
handles the segmentation of wires.
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3 Short Segment <X /10

Fig. 2: A straight wire divided into short
segments relative to the wavelength.

The flow of electric currents within the structure can be achieved by introducing a voltage
generator at a specific location operating at a given frequency. Current generators can
also serve as the excitation source, alongside plane waves impinging on the structure from
distant sources. Once the geometry, materials, and sources of the structure are defined, the
computation can be executed to determine the currents flowing through the wire segments.
Generally, these electric currents exhibit varying intensities along and across the structure,

collectively referred to as a current distribution. Fig. 3 showcases an example of the
current distribution on a log-periodic antenna.
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Fig. 3: Current distribution on a log-periodic antenna. The color map on the

structure indicates the amplitude of the electric currents.

In the subsequent phase of the simulation process, the electromagnetic field radiated by
the current distribution can be calculated. However, the current distribution itself provides
valuable insights into the behavior of the structure, particularly when a frequency sweep is
conducted. In the case of antennas, the feed point impedance can be analyzed as a
function of frequency to assess the bandwidth. The Voltage Standing Wave Ratio (VSWR)
can be plotted on a Smith chart for better interpretation of the results, as demonstrated in
Fig. 4. The electric and magnetic fields in the proximity of the structure, known as the near-
field zone, can be obtained and visualized as a color map, with intensities often resembling

temperature maps used in weather forecasts, as shown in Fig. 5.
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Fig. 5: Near electric field in the vicinity of a Horn antenna.
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In the far-field zone, situated several wavelengths away from the structure, the magnetic
field becomes proportional to the electric field. As a result, the electric field intensities are
commonly used to analyze the results. This region is depicted in polar diagrams, as
illustrated in Fig. 6, where the radiated field is represented as a function of direction. A more
comprehensive representation can be achieved by plotting a 3D pattern, where radiation
lobes can be superimposed onto the structure’s geometry, providing enhanced visualization
of its directional properties, as exemplified in Fig. 7.
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Fig. 6: Far-field pattern represented in a polar diagram, indicating beamwidth,
front-to-rear ratio, and front-to-back ratio.
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Fig. 7: Far-field pattern represented in a 3D plot, superimposed onto the antenna
geometry.

AN-SOF stands out as the easiest-to-use software tool for simulating antennas, particularly
those that can be modeled using conductive wires. Are you ready to embark on your first
simulation? Let’s get started!

Performing the First Simulation with AN-SOF

Several example files are included in the AN-SOF installation directory, located within a
folder named “Examples”. When opening a file with the extension “.emm?”, the wire structure
will be displayed on the screen. To run the calculation, click on the Run ALL button on the
toolbar. The main results can be plotted by clicking on the following buttons: Plot Current
Distribution, Far-Field 3D Plot, and Far-Field Polar 1 Slice.

As a first experience using AN-SOF, let’s simulate a standard half-wave dipole, which is one
of the simplest antennas that can be modeled. A dipole is a straight wire that is fed at its
center. When the wire’s cross-section is circular, it is referred to as a cylindrical antenna.
Since the wire is typically made of a highly conductive material, it can be considered a
perfect conductor with zero resistivity. Therefore, we will model a cylindrical antenna with
zero resistivity in this example. Follow the steps below to perform this simulation.
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Step 1: Setup

The first step is to set the operating frequency. Navigate to the Setup tab in the AN-SOF
main window. Within the Frequency panel, there are three options to choose from. Select
Single and enter the operating frequency for the antenna (see Fig. 8). In this case, the
frequency is given in megahertz (MHz), and lengths are measured in meters (m). If desired,
you can change the unit system for frequencies and lengths by going to Tools >
Preferences. Please note that for a frequency of 300 MHz, the wavelength is approximately
1 meter (0.999308 m).
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Fig. 8: The Single Frequency option in the Setup tab, where a frequency of 300 MHz is set.

Step 2: Draw

Once the operating frequency has been set, you can draw the antenna geometry on the
Workspace tab. The workspace is where the wire structure is visualized, representing a 3D
space that allows zooming, rotation, and movement.

In AN-SOF, a straight wire is referred to as a Line. To draw a line, go to the main menu and
select Draw > Line. This will open the Draw dialog box. In the Line tab, you can set the
coordinates of two distinct points.

For this example, we will create a line along the z-axis that is 0.5 meters long, corresponding
to half a wavelength at 300 MHz. Figure 9 illustrates the chosen starting point of the line at
(X1,Y1,21)=(0, 0, -0.25) m, and the ending point at (X2, Y2, Z2) = (0, 0, 0.25) m. Next,
switch to the Attributes tab (see Fig. 10). To ensure accurate results, the line should be
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divided into segments that are relatively short compared to the wavelength. Generally, a
segment length equal to or less than one-tenth of a wavelength is considered short. AN-
SOF suggests a minimum number of segments to achieve reliable results automatically. If
you require higher resolution, you can increase the number of segments.

| Attributes | Materials |

Options: 2Points

From Point [m]

X1 0 ¥10

Fig. 9: The Line tab in the Draw dialog box for
drawing a straight line.

Mumber of Segments 17

Fig. 10: The Attributes tab in the Draw dialog box,
where you can set the number of segments and wire
radius.
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In this case, the line will be divided into 17 segments, and the wire cross-section will be
circular with a radius of 5 millimeters. On the Materials tab (refer to Fig. 11), you can set
the wire’s resistivity to zero.

Wire Resistivity [Ohm m)] 0

Wire Coating

Relative Permittivity eps 1
Relative Permeability mu 1

Thickness [mm]

[ o ] [ o ]

Fig. 11: The Materials tab in the Draw dialog box,
used for setting the wire resistivity.

The next step is to feed the dipole. Right-click on the wire and select the Source/Load
command from the pop-up menu that appears. A toolbar with a slider will be displayed at
the bottom of the screen. Move the slider to the segment located at the center of the wire.
Then, click the Add Source button. Add a voltage source with an amplitude of 1 Volt and a
phase of zero (see Fig. 12).
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Fig. 12: The Add Source dialog box appears after clicking the Add Source button in the Source/Load
toolbar at the bottom of the screen.

Step 3: Run

To run the calculation, go to Run > Run Currents in the main menu. Once the calculations
are completed, proceed to Run > Run Far-Field in the main menu. This will calculate the
current distribution on the dipole antenna and the radiated field.

AN-SOF provides integrated graphical tools for result visualization. Right-click on the wire
and select Plot Currents from the displayed pop-up menu. A plot showing the current
distribution in amplitude along the dipole antenna will be displayed (refer to Fig. 13). Since a
half-wave dipole has been drawn, the resulting current distribution resembles a semi-cycle
approaching a sine function.

You can obtain several parameters from the perspective of the voltage source connected to
the antenna terminals. Right-click on the wire and select List Currents from the pop-up
menu. Move the slider to the position of the voltage source and click on the Input List
button. This will display the input impedance of the dipole antenna, along with many other
parameters (see Fig. 14).
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Fig. 13: Current distribution in amplitude and phase along a half-wave dipole.

B input List

Current vs. Freg
voltage vs. Preg
Porwer ws. Fresg

Rho ws. Freq

VSR vs. Freg
Rt Loss vs. Freg
Teares. Loss vs. Freg

Pt

= 1 ) Z: £a3 Segment: 5of 17 Poson: S50%

Wires: 1 Sowces: 1 Loads: 0 Segments: 17 Connectssns: 0 GNIDE 0 Totak 17

Fig. 14: The Input List dialog box displaying the input impedance.

https://antennasimulator.com/index.php/an-sof-user-guide/ 16/303



12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

Alternatively, you can obtain the input impedance by simply clicking on the List Input
Impedances (Zin) button in the main toolbar. To represent the radiation pattern in a 3D plot,
navigate to Results > Plot Far-Field Pattern > 3D Plot in the main menu. The normalized
radiation pattern will be displayed in the AN-3D Pattern application. A color bar-scale
indicates the field intensities over the radiation lobes. Additionally, you can plot the directivity,
gain, and electric field patterns by accessing the Plot menu in AN-3D Pattern. In the case of
a half-wave dipole, it exhibits omnidirectional characteristics in the plane perpendicular to the
dipole axis (xy-plane) (refer to Fig. 15).
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Fig. 15: The radiation pattern of a half-wave dipole exhibits a donut shape.

As you have just experienced, a simulation consists of three simple steps. We hope you
have enjoyed this example. For additional step-by-step examples, please visit our section
titted Examples > Step by Step.

Summary

The key advantages of AN-SOF can be summarized as follows:

AN-SOF is antenna modeling and design software that offers fast and user-friendly
input and output graphical interfaces.

AN-SOF employs the Conformal Method of Moments with Exact Kernel, resulting in
enhanced accuracy and speed.
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AN-SOF provides an extended frequency range, enabling simulations from extremely
low frequencies (such as 60 Hz circuits) to microwave antennas.

Simulating a wire structure involves a three-step procedure:
1. Setup: Set frequencies, environment, and desired results.
2. Draw: Draw the geometry, specify materials, and add sources.
3. Run: Perform the calculation and visualize the results.

At the beginning of the simulation, you can choose a convenient unit system for frequencies
and lengths. This choice can be adjusted later by accessing Tools > Preferences. For
instance, wire lengths are typically measured in meters (m) or feet (ft) for frequencies below

100 MHz, while millimeters (mm) or inches (in) are commonly used for higher frequencies.
AN-SOF Overview

Features and Capabilities

AN-SOF is a comprehensive software tool for the modeling and simulation of antenna
systems and radiating structures in general.

AN-SOF is intended for solving problems in the following areas:

* Modeling and design of wire antennas.

o Antennas above a lossy ground plane.

e Broadcast antennas over radial wire ground screens.

o Single layer microstrip patch antennas.

o Radiated emissions from printed circuit boards (PCBs).

o Electromagnetic Compatibility (EMC) applications.

» Passive circuits, transmission lines, and non-radiating networks.

AN-SOF is based on an improved version of the so-called Method of Moments (MoM) for
wire structures. Metallic objects like antennas can be modeled by a set of conductive wires
and wire grids, as it is illustrated in Fig. 1. In the MoM formulation, the wires composing the
structure are divided into segments that must be short compared to the wavelength. If a
source is placed at a given location on the structure, an electric current will be forced to flow
on the segments. The induced current on each individual segment is the first quantity
calculated by AN-SOF.

Once the current distribution has been obtained, the radiated electromagnetic field can be
computed in the far- and near-field zones. Input parameters at the position of the source or
generator can also be obtained, such as the input impedance, input power, standing wave
ratio (SWR), reflection coefficient, transmission loss, etc.
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The modeling of the structure can be performed by means of the AN-SOF specific 3D CAD
interface. Electromagnetic fields, currents, voltages, input impedances, consumed and
radiated powers, directivity, gain and many more parameters can be computed in a
frequency sweep and plotted in 2D and 3D graphical representations.

Fig. 1: Antennas modeled by means of wires and wire grids.

In the case of curved antennas like loops, helices, and spirals, the MoM in AN-SOF has been
improved to accurately account for the wire’s exact curvature. Traditional calculations often
use straight-line segments to approximate curved antennas, resulting in many discontinuous
wire junctions. This linear approximation can be inefficient in terms of computer memory and
the number of calculations required, as it necessitates multiple straight segments to mimic
the smooth curvature of wires. To address this issue, AN-SOF uses curved segments that
precisely follow the contours of curved antennas. This innovative technique is known as the
Conformal Method of Moments (CMoM).

As an example, Fig. 2 shows the different approaches to a circular disc obtained by means
of the MoM and CMoM methods. Both methods are available in AN-SOF since the MoM is a
special case of the more general CMoM.
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MoM CMoM

Fig. 2: Modeling of a disc by means of the MoM and CMoM methods.

In addition to the CMoM capabilities, advanced mathematical techniques have been
implemented in the calculation engine making possible simulations from extremely low
frequencies (e.g., electric circuits at 50-60 Hz) to very high ones (e.g., microwave antennas
above 1 GHz).

In what follows, a summary of the modeling options and the simulation results that can be
obtained from AN-SOF is presented.

Modeling of Metallic Structures

Metallic structures can be modeled by combining different types of wires, grids, and
surfaces:

Wires
Wire Grids and Solid Surfaces

1. All types of curved wires can be modeled by means of arced or quadratic segments.

2. Wire grids and solid surfaces can be defined using either curved or straight wire
segments. Curved segments follow the exact curvature of discs, rings, cones,
cylinders, spheres, and parabolic surfaces. Grids are composed of cylindrical wires
that leave holes between them, while solid surfaces are composed of flat wires or
strips that cover the surface without leaving holes between them.

. Tapered wires with stepped radii can be defined.

. All wires can be loaded or excited at any segment.

. The structure can also have finite non-zero resistivities (skin effect).

. Electrical connections of different wires and connections of several wires at one point
are possible.

7. Metallic wires in either dielectric or magnetic media can be analyzed.

o O~ W
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8. Wires with insulation can be modeled. Dielectric and magnetic coatings are available.
9. The structures can be placed in free space, over a perfectly conducting ground
plane or over an imperfect ground plane.

10. Flat strip lines can be defined on a dielectric substrate for modeling planar antennas
and printed circuit boards (PCB).

11. Vias in microstrip antennas and printed circuit boards can also be modeled.

12. The wire cross-section can either be Circular, Square, Flat, Elliptical, Rectangular or
Triangular.

13. Transmission lines can be connected to the metal structure. There are over 160 cable
models available, including two-wire and coaxial cables, with characteristic impedance,
velocity factor, and loss parameters adjusted to actual datasheets.

14. The geometry modeling can be performed in suitable unit systems (um, cm, mm, m,
in, ft). Different unit systems can also be chosen for inductance (pH, nH, uH, mH, H)
and capacitance (pF, nF, uF, mF, F).

Excitation Methods

1. Voltage sources can be placed on the wires, as many as there are segments, with
equal or different amplitudes (RMS values) and phases.

2. Current sources (e.g., representing impressed currents) can also be arranged at any
segments.

3. The voltage and current sources can have internal impedances.

4. An incident plane wave of arbitrary polarization (linear, circular, or elliptical) and
direction of incidence can also be used as the excitation.

5. Hertzian electric and magnetic dipoles can also be modeled and used as the
excitation.

6. The antenna input power can be set to obtain the results (current distribution, near
and far fields) scaled accordingly.

Frequency options

1. The simulation can either be performed for a single frequency, for frequencies taken
from a list or for a frequency sweep.

2. The list of frequencies can either be created inside the program or loaded from a text
file. It can also be saved to a txt file.

3. Linear and logarithmic frequency sweeps are possible.

4. A suitable unit system can be selected (Hz, KHz, MHz, GHz).

Data Input

1. 3D CAD tools are implemented for drawing and modifying the structure geometry,
including wires, grids, surfaces, discrete generators, and lumped loads.
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10.

. The segmentation of wire geometry can be done automatically or manually.
. Left-clicking on a wire selects and highlights it. Right-clicking on a wire reveals a pop-

up menu with various options.

. Wire connections are easily established by copying and pasting the endpoints of

wires.

. Special 3D symbols indicate the positions of sources, load elements, and ground

points.

. All dialog boxes validate inputs for accuracy.
. The program includes mouse-supported functions for rotating, moving, and zooming.
. Transmission lines can be easily entered into a table, which serves as a library, for

later use. A line is highlighted in the graphical interface for easy identification.

. The program allows you to import geometrical data from text files. It supports three

different file formats for importing wires, including the NEC (Numerical
Electromagnetics Code) cards. Additionally, it can import DXF files containing 3D
LINE entities.

The AN-SOF architecture integrates powerful numerical methods to achieve the
fastest calculation speed and the most accurate results.

Data Output

. All computed data is stored in files for subsequent graphical analysis.
. Input impedances, currents, voltages, VSWR, S44, return and transmission losses,

radiated and consumed powers, efficiency, directivity, gain, and other system
responses are presented as lists in text format and can be plotted against frequency. A
Smith chart is available to represent impedances and admittances, as well as to
display the reflection coefficient and VSWR at the selected point on the graph.

. The current distribution on a selected wire can be plotted in amplitude, phase, real,

and imaginary parts against position in a 2D representation. The currents flowing on a
structure can also be plotted as a color map on the wires.

. Radiation and scattering fields are obtained, including power density, directivity and

gain patterns, total electric field, linearly and circularly polarized components, axial
ratio, and Radar Cross Section (RCS). The surface-wave field can be determined as
a function of distance in the case of a real ground with finite conductivity.

. Near-field components can be calculated in Cartesian, cylindrical, and spherical

coordinates. Field intensities can be plotted in 2D and 3D graphical representations
and visualized as color maps in the proximity of a structure.

. A 2D representation of radiated fields is available in Cartesian and polar coordinates.

The ARRL-style log scale can be applied to polar diagrams.
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7.

10.

11

12.

13.

14.

3D radiation patterns can be viewed from arbitrary angles with zoom functions,
colored mesh and surface representations, and a color bar scale. 3D patterns can be
plotted with specially designed lighting and illumination for enhanced visualization of
simulation results.

. Far-field patterns can be separated into theta (vertical) and phi (horizontal) linearly

polarized components, as well as right and left circularly polarized components. The
axial ratio and the front-to-rear and front-to-back ratios are shown in polar plots and
can be displayed as a function of frequency.

. The frequency spectrum of near- and far-fields can be visualized in a 2D

representation for all field components across different frequencies.
An average radiated power test, also known as AGT (Average Gain Test), is
conducted to verify the accuracy of the simulation.

. The calculated data can be exported to .csv, .dat, or .txt files for use in other software

programs.

An embedded transmission line calculator is included to simplify the design of feed
lines for transmitting antennas. Actual cable part numbers can be selected from a wide
range of manufacturers, thanks to data extracted from cable datasheets and integrated
into the calculator.

A Bulk Simulation feature enables the automated calculation of multiple files, each
with different geometric descriptions, to obtain results based on variable geometric
parameters. The results are automatically exported to .csv files for further processing.
You can choose suitable unit systems for the plotted results, including current scaling
(KA, A, mA, uA), voltage scaling (KV, V, mV, uV), electric field scaling (KV/m, V/m,
mV/m, uV/m), magnetic field scaling (KA/m, A/m, mA/m, uA/m), decibel scales, and
more.

Integrated graphical tools

AN-SOF has a suite of integrated graphical tools for the convenient visualization of the
simulation results. The following applications are installed automatically and used by the
main program, AN-SOF:

AN-XY Chart app
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A friendly 2D chart for plotting two related quantities, Y versus X. Use AN-XY Chart to plot
parameters that depend on frequency, such as currents, voltages, impedances, reflection
coefficient, VSWR, S14, radiated power, consumed power, directivity, gain, radiation
efficiency, radar cross section, field components, axial ratio, and many more. Also plot the
current distribution along wires as a function of position, 2D slices of radiation lobes and near
fields as a function of distance from an antenna. Choose different units to display results and
use the mouse to easily zoom and scroll graphs.
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AN-Smith app

Plot impedance or admittance curves on the Smith chart with this tool. Just click on the
graph to get the frequency, impedance, reflection coefficient, VSWR, and S44 that
correspond to each point on the curve. Plots can be stored in independent files and opened
later for a graphical analysis with AN-Smith.
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AN-Polar app

Plot on a polar diagram the radiation pattern versus the azimuth (horizontal) or zenith
(vertical) angles. The maximum, -3dB and minimum radiation levels are shown within the
chart as well as the beamwidth and front-to-rear/back ratio. Click on the graph to quickly
obtain the values of the radiated field. The represented quantities include power density,
directivity, gain, normalized radiation pattern, total electric field, linearly and circularly
polarized components, axial ratio, and radar cross section (RCS).
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AN-3D Pattern app

Get a complete view of the radiation properties of a structure by plotting a 3D radiation
pattern. AN-3D Pattern implements colored mesh and surface for the clear visualization of
radiation lobes, including a color bar-scale indicating the field intensities over the lobes.
Quickly rotate, move, and zoom the graph using the mouse. The 3D radiation pattern can be
superimposed to the structure geometry to gain more insight into the directional properties of
antennas.

The represented quantities include the power density, normalized radiation pattern,
directivity, gain, total field, linearly and circularly polarized components, axial ratio, and
Radar Cross Section (RCS). Choose between linear or decibel scales. Display near fields
as color maps in the proximity of antennas in three different representations: Cartesian,
cylindrical and spherical plots. Also plot the current distribution on the structure as a
colored intensity map.
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The AN-SOF Interface

Main Window and Menu

When AN-SOF is started, the initial screen contains the following components:

Title bar ~—

. B 4N-50F - Moxon-Yagi-UHF - a *
Mainmenu — L. i oaw View Tools FRun Results  Help
Toolbar —— = = o ¢ OO N & &y ;| § W | X¥ yI oI¥ ' P b b | 2 » i E L]

Setup Workspate  Feedlne Resits  Fiots

Tab sheets -

Workspace —

Status bar _..‘_'.'.lrc; 13 Sources: 1 Loads 0

Segments 121 Connections: & GNDs: 0 Total: 127

Fig. 1: The AN-SOF interface.

The title bar contains the name of the currently active project (.emm file).
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The main menu bar contains the File, Edit, Draw, View, Tools, Run, Results, and Help
menus.

The main toolbar contains icons that represent commands.
The tab sheets allow us to quickly switch between pages, from Setup to Plots.
The workspace is the page where the wire structure can be drawn in a 3D space.

The status bar contains information about the number of segments, connections, and
ground points.

File Menu

Use the File menu to open, save, close, and print new or existing projects. This menu has
the following commands:

New... (Ctrl + N)

Creates a new project.

Open... (Ctrl + O)

Displays the Open dialog box for opening an existing project (.emm file).
Save (Ctrl + S)

Saves the currently active project using its current name.

Save As...

Saves the currently active project using a new name. Also saves a new project using a name
specified by the user.

Import Wires

Displays the Import dialog box for importing a list of wires in either AN-SOF (.wre files), NEC,
DXF (CAD files) or MM format.

Export Wires
Displays the Export dialog box for exporting wires to a NEC or DXF file.
Copy Workspace

Sends the project workspace to the clipboard as a bitmap image.
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Print... (Ctrl + P)
Sends the project workspace to the printer.

Exit (Ctrl + Q) Closes the project that is open and then exits AN-SOF.

Edit Menu

Use the Edit menu commands to edit and handle wires and wire grids. This menu has the
following commands:

Undo (Ctrl + 2)
Returns the project to the status before a command was executed.
Source/Load (Ctrl + Ins)

Displays the Source/Load toolbar for exciting or loading the selected wire. This command is
enabled when a wire is selected.

Modify (Ctrl + M)

Displays the Modify dialog box for modifying the selected wire or wire grid. This command is
enabled when a wire or wire grid is selected.

Wire Color

Displays a Windows(R) dialog box for changing the color of the selected wires. This
command is enabled when a wire or group of wires is selected.

Delete (Ctrl + Del)

Deletes the selected wire, wire grid or group of wires with all sources and loads placed on it.
This command is enabled when a wire, wire grid or group of wires is selected.

Copy Start Point

Copies the starting point of the selected wire. This point can then be used as the starting
point of a second wire, which will be connected to the first one. This command is enabled
when a wire is selected.

Copy End Point

Copies the ending point of the selected wire. This point can then be used as the starting
point of a second wire, which will be connected to the first one. This command is enabled
when a wire is selected.
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Start Point to GND

Draws a vertical wire between the start point of the selected wire and the ground plane. This
command is shown when a ground plane is included in the model, and it is enabled when a
wire is selected.

End Point to GND

Draws a vertical wire between the end point of the selected wire and the ground plane. This
command is shown when a ground plane is included in the model, and it is enabled when a
wire is selected.

Copy Wires

Displays the Copy Wires dialog box for copying the selected wire or group of wires. The
copied wires can then be pasted in a different position. This command is enabled when a
wire or group of wires is selected.

Move Wires

Displays the Move Wires dialog box for moving the selected wire or group of wires to a
different position. This command is enabled when a wire or group of wires is selected.

Rotate Wires

Displays the Rotate Wires dialog box for rotating the selected wire or group of wires around
the chosen axis. This command is enabled when a wire or group of wires is selected.

Scale Wires

Displays the Scale Wires dialog box for scaling the selected wire or group of wires according
to the specified scale factor. This command is enabled when a wire or group of wires is
selected.

Stack Wires

Displays the Stack Wires dialog box for stacking the selected wire or group of wires along
the specified direction and according to the given number of wires in the stack. This
command is enabled when a wire or group of wires is selected.

Draw Menu

Use the Draw menu commands to create and draw wires and wire grids. This menu has the
following commands:
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Line

Opens the Line dialog box for drawing a line or straight wire.

Arc

Opens the Arc dialog box for drawing an arc.

Circle

Opens the Circle dialog box for drawing a circle or circular loop.

Helix

Opens the Helix dialog box for drawing a helix or helical wire.
Quadratic

Opens the Quadratic dialog box for drawing a quadratic wire.
Archimedean Spiral

Opens the Archimedean Spiral dialog box for drawing an Archimedean spiral.
Logarithmic Spiral

Opens the Logarithmic Spiral dialog box for drawing a logarithmic spiral.
Wire Grid

Creates a new wire grid in the workspace. This option has a sub-menu with the following
commands:

» Patch: Opens the Draw dialog box for drawing a rectangular grid on the xy-plane.

» Plate: Opens the Draw dialog box for drawing a plate or bilinear surface.

e Disc: Opens the Draw dialog box for drawing a disc.

* Flat Ring: Opens the Draw dialog box for drawing a flat ring or a disc with a hole at its
center.

e Cone: Opens the Draw dialog box for drawing a cone.

e Truncated Cone: Opens the Draw dialog box for drawing a truncated cone.

e Cylinder: Opens the Draw dialog box for drawing a cylinder.

» Sphere: Opens the Draw dialog box for drawing a sphere.

o Paraboloid: Opens the Draw dialog box for drawing a parabolic surface.

Tapered Wire
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Creates a new tapered wire in workspace. This option has a sub-menu with the same
commands as the wire options described above, but each wire can have a stepped radius
along its length.

Tabular Input (Ctrl + T)

Opens a table to enter linear wires, sources and loads in spreadsheet format.

View Menu

Use the View menu commands to display or hide different elements of the AN-SOF interface,
zoom the wire structure, and view additional information about the project and wires. This
menu has the following commands:

Wire Properties... (Ctrl + W)

Displays the Wire Properties dialog box for viewing information about the selected wire. This
command is enabled when a wire is selected.

Project Details...

Displays the Project Details dialog box for viewing information about the project that is open.
Zoom In (Ctrl + 1)

Increases the size of the view in the workspace (also roll the mouse wheel to zoom).

Zoom Out (Ctrl + K)

Decreases the size of the view in the workspace (also roll the mouse wheel to zoom).

Reset Zoom Scale

Resets the zoom and resizes the view of the structure in the workspace.

Axes (Ctrl + A)

Displays the Axes dialog box for changing the appearance of the axes in the workspace.
Press F7 to switch between small and main axes.

X-Y Plane / Y-Z Plane / Z-X Plane
Shows a view of the xy-plane/ yz-plane/ zx-plane parallel to the screen.

Center
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Centers the view of the structure in the workspace (double click on the workspace to center
the view).

Initial View (Home)
Returns the workspace to the initial view.
Drawing Panel

Displays a panel to the left of the workspace that contains buttons for quicker access to
commands for drawing wires and wire grids.

Tools Menu

Use the Tools menu commands to display 3D, polar, rectangular, and Smith charts and to
check the wires. This menu has the following commands:

3D Chart

Executes the AN-3D Pattern application for opening 3D plot files (.p3d).
Polar Chart

Executes the AN-Polar application for opening polar plot files (.plr).
Rectangular Chart

Executes the AN-XY Chart application for opening rectangular plot files (.plt).
Smith Chart

Executes the AN-Smith application for opening Smith chart files (.sth).
Check Individual Wires

Checks the segment length, cross-section size and thin-wire ratio of each wire. Wires in
warning/error will be highlighted in yellow/red.

Check Wire Spacing

Checks the spacing between wires. Wires in warning/error will be highlighted in yellow/red.
Delete Duplicate Wires

Deletes duplicate or overlapping wires.

Calculator
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Executes the Microsoft Windows(R) Calculator application.
Preferences

Displays the Preferences dialog box for setting up the preferred options for unit systems,
workspace color, pen width, confirmation questions, etc.

Run Menu

Use the Run menu commands to run the calculations. This menu has the following
commands:

Run ALL (F10)

Runs the calculation of the current distribution, far- and near-fields.

Run Currents and Far-Field (F11)

Runs the calculation of the current distribution and far-fields.

Run Currents and Near-Field (F12)

Runs the calculation of the current distribution and near electric and magnetic fields.
Run Currents

Runs the calculation of the current distribution on the wire structure. This command is
disabled when the currents are already computed.

Run Far-Field

Runs the calculation of the far-field generated by the currents flowing on the wire structure.
This command is enabled when the currents are already computed.

Run Near E-Field

Runs the calculation of the near electric field generated by the currents flowing on the wire
structure. This command is enabled when the currents are already computed.

Run Near H-Field

Runs the calculation of the near magnetic field generated by the currents flowing on the wire
structure. This command is enabled when the currents are already computed.
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Run Bulk Simulation Opens a dialog box for choosing multiple files in NEC format at the
same time. The file extension must be “.nec”. AN-SOF will import these input files and
compute the corresponding output results. The results will be saved as CSV files in the same
directory as the NEC input files.

Results Menu

Use the Results menu commands to visualize the results from a simulation. This menu has
the following commands:

Plot Current Distribution

Executes the AN-3D Pattern application for plotting the current distribution as a colored
pattern on the wire structure.

Plot Currents

Executes the AN-XY Chart application for plotting the currents vs. position along the selected
wire. This command is enabled when a wire has been selected.

List Currents

Displays the List Currents toolbar for listing the currents vs. frequency at the chosen
segment on the selected wire. If the segment has a source on it, the list of input impedances,
voltages, and powers as a function of frequency can be shown. This command is enabled
when a wire has been selected.

List Input Impedances

Displays a table with the list of input impedances vs. frequency, including reflection
coefficient, VSWR, return loss and transmission loss at the antenna terminals.

Plot Far-Field Pattern
This option has a sub-menu with the following commands:

o 3D Plot: Executes the AN-3D Pattern application for plotting a 3D view of the radiation
patterns.

o Polar Plot 1 Slice: Displays the Radiation Pattern Cut dialog box for selecting a 2D
slice of the 3D far-field pattern. Then, the selected 2D pattern cut will be plotted in polar
coordinates by the AN-Polar application.

o Polar Plot 2 Slices: Displays a dialog box for selecting two slices of the 3D far-field
pattern. Then, the selected 2D patterns will be plotted in polar coordinates by the AN-
Polar application.
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» 2D Rectangular Plot: Displays the Radiation Pattern Cut dialog box for selecting a 2D
cut of the 3D far-field pattern. Then, the selected 2D pattern cut will be plotted in
rectangular coordinates by the AN-XY Chart application.

Plot Far-Field Spectrum

Displays the Select Far-Field Point dialog box for selecting a point in space where the far-
field components will be shown versus frequency. Then, the far-field spectrum will be plotted
in rectangular coordinates by the AN-XY Chart application.

List Far-Field Pattern

Displays a table showing the total E-field and its components (E-theta, E-phi, E-right, E-left)
at the grid of angles theta and phi specified in the Far-Field panel of the Setup tabsheet. This
table can be exported as a CSV file.

List Far-Field Spectrum

Displays the Select Far-Field Point dialog box for selecting a point in space where the far-
field components will be shown versus frequency. Then, this far-field spectrum will be listed
in a table with different columns for the total E-field and the field components: E-theta and E-
phi (spherical components) and the right and left polarized components.

Power Budget/RCS

Displays the Power Budget dialog box for listing the total input power, consumed and
radiated powers, power densities, efficiency, directivity and gain vs. frequency. In the case of
plane wave excitation, the Radar Cross Section (RCS) vs. frequency will be displayed.

Plot Near E-Field Pattern
This option has a sub-menu with the following commands:

« 3D Plot: Executes the AN-3D Pattern application for plotting a 3D view of the near
electric field components.

* 2D Plot: Displays the Near-Field Cut dialog box for selecting a 2D cut of the near
electric field pattern. Then, the selected 2D pattern cut will be plotted by the AN-XY
Chart application.

Plot Near E-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near electric
field components will be shown versus frequency. Then, this near-field spectrum will be
plotted in rectangular coordinates by the AN-XY Chart application.

https://antennasimulator.com/index.php/an-sof-user-guide/ 36/303



12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

List Near E-Field Pattern

Displays a table showing the total near E-field and its components at the grid of points
specified in the Near-Field panel of the Setup tabsheet. This table can be exported as a CSV
file.

List Near E-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near electric
field components will be shown versus frequency. Then, this near-field spectrum will be listed
in a table with different columns for the field components.

Plot Near H-Field Pattern
This option has a sub-menu with the following commands:

o 3D Plot: Executes the AN-3D Pattern application for plotting a 3D view of the near
magnetic field components.

e 2D Plot: Displays the Near-Field Cut dialog box for selecting a 2D cut of the near
magnetic field pattern. Then, the selected 2D pattern cut will be plotted by the AN-XY
Chart application.

Plot Near H-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near magnetic
field components will be shown versus frequency. Then, the near-field spectrum will be
plotted in rectangular coordinates by the AN-XY Chart application.

List Near H-Field Pattern

Displays a table showing the total near H-field and its components at the grid of points
specified in the Near-Field panel of the Setup tabsheet. This table can be exported as a CSV
file.

List Near H-Field Spectrum

Displays the Select Near-Field Point dialog box for selecting a point where the near magnetic
field components will be shown versus frequency. Then, the near-field spectrum will be listed
in a table with different columns for the field components.

Help Menu

Use the Help menu to access the user guide, request technical support, activate a license, or
view the version of AN-SOF. This menu has the following commands:
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User Guide

Displays the AN-SOF user guide in PDF format.

AN-SOF Home Page

Goes to the AN-SOF web page at www.antennasimulator.com in the default web browser.
Knowledge Base

Goes to the knowledge base > where you can search for categorized information.

Email to Tech Support

Executes the default e-mail client to send a technical support request to
info@antennasimulator.com.

Chat to Tech Support

Goes to the live chat page in the default web browser.

Activation Key

Executes the AN-Key application to activate a license.

Check for Updates

Goes to the website where the latest AN-SOF releases > are posted.
About AN-SOF

Shows copyright and version information.

Main Toolbar

The main toolbar has the following icons and associated commands:

DNEH|COZ2RXK| @8 A|kiINGAGGE| A wvzox|B@ld b o |ZikwdgEL S
Fig. 2: Main Toolbar.

New (Ctrl + N)
Creates a new project.
Open (Ctrl + O)

Displays the Open dialog box to open an existing project (.emm file).
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Save (Ctrl + S)

Saves the currently active project using its current name.

Undo (Ctrl + 2)

Returns the project to the status before a command was executed.
Source/Load (Ctrl + Ins)

Displays the Source/Load toolbar for adding a source or load to the selected wire. This
command is enabled when a wire has been selected.

Modify (Ctrl + M)

Displays the Modify dialog box for modifying the selected wire or group of wires. This
command is enabled when a wire or group of wires has been selected.

Wire color

Displays a Windows(R) dialog box for changing the color of the selected wire or group of
wires. This command is enabled when a wire or group of wires has been selected.

Delete (Ctrl + Del)

Deletes the selected wire, wire grid or group of wires with all sources and loads placed on it.
This command is enabled when a wire, wire grid or group of wires has been selected.

Preferences

Displays the Preferences dialog box for setting up the preferred options for unit systems,
workspace color, pen width, confirmation questions, etc.

Wire Properties (Ctrl + W)

Displays the Wire Properties dialog box for viewing information about the selected wire. This
command is enabled when a wire has been selected.

Project Details

Displays the Project Details dialog box for viewing information about the currently active
project.

Select Wire

Enables the selection mode where a wire can be selected individually by left clicking on it.
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Selection Box

Enables the selection mode where a group of wires can be selected expanding a box with
the mouse (left mouse button pressed).

Draw Line

Enables the drawing mode where a line can be dragged with the mouse (left mouse button
pressed). This mode is enabled when the X-Y, Y-Z or Z-X view has been chosen. The
coordinates of the starting and ending points of the line will be shown in the status bar.

Rotate around X/Y/Z/3D

Enables the 3D rotation of the view or around the x/y/z-axis by moving the mouse.
Move

Enables the movement of the view by moving the mouse (left mouse button pressed).
Zoom

This allows you to expand a rectangle and select the area of the screen you wish to zoom in
on. Additionally, you can use the mouse wheel to adjust the zoom level of the view.

X-Y /Y-Z | Z-X Plane

Shows a view of the xy/yz/zx-plane parallel to the screen.
Center

Centers the view of the structure on the workspace.

Initial View (Home)

Returns the workspace to the initial view.

Run ALL (F10)

Runs the calculation of the current distribution, far- and near-fields.
Run Currents and Far-Field (F11)

Runs the calculation of the current distribution and far-fields.
Run Currents and Near-Field (F12)

Runs the calculation of the current distribution and near-fields.
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List Input Impedances

Shows a table with the input impedances vs. frequency. Reflection coefficient, VSWR, return
and transmission losses at the antenna terminals are also tabulated.

Plot Current Distribution

Executes the AN-3D Pattern application for plotting the current distribution as a colored
pattern on the wire structure.

Far-Field 3D Plot
Executes the AN-3D Pattern application for plotting a 3D view of the radiation pattern.
Far-Field Polar 1 Slice

Displays the Radiation Pattern Cut dialog box for selecting a 2D cut of the 3D far-field
pattern. Then, the selected 2D pattern cut will be plotted in a polar chart by the AN-Polar
application.

Far-Field Polar 2 Slices

Displays a dialog box for selecting two slices of the 3D far-field pattern. Then, the selected
2D patterns will be plotted in a polar chart by the AN-Polar application.

Far-Field 2D Plot

Displays the Radiation Pattern Cut dialog box for selecting a 2D cut of the 3D far-field
pattern. Then, the selected 2D pattern cut will be plotted in rectangular coordinates by the
AN-XY Chart application.

Export Results
Opens a dialog box to save the results displayed in the “Results” tab as a CSV file.
User Guide

Opens the user guide file in PDF format.
Custom Preferences

Preferences

Preferences in AN-SOF allow users to customize the unit system for input and output data,
adjust the workspace appearance, and configure various miscellaneous options. To access
preferences, navigate to Tools > Preferences from the main menu.
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Units

On the Units page of the Preferences dialog box (see Fig. 1), users can select suitable units
for frequencies, lengths, wire cross-section, inductances, and capacitances. Apart from
standard Sl units, options such as inches (in) and feet (ft) are available for lengths and
cross-sections.

Preferences

Units  wWorkspace — Options

Frequency

(OHz (O kHz (®) MHz (O GHz

Length

Cum Omm Olem @®m Oin (Oft

Cross-Section

Cum @®mm Oeom Om Oin (Oft

Inductance

pH OrH ®uwH OmH (OH

Capacitance

@pF OnF  Ou  OmF  OF

QK Cancel

Fig. 1: Units tab in the Preferences dialog box
where frequencies, lengths, wire cross-sections,
inductances, and capacitances can be set.

Workspace

In the Workspace tab (Fig. 2), users can toggle the workspace background color between
black and white. Additionally, there are three levels for the pen width used to draw objects on
the workspace: Thin, Medium, and Thick. This option applies to axes, wires, and wire grids.
Users can also customize the size and color of source symbols and loads. Enabling the
Show Segments option displays the segments in the workspace.
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Preferences

Sources

Units ~Workspace  Options

Background Calar

(®) Black i white

Pen Width

) Thin (®) Medium () Thick

Source Size %o Source Color Load Color

CHI =

[ Loads [ Segments

[ ] show Segments

oK Cancel

Fig. 2:

Preferences dialog box showing the

Workspace tab, where the workspace background
color, pen width, and appearance of sources/loads

Options

can be set.

In the Options tab, users can check the Show Main Toolbar option to display the toolbar
(Fig. 3). Two “Ask before...” questions can be set to avoid mistakes. If the option “Run ALL”
also calculates the H-Field is checked, the near H-field will be calculated after clicking on
the “Run ALL” button. Users can also choose to close the chart windows after exiting AN-
SOF. Additionally, the option “The comma is set as the decimal symbol” should be
selected if the comma is used as the decimal separator in the Windows® regional settings.
Users can also set the number of significant digits shown in results, although this option

does not modify the double precision used in the internal algorithms.
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Preferences

Units  Workspace — Options

Show Main Toolbar

[] sk before deleting wires

[ ] Ask before aborting simulation

"Run ALL" also calculates the H-Field
Close charts when exiting AN-S0F

[ ] The comma is set as the decimal symbal

Significant digits in Results EI =

oK Cancel

Fig. 3: Options tab in the Preferences dialog box,
where various additional settings can be
configured.

Note

All preferences can be configured at any time, either before or after performing a
calculation.
Tools in the Workspace

Display Options

The background of the workspace can be white or black. When a white (black) background
is chosen, all wires will default to black (white) unless a different color is specified for certain
wires. The workspace color can be set by going to Tools > Preferences > Workspace tab.
The color of selected wires and wire grids can be changed at any time via Edit > Wire Color
in the main menu.

The width of the line used for drawing wires and axes in the workspace can be changed by
selecting a Pen Width option in the Workspace tab of the Preferences dialog box. There are
three levels: Thin, Medium, and Thick. Figure 1 illustrates the different combinations between
the workspace color and pen width that can be obtained.
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Fig. 1: Display options in the workspace.

Viewing 3D Axes

To change the appearance of the X, Y, Z axes in the workspace go to View > Axes (Ctrl + A)
in the main menu to display the Axes dialog box, Fig. 2. There are two types of axes, the
Small Axes, and the Main Axes. The small axes are displayed in the lower left corner of the
workspace, while the main axes are displayed in the center of the screen.

Both positive and negative axes can be displayed. The color of the main axes can be
changed by pressing the Color button.

Check the Show Ticks option to add the specified number of ticks to the Main Axes.
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Small Axes @ Main Axes

Show

VIX+ VY+

Fig. 2: Axes dialog box. Positive and negative axes
can be displayed.

Tip
Press F7 to switch between small and main axes.

Zooming the View

To zoom in or out the view of the structure in the workspace, move the mouse wheel. If you
are using a laptop touchpad, you can also use two fingers, just like when zooming an image.
Alternatively, you can utilize the Zoom In (Ctrl + I) and Zoom Out (Ctrl + K) commands
from the View menu.

For a more specific zoom on a particular area of the screen, click on the Zoom button on
the toolbar and then select the desired area by expanding a rectangle. To return to the initial
view, simply click the Initial View (Home) button on the toolbar.

Rotating the View

To rotate the view of the structure around the desired axis, first press one of these buttons on
the toolbar: Rotate around X, Rotate around Y, Rotate around Z, or 3D Rotation.

Then, move the mouse over the screen with the left button pressed.

The view can also be rotated by pressing the following keys:
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F1: Right-handed rotation around the x-axis.
F2: Left-handed rotation around the x-axis.
F3: Right-handed rotation around the y-axis.
F4: Left-handed rotation around the y-axis.
F5: Right-handed rotation around the z-axis.

F6: Left-handed rotation around the z-axis.

Moving the View

The view of the structure can be moved in the workspace. First press the Move button on
the toolbar and then move the mouse over the screen with the left button pressed.

Tip

Double-click on the workspace to center the view of the structure on the screen.
The Conformal Method of Moments

Introduction

The Method of Moments (MoM) is widely recognized as one of the most reliable techniques
for modeling and simulating antennas and radiating systems. However, traditional
implementations of MoM suffer from several issues primarily stemming from
approximations used in numerical calculations to reduce computational requirements.
While these approximations were justified in the 1970s and 1980s due to limited processor
speeds and memory capacities, the present-day computing power, even on personal
computers, allows for more accurate calculations. The limitations imposed by these
approximations in traditional MoM models restrict their validity and applicability.

The fundamental principle of MoM involves representing metal surfaces through wire
segments, which is a suitable approximation for many metallic antennas, particularly wire-
type antennas like linear antennas, dipoles, monopoles, yagis, log-periodic arrays, quads,
antenna arrays of all types, traveling wave antennas, fractals, aperture antennas, and
reflectors. It is essential for each wire segment to have a small length and cross-section
relative to the wavelength. The MoM seeks to determine the unknown current flowing
through each wire segment, as depicted in Fig. 1.
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Fig. 1: In the traditional Method of Moments (MoM), linear approximation is applied to the structure’s
geometry using straight segments. The MoM enables the conversion of Maxwell’s equations from their
integral form into a matrix equation, which in turn allows for the determination of currents in the segments.

The Thin-Wire Approximation

In the modeling of antennas using cylindrical wire segments, the initial approximation
commonly employed is known as the “thin-wire approximation,” as illustrated in Fig. 2. This
approximation is based on the following assumptions:

1. The electric current flowing through a wire can be represented as a filament along the
wire axis, disregarding the fact that it actually flows on the wire’s surface.

2. Variations in the current along the circular contour of the wire’s cross-section can be
ignored.

3. The component of the current perpendicular to the wire axis can be disregarded.

4. It is sufficient to enforce the boundary condition of zero total tangential electric field
on the surface of an ideal conducting wire along its axis.

L<<A

I, (average) \
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I, <<
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Fig. 2: lllustration of the thin-wire approximation for a wire segment in the Method of Moments.

When dealing with a wire segment with a cross-section significantly smaller than the
wavelength, assumptions 2, 3, and 4 are reasonably valid and align with experimental
observations and theoretical predictions in the quasi-electrostatic regime for metal surfaces.
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However, assumption 1, regarding the current filament along the wire axis, has sparked
debates throughout the history of linear antennas.

Assumption 1 only holds as a limiting case when the wire’s cross-section approaches zero
size, such as when the wire has a circular cross-section and its radius tends to zero. This
assumption relates to the crucial aspect known as the Kernel of the problem. The Kernel
represents the core of the integral equation that the MoM solves to determine the currents
flowing along the wires. Instead of employing the “thin-wire Kernel” utilized in traditional
MoM, which is based on assumption 1, AN-SOF employs the exact Kernel. In the exact
Kernel, it is considered that the current flows on the surface of the wires rather than being
confined to a filament along the wire axis.

Eliminating assumption 1 has a significant impact on the accuracy of calculations,
particularly in the current distribution near the antenna’s feed point or terminals, where
obtaining precise values for input impedance and standing wave ratio (SWR) is crucial. In
addition to discarding assumption 1 in AN-SOF, the use of the exact Kernel and curved wire
segments helps overcome other issues inherent in traditional MoM, as described below.

Overcoming the 7 Limitations of the Traditional MoM

In AN-SOF, we have departed from the traditional MoM and embraced innovation by
implementing a new method called the Conformal Method of Moments (CMoM) with an
exact Kernel formulation. This decision stems from the lack of substantial improvements in
traditional methods over several decades, despite advancements in computational power. By
adopting CMoM with an exact Kernel, we have successfully addressed the main limitations
of the traditional MoM, which can be categorized into seven key areas:

1. No curved wires:

Traditional MoM models rely on straight wire segments, which are suitable for linear
antennas such as dipoles and their arrays. However, many antennas and structures have
curved shapes. In traditional MoM, curved wires are approximated using a series of
straight-line segments, leading to modeling errors that persist throughout the simulation. This
approximation often produces inaccurate results for curved antennas like loops, helices, and
spirals, particularly in terms of feed point impedances.
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2. Wire spacing limitation:

Another limitation of traditional MoM is the spacing between parallel wires. Misleading
results occur when the spacing between segments is less than a quarter of the segment
length. As a result, the traditional MoM becomes less applicable when modeling
configurations with close parallel wires, such as in two-wire transmission lines.

AL

A
L J

< AL/4

3. Issues with bent wires:

The thin-wire Kernel employed in traditional MoM leads to erratic numerical oscillations when
wires are bent at right angles or have angles less than 30 degrees between adjacent
segments.

90° x

< 30°

4. Short segment constraint:

Traditional MoM imposes a constraint on the segment length, requiring it to be greater than
0.001 of a wavelength. Consequently, the traditional MoM cannot be effectively applied at
very low frequencies. For instance, when modeling an electric circuit of around 1 meter
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operating at 60 Hz, the segment length needed to accurately represent the circuit becomes
at least 5,000 times shorter than the minimum segment length supported by traditional MoM.
Therefore, the traditional MoM implementation falls short when modeling wire antennas at
low frequencies.

AL <0.001A

o)

Thick wires deviate from the thin-wire approximation assumption, where current flow is
limited to the wire axis rather than its surface. This deviation introduces significant errors in
the results.

F 3
A J

5. Thin wire requirement:

AL < 2a

X

F 3
L J

a=01\
—f

6. Tapered wire issues:

Changes in radius between adjacent segments create non-physical discontinuities in

traditional MoM simulations.

7. Proximity to lossy ground plane affects horizontal wires:

Antennas such as monopoles positioned above ground screens with elevated radial wires
exhibit diverging input impedance and inaccurate antenna efficiency due to the influence of
the lossy ground plane.
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Thanks to the Conformal Method of Moments (CMoM) with Exact Kernel, AN-SOF has
successfully eliminated these limitations. CMoM employs conformal segments that
accurately capture the structure’s contour, enabling an exact representation of geometric
details. Conformal segments, resembling curved cylindrical tubes, enable precise modeling
of curved wires. By employing the exact Kernel instead of the thin-wire approximation, AN-
SOF overcomes limitations associated with bent wires, small wire spacings, and segment
lengths. This approach facilitates highly accurate calculations compared to the traditional

method.
Conformal vs. Traditional Method of Moments ﬂ\""
Conformal MoM Traditional MoM
21 21 —jkR —jk.
Exact Kernel K(s,s') = %L JO e de'de % Thin-Wire Kernel K(s,s") = ¢ ; )
Curved segments ¥ Straight segments

With the implementation of CMoM and an exact Kernel formulation, AN-SOF achieves
enhanced accuracy, reduced computational requirements, and more efficient
simulations. The improved method enables AN-SOF to simulate a wide frequency range,
spanning from extremely low frequencies (e.g., 60 Hz circuits) to microwave antennas.
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AN-SOF stands as the only antenna modeling software that offers a calculation engine
based on the Conformal Method of Moments with an Exact Kernel.

Simulation Setup

The Setup Tab

The simulation parameters can be set in the Setup tabsheet. This page has the following
panels: Frequency, Environment, Far-Field, Near-Field, Excitation, and Settings, Fig. 1.
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Fig. 1: Setup tab where the simulation parameters can be set.
In the Frequency panel >, the project operating frequencies can be specified.

In the Environment panel >, the relative permittivity and permeability of the
surrounding medium and the type of ground plane can be set.

In the Far-Field panel >, the angular ranges for the calculation of the far-field can be
set.

In the Near-Field panel >, the observation points for the calculation of the near-field
can be set.
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In the Excitation panel >, the type of excitation for the structure can be set. When
discrete sources are chosen as excitation, the total input power can be specified. When
an incident field is chosen as excitation, the incoming direction and polarization for the
incident wave can be specified.

In the Settings panel >, additional parameters can be set, such as the reference
impedance for VSWR and the accuracy of the calculations.

On the right side of the Setup page there is a Note panel to write notes associated to
the project. These notes will be saved in a text file in the same path as the project file
and with the same name as the project.

Specifying the Frequencies

Go to the Setup tab in the main window and select the Frequency panel.

The Frequency panel has three options: Single, List and Sweep. By choosing one of these
options the simulation can either be performed for a single frequency, for frequencies taken
from a list or for a frequency sweep.

If Single is chosen, enter the frequency in the Single Frequency box, as shown in Fig.
1. The wavelength will be shown below the frequency.

If List is chosen, write the list of frequencies in the Frequency List box, Fig. 2. Alist
from a text file can be read by pressing the Open button. The frequency list can also be
saved to a text file by pressing the Save button.

If Sweep is selected, it can either be linear or logarithmic. For a linear sweep the start,
step and stop frequencies must be set, Fig. 3. For a logarithmic frequency sweep the
start, stop and a multiplication factor must be set, Fig. 4.

The frequency unit can be changed going to Tools > Preferences in the main menu and
choosing a suitable unit in the Units page of the Preferences dialog box. Refer to
Preferences >.
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¥ Freguency
Options
(®) Single Single Frequency
300 MHz
() List
0.999303 m
Wawvel thi
) Sweep aveleng

Fig. 1: Frequency panel in the Setup tabsheet. A single
frequency is set.

¥ Freguency
Options Frequency List [MHz]
) 100 -
) Single 200
300
400
Q) List 500
() Sweep Open l [ = J

Fig. 2: Frequency panel in the Setup tabsheet. A list of
frequencies is set.

¥ Frequency
Options Frequency Sweep
) single @ Lin Log
, Start 100 MHz
() List
Step 100 MHz
© sweep Stop 500 MHz

Fig. 3: Frequency panel in the Setup tabsheet. A linear
frequency sweep is set.
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¥ Frequency
Options Frequency Sweep
Single O Lin 9 Log
Start 10 MHz
List
X 2 Times
9) Sweep Stop 640 MHz

Fig. 4: Frequency panel in the Setup tabsheet. A logarithmic
frequency sweep is set.
Defining the Environment

Ground Plane Options

Navigate to the Setup tab in the main window and access the Environment panel. You can
adjust the relative permittivity and permeability of the surrounding medium within the
Medium box, as shown in Fig. 1.

There are four ground plane options available:

None

When the None ground plane is selected, the simulation will be conducted in free space,
with the relative permittivity and permeability values set in the Medium box (see Fig. 1).
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¥ Environment

Medium

Permittivity €_ [1 Permeabiity p, [1 |

Ground Plane

Type

(® None

() Perfect

(O Real

(O Ssubstrate

Fig. 1: Medium and Ground Plane boxes in the
Environment Panel. None ground plane is chosen
(free space).

Perfect

An infinitely large perfectly electrically conducting (PEC) ground plane will be
positioned at the specified height from the xy-plane (“Z Position” in Fig. 2). Consequently, the
ground plane will be parallel to the xy-plane. The “Z” position determines the height of the
ground plane above the xy-plane, with a negative Z indicating placement below the xy-plane.

When the Perfect option is selected, all wires must be positioned above the perfect
ground plane. In simpler terms, all wires must have a Z-coordinate greater than or equal to
the specified position. AN-SOF does not verify wires for potential crossings with the PEC
ground plane or for placement at the bottom of the plane. Additionally, it does not support
horizontal wires lying directly on the ground plane. However, it does allow for connections
to be established from wire ends to the ground plane.
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¥ Environment
Medium
Permittivity €, 1 Permeabiity 1, |1 |
Ground Plane
Type

() None

Position [m]

@ Perfect Z 0 |

(O Real

(O substrate

Fig. 2: A perfect ground plane is placed at Z = 0 (xy-
plane).

Real

A real ground plane, with user-defined conductivity and relative permittivity (relative
permeability set to 1), will be situated on the xy-plane at z = 0, as shown in Fig. 3. There are
three available options for real ground calculations: Sommerfeld-Wait/Asymptotic,
Reflection Coefficients/Asymptotic, and Radial wire ground screen.

All wires must be positioned above the ground plane (z = 0). Horizontal wires placed
directly on the ground plane are not supported. However, wire end connections to the ground
plane can be established when either the “Sommerfeld-Wait/Asymptotic” or “Radial wire
ground screen” options are selected.

The “Reflection Coefficients/Asymptotic” option exclusively permits connections to the
ground plane for vertical wires, resulting in perfect zero-Ohm connections. In cases involving
horizontal wires, they must be separated by at least one free space wavelength from the
ground plane. In such situations, it is essential to verify the validity of the results. AN-SOF
does not automatically verify whether these conditions are satisfied within a model.
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¥ Environment

Medium
Permittivity €, Permeability [ - D
Ground Plane
Type Real Ground Options
lSommerfeld-\ﬁ.faithsymptoﬁc vl
() None
‘CustOm v‘
O Perfect [] zero-Ohm connections to gnd

Conductivity [Sfm] Permittivity

(O Ssubstrate

Fig. 3: The parameters of a real ground plane are set.

Real Ground Options
Sommerfeld-Wait/Asymptotic

This option involves calculating the currents flowing through the antenna/wire structure using
a model that includes a perfect ground plane and incorporates equivalent loss impedances
to address power dissipation in the ground plane, particularly when wires are in close
proximity to or connected to the ground. Developed by Prof. James R. Wait, this model is
particularly effective for obtaining the input impedance of low-frequency (LF) and medium-
frequency (MF) antennas, especially in scenarios where the ground conductivity is high
within those frequency bands. Additionally, the finite conductivity and permittivity of the
ground are employed to calculate the near-field and far-field radiation from the structure,
utilizing the Sommerfeld-Norton asymptotic expressions and Fresnel’s reflection coefficients,
respectively.

Connections to the ground are permitted, either at the start or end point of a wire with z = 0,
and they are considered imperfect by default. This means that currents flowing between the
ground and the grounded wires result in power losses in the ground. However, if you select
the “Zero-Ohm connections to ground” option, wire connections to the ground will be
treated as perfect, with no power dissipation occurring at the connection point.

Reflection Coefficients/Asymptotic

In this option, the ground parameters have an impact on the current distribution on the
antenna or wire structure above the ground. This influence is determined through a
generalization of Fresnel’s reflection coefficients, which means that the input impedance of a
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transmitting antenna is also influenced by the real ground conditions. Moreover, the near and
far fields are affected by the finite ground conductivity and its dielectric constant. The near
fields are computed using the Sommerfeld-Norton asymptotic expressions, allowing us to
calculate the electric and magnetic field as a function of distance from the transmitting
antenna. This enables us to observe the attenuation resulting from ground losses. The far-
field, on the other hand, is computed using standard Fresnel’s reflection coefficients.

Vertical wire connections to the ground are permitted, but they are treated as lossless
connections.

Radial wire ground screen

In this option, a ground screen consisting of buried radial wires will be positioned beneath
the ground plane. The screen is centered at the origin of coordinates and features user-
specified parameters, including the number of radial wires, wire length (or radius of the
circular screen), and wire radius.

The ground screen model influences the current distribution on the antenna/wire structure by
calculating the power dissipated in the ground plane-wire screen system. Consequently, the
presence of the screen and the finite ground conductivity will impact the input impedance of
a transmitting antenna located above the ground screen. Additionally, the finite ground
conductivity and permittivity are employed to compute the near- and far-fields radiated from
the structure, utilizing the Sommerfeld-Norton expressions and the Fresnel’s reflection
coefficients, respectively.

Connections to the ground are permitted, either at the start or end point of a wire with z = 0,
and they are considered imperfect by default. This means that currents flowing between the
ground and the grounded wires result in power losses in the ground. However, if you select
the “Zero-Ohm connections to ground” option, wire connections to the ground will be
treated as perfect, with no power dissipation occurring at the connection point.

Substrate

A dielectric substrate, with a user-defined permittivity, will be positioned beneath the xy-
plane (z = 0), as shown in Fig. 4. The substrate can either extend infinitely or have finite
dimensions in the xy-plane. It is essential to specify the slab thickness, denoted as ‘h;’
along the z-axis. A perfectly electrically conducting (PEC) ground plane will be situated
at z = -h, just below the dielectric slab, as illustrated in Fig. 5. To facilitate setting the
substrate’s permittivity, choose from a drop-down list with common materials (e.g., FR4,
RT/Duroid, Rogers RO slabs).

When the Substrate option is selected, all wires must be positioned on the xy-plane (z =
0). These wires can represent flat traces of planar or patch antennas printed on the dielectric
substrate, microstrip lines, or PCB (Printed Circuit Board) traces. The only exception to this
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rule is for vertical wires, which can be employed to connect wire strips at z = 0 to the PEC
ground plane at z = -h. Typically, a voltage or current source is connected to these vertical
wires to power the system, whether it's an antenna or a PCB.

It's important to note that the PEC ground plane beneath the dielectric substrate cannot
be omitted from the model, meaning that ungrounded substrates are not supported with
this option. Wires positioned above the xy-plane (with z-coordinates > 0) or below the PEC
ground plane of the substrate (with z-coordinates < -h) are not supported. AN-SOF does not
automatically verify compliance with these conditions.

¥ Environment

Medium

Ground Plane

Type

O MNone

() Perfect

() Real

Fig. 4: The parameters of a finite dielectric substrate
are set. A perfect ground plane will be placed at z = -
h.
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i

T

Fig. 5: Dielectric substrate below the xy-plane. A microstrip line is

Far Field Parameters

set over the xy-plane.

The Far-Field Panel

Go to the Setup tab in the main window and select the Far-Field panel, Fig. 1.

The far field can be computed after having calculated the current distribution previously.
Thus, the parameters set in the Far-Field panel have no effect in the determination of the
currents and can be modified at any time. However, the far field must be recalculated every

Fig. 1: Far-Field panel in the Setup tabsheet.

time these parameters are modified.

FarField

Options

@ Full30 () Vertical () Horizontal () Custom
Origin [m]

X0 0 Yo 0 Z0 0

Distance [m] 1

Theta [deg] Phi [deg]

Start |0 Start 0

Step 2.5 Step 5

Stop |90 Stop 360

There are four options for radiation pattern calculations:
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Full 3D

The far field is calculated in angular ranges that cover the entire 3D space, which allows us
to obtain 3D radiation lobes. The steps for the Theta (zenith) and Phi (azimuth) angles can
be set in the Theta [deg] and Phi [deg] boxes.

Vertical

The far field is calculated at a vertical slice for a given Phi (azimuth) angle. The step for the
Theta (zenith) angle can be set in the Theta [deg] box, while the fixed Phi can be set in the
Phi [deg] box.

Horizontal

The far field is calculated at a horizontal slice for a given Theta (zenith) angle. The step for
the Phi (azimuth) angle can be set in the Phi [deg] box, while the fixed Theta can be set in
the Theta [deg] box.

Custom

The far field is calculated for the specified ranges of angles Theta (zenith) and Phi (azimuth).
The start, step, and stop values for Theta and Phi can be set in the Theta [deg] and Phi
[deg] boxes.

Additionally, the following parameters can be set:
Origin (X0,Y0,Z0)

This can be any point used as a phase reference, its coordinates do not affect the shape of
the radiation pattern. The 3D radiation pattern will be plotted centered at this point.

Distance

It is the distance from (X0,Y0,Z0) to an observation point in the far-field region. A normalized
far-field pattern can be obtained by setting Distance = 1.

The zenith and azimuth angles, Theta and Phi, are shown in Fig. 2, where it is also shown
de Distance R from the structure to an observation point in the far-field zone. These three
numbers (R,Theta,Phi) define the spherical coordinates of the far-field point.
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Far-Field Point

Structure

Dt’-]ZI,TEI,EEIj/

X

Fig. 2: Spherical coordinates (R, Theta,Phi) of a far-field point.
Near Field Parameters

Near-Field Panel

Go to the Setup tab in the main window. Then, select the Near-Field panel.

The near field can be computed after having calculated the current distribution previously.
Thus, the parameters set in the Near-Field panel have no effect in the determination of the
currents and can be set at any time. However, the near field must be recalculated every time
these parameters are modified. The Near-Field panel has three options: Cartesian,
Cylindrical, and Spherical. By choosing one of these options near-fields can either be
calculated in Cartesian, Cylindrical or Spherical coordinates.

Cartesian Coordinates

If the Cartesian option is chosen, the following parameters can be set for near-field
calculations, Fig. 1:

Origin (X0,Y0,20)

It is the origin of the Cartesian coordinates used to define the observation points where near
fields will be calculated.

X

This box is used to set x-coordinates of the observation points where near-fields will be
calculated. The start, step and stop x-coordinates must be set. Start and stop x-coordinates
are measured from XO0.
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Y

This box is used to set y-coordinates of the observation points where near-fields will be
calculated. The start, step and stop y-coordinates must be set. Start and stop y-coordinates
are measured from YO.

Z

This box is used to set z-coordinates of the observation points where near-fields will be
calculated. The start, step and stop z-coordinates must be set. Start and stop z-coordinates
are measured from Z0.

¥ Near-Field
Options
@ Cartesian ") Cylindrical ) Spherical
Origin [m]
X0 0 Yo 0 20 0
X [m] Y [m] Z [m]
Start 1 Start 1 Start 1
Step 1 Step 1 Step 1
Stop 5 Stop 5 Stop 5

Fig. 1: Near-Field panel in the Setup tabsheet. The
Cartesian option is selected.

Cylindrical Coordinates

If the Cylindrical option is chosen, the following parameters can be set for near-field
calculations, Fig. 2:

Origin (X0,Y0,Z0)

It is the origin of the Cylindrical coordinates used to define the observation points where near
fields will be calculated.

R

This box is used to set the distances or R-coordinates of the observation points where near-
fields will be calculated. The start, step and stop R-coordinates must be set. Start and stop
distances or R-coordinates are measured from the origin (X0,Y0,Z0).
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Phi

This box is used to set the azimuth angles or phi-coordinates of the observation points where
near-fields will be calculated. The start, step and stop phi-coordinates must be set in
degrees.

Z

This box is used to set the z-coordinates of the observation points where near-fields will be
calculated. The start, step and stop z-coordinates must be set.

¥ Near-Field
Options
Cartesian @ Cylindrical Spherical
Origin [m]
X0 0 Yo 0 20 0
R [m] Phi [deg] Z [m]
Start 1 Start 0 Start -1
Step 1 Step S Step 0.25
Stop S Stop 90 Stop 1

Fig. 2: Near-Field panel in the Setup tabsheet. The
Cylindrical option is selected.

Spherical Coordinates

If the Spherical option is chosen, the following parameters can be set for near-field
calculations, Fig. 3:

Origin (X0,Y0,Z0)

It is the origin of the Spherical coordinates used to define the observation points where near
fields will be calculated.

R

This box is used to set the distances or R-coordinates of the observation points where near-
fields will be calculated. The start, step and stop R-coordinates must be set. Start and stop
distances or R-coordinates are measured from the origin (X0,Y0,Z0).

Theta
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This box is used to set zenith angles or theta-coordinates of the observation points where
near-fields will be calculated. The start, step and stop theta-coordinates must be set in

degrees.
Phi

This box is used to set azimuth angles or phi-coordinates of the observation points where
near-fields will be calculated. The start, step and stop phi-coordinates must be set in

degrees.
¥ Near-Field
Options
Cartesian Cylindrical @) Spherical
Origin [m]
X0 0 YO O 20 0
R [m] Theta [deg] Phi [deg]
Start 1 Start 45 Start 0
Step 1 Step S Step 10
Stop 9 Stop 90 Stop 180

Fig. 3: Near-Field panel in the Setup tabsheet. The
Spherical option is selected.

Defining the Excitation

Excitation Panel

Go to the Setup tab in the main window and select the Excitation panel. There are two
types of excitations: Discrete Sources and Incident Field, Fig. 1.
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¥ Excitation Excitation
Type Type
(® Discrete Sources O Incident Field O Discrete Sources (® Incident Field
E-Field Major Axis Angles [deg]
S Vin ammalo
w Axial Ratio Theta lg"-‘ ]

I O
Phase Reference I

O 2 e

Fig. 1: Excitation panel in the Setup tabsheet.

Discrete Sources

The discrete generators placed at the wire structure will be used to calculate the current
distribution. The total input power in Watts can be specified, so the voltage/current sources
will be adjusted accordingly to achieve the specified input power. If the input power is not
specified, then the voltage/current sources will be constant, and the input power will be an
output result from calculations.

Incident Field

An incident plane wave will be used as the excitation of the structure. The direction of
incidence and polarization of the incoming field can be set in this panel.

The following parameters must be set for the incident wave excitation:
E-Field Major Axis

In the case of linear polarization, it is the amplitude, in Volts per meter (rms value), of the
incoming electric field. For an elliptically polarized plane wave, it is the major axis of the
polarization ellipse.

Axial Ratio

It is the ratio of the minor axis to the major axis of the polarization ellipse. If the axial ratio is
positive (negative) a right-handed (left-handed) ellipse is obtained. If the axial ratio is set to
zero, a linearly polarized wave will be obtained.

Phase Reference

It is the phase, in degrees, of the incident plane wave at the origin of coordinates. Its value
only shifts all phases in the structure by the same amount.
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Gamma

For a linearly polarized wave, it is the polarization angle, in degrees, of the incident electric
field measured from the plane of incidence to the direction of the electric field vector, as it is
shown in Fig. 2. For an elliptically polarized wave, Gamma is the angle between the plane of
incidence and the maijor ellipse axis.

Theta

It is the zenith angle, in degrees, of the incident direction.
Phi

It is the azimuth angle, in degrees, of the incident direction.
The definition of these parameters is illustrated in Fig. 2.

When the 3D View button is pressed a user interface is enabled in the workspace, where the
direction of arrival of the plane wave and its polarization can be specified easily, Fig. 3.

Note

When an incident plane wave is used as excitation, all discrete sources, if any,
will not be considered in the simulation.

Zy Einc
Erc
4
8 kK
"«\ k
Structure
VP4 -y
- R o

/ ¢ ['
x » \

"™ Plane of incidence

Fig. 2: Definition of the incident plane wave.
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Gamma 90

Theta 55

Phi S50

Fig. 3: 3D View user interface for the incident field definition. In the case of
elliptical polarization, the electric field vector Einc indicates the major ellipse axis.
The Settings Panel

Go to the Setup tab in the main window and select the Settings panel, Fig. 1.
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¥ Settings

Accuracy VSWR Ref, Impedance

Quadrature Tolerance D Ohm
%

Interaction Distance .

Options
PO !

] neF
Matrix Size Threshold
4000 Load Impedances
[“] Exact Kernel Wire Resistivity

Wire Coating

Fig. 1: Settings panel in the Setup tabsheet.

The accuracy of the integrals involved in the calculations can be set in the Settings panel.
The Quadrature Tolerance is the error in the evaluation of interactions between wire
segments which are separated by a distance less than the Interaction Distance.

The Interaction Distance is the maximum distance in wavelengths between segments for
which an error less than the Quadrature Tolerance is guaranteed in the integrations. The
interaction between all wire segments further apart than the Interaction Distance is computed
using a third-degree polynomial approximation to the involved integrals, which is more
accurate for curved segments than the Hertzian dipole approximation used in the traditional
Method of Moments. Therefore, the Interaction Distance could be set to zero for a faster
simulation when wire segments are not too close to each other, but results will be less
accurate. A convergence test for various values of this parameter is recommended.

For most cases, a quadrature tolerance between 0.1% and 1% and an interaction distance
between 0.25 and 1.0 wavelengths will be enough for obtaining accurate results.

In AN-SOF, all calculations are done with double precision. The Matrix Size Threshold
allows us to simulate big antenna problems when the size of the structure compromises the
available memory space. For instance, by setting the Matrix Size Threshold to 4,000, the set
of linear equations associated to the Z-matrix of the antenna system will be computed using
single precision for a matrix size bigger than 4,000 x 4,000. This will impact the accuracy of
the calculations but will save memory. In practice, the error will be not significant.
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The Exact Kernel option allows us to use the exact Kernel for the Electric Field Integral
Equation associated to the structure. This option must be chosen when relatively thick wire
segments are used to describe the wire structure. If the Exact Kernel option is unchecked,
an extended thin-wire approximation will be used for the kernel. If all wire segments are thin
enough, then the computation will be a little faster using the extended thin-wire kernel. Refer
to The Exact Kernel for further information.

In the Settings panel, the Reference Impedance for VSWR calculations can also be set. A
default value of 50 Ohm is set.

Besides, the following options for the type of simulation are available in the Options box:

If NGF is checked, the Numerical Green’s Function calculation is performed in the
simulation, that is, the LU-decomposed matrix of the system is stored in a file in the
first simulation. Then, by using the stored information, new simulations are performed
faster than the first one. Check this option if you need to change the amplitude values
of voltage/current sources frequently.

If Load Impedances is checked, lumped impedances will be considered in the
simulation. With this option all the lumped loads can be disabled or enabled at the
same time.

If Wire Resistivity is checked, the finite resistivity of the wires will be considered in the
simulation. Any wire has its own resistivity in [Ohm meter] that can be set when the
wire is drawn. This option allows us considering the whole structure as a perfect
electric conductor when it is unchecked.

If Wire Coating is checked, the coating materials of the wires will be considered in the
simulation. Any wire has its own coating specified by a dielectric permittivity, magnetic
permeability, and thickness, which can be set when the wire is drawn. When this option
is unchecked, the wire coating will not be considered in the simulation.

Project Details

Go to View > Project Details in the main menu to display the Project Details window, where
a summary of the project information is shown, Fig. 1. There is also a button on the toolbar
to access this window.

The text in the Project Details window can be selected and copied to the clipboard in the
usual way (Ctrl+C and Ctrl+V commands).
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B Project Details -

— Structure —
Wires: 291
Sources: 1
Loads: O

Total: 893

— Excitation -

— Medium -

— Far-Field -
Ongn: 000 m
Distance: 10 m

Segments: 459
Connections: 434
Ground Points: 0

Decrete sources

- Frequencies —
Frequency range: 75 - 95 MHz

- Free Space -

Theta: 0: 2.5 :
Phi: 0 : 5: 360 deg

Project mame: AN-SOF - HelxGND
Last saved: 8/16/2022 14:59:36

Relative Permittivity: 1
Rebative Permeabilty: 1
Minimum Wavelength: 3.15571 m

180 deg

File Formats

When a project is saved in AN-SOF, multiple files that share the same name as the project
are saved within the same directory. Each file has a unique extension that corresponds to its

specific content.

IMPORTANT: When requesting support, please compress all the project files into a ZIP

Fig. 1: Project Details window.

archive and attach it to your support request email.

These files include:
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Description

Main file with configuration data

*.wre Geometric description of the wire structure
*.cur Current distribution

*.phi E-phi component of the far-field.

*.the E-theta component of the far-field.

*.pwr Radiation pattern data

*.nef Near electric field

*.nhf Near magnetic field

*.ngf Numerical Green’s function

*.txt Notes written by the user

Shortcut Keys

Pressing ALT with the underlined letter of a menu item will execute the command associated

with the item.

The following keys and associated actions are available:
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Key Action

Home Return the structure to the initial view
ESC Unselect a wire

F1 Rotate view around +X axis

F2 Rotate view around -X axis

F3 Rotate view around +Y axis

F4 Rotate view around -Y axis

F5 Rotate view around +Z axis

F6 Rotate view around -Z axis

F7 Show Main/Small axes

F8 Select a wire in order of creation
F9 Select a wire in reverse order of creation
F10 Run ALL

F11 Run currents and far-field

F12 Run currents and near-field
Ctri+ A Display the Axes dialog box

Ctrl +1 Zoom in

Ctrl+ K  Zoom out

Ctri+ M  Modify the selected wire

Ctrl+ N Create a new project

Ctrl+ O Open a project file

Ctrl + P Print the workspace

Ctrl+Q  Exit AN-SOF
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Key Action

Ctrl+ R Run Currents

Ctri+ S Save the project

Ctrl+T Tabular input of linear wires

Ctrl+ W  Show properties of the selected wire

Ctrl + Del Delete the selected wire or group of wires

Ctrl + Ins Display the Source/Load toolbar

Drawing Wires

Types of Wires

AN-SOF has different types of wires. Each wire type has its own geometrical parameters,
attributes and materials that can be set in a specific Draw dialog box. This dialog box allows
us drawing a new wire in the workspace.

Choosing Draw in the main menu shows the following commands:

Menu Options

The commands to draw wires can be accessed from three menus:

¢ Main menu > Draw.
e Popup menu by right clicking on the workspace.
e Main menu > View > Drawing Panel.

Wire Attributes

The Attributes page is part of the Draw dialog box for the selected wire type (see Fig. 1). On
the Attributes page, you can specify the following attributes:

Number of Segments

Every wire must be divided into a certain number of segments. During the simulation
process, AN-SOF needs to determine the unknown current on each segment. When you
access the Attributes page, a default Number of Segments is displayed. This default number

is calculated based on the wire’s length and the shortest wavelength, but you can modify it
as needed.
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Note

If you set the Number of Segments to zero, AN-SOF will automatically compute the
minimum recommended number of segments for the wire. This calculation assumes 10
segments per wavelength, considering the shortest wavelength in a frequency
sweep.

Cross-Section

The Cross-Section of the wire can be chosen from a combo-box. There are six cross-section
types available: Circular, Square, Flat, Elliptical, Rectangular, and Triangular. AN-SOF
computes an equivalent radius for the five last cases. Infinitesimally thin wires are not
allowed, so the cross-section radius must be greater than zero.

The Draw dialog box for any wire type has its own Attributes page with the same features as
those described here.

[Line _|{Atirbutes || aterials

Number of Segments 19

Cross Section [Ctnja'

Fig. 1: Attributes page in the Draw dialog box for the
Line.

Wire Materials

The Materials page belongs to the Draw dialog box of the chosen wire type, Fig. 1.
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Draw
Line  Attributes |Materials

Wire Resistivity [Ohm m)

Copper v| |1.74-8 |

Wire Coating
Relative Permittivity € |1 |

Relative Permeability @ |1

Thickness [mm] 0

OK Cancel

Fig. 1: Materials page in the Draw dialog box for the
Line.

In the Materials page the following attributes can be specified:

Wire Resistivity

A resistivity in [Ohm meter] can be specified for the wire. The following list of most common
metals is available for choosing:
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Material (Metals) Resistivity [Q m]

Aluminum (Pure) 2.65E-8

Aluminum (6061-T6) 4.01E-8

Aluminum (6063-T832) 3.25E-8

Brass 6.41E-8
Carbon Steel 1.67E-7
Constantan 4 42E-7
Copper 1.74E-8
German Silver 3.33E-7
Germanium 4 55E-7
Gold 2.44E-8
Iron 9.71E-8
Manganin 4.41E-7
Nichrome 1.00E-6
Nickel 6.90E-8
Phosphor Bronze 1.10E-7
Silver 1.59E-8
Solder 1.43E-7
Stainless Steel 9.09E-7

Stainless Steel 302 7.19E-7

Tin 1.14E-7
Tungsten 5.49E-8
Zinc 5.90E-8

https://antennasimulator.com/index.php/an-sof-user-guide/ 79/303



12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

The corresponding resistivity value will be automatically displayed for the chosen metal.
Choose the Custom option to set a resistivity value if it is not in the list. Choose Perfect
(PEC) to set a perfect electrically conducting metal.

The resistivity is used for computing a distributed impedance per unit length along the wire,
which considers the skin effect. The equivalent radius for wires of non-circular cross section
will be used to compute the impedance per unit length along the wires.

The resistivity of wires is considered in the simulation if the option Wire Resistivity is
checked in the Settings panel of the Setup tabsheet.

Wire Coating

Wires can have insulation or coating material. The cross section of a coated wire is
circular, so the equivalent radius will be used for wires having a non-circular cross section.
In this case, the material the coating is made of can be set by the following parameters:

» Relative Permittivity: It is the dielectric constant of the coating material relative to the
permittivity of vacuum.

» Relative Permeability: It is the magnetic permeability of the coating material relative to
the permeability of vacuum.

o Thickness: It is the thickness of the coating shield. It can be set to zero when no
coating is used.

The wire coating is considered in the simulation if the option Wire Coating is checked in the
Settings panel of the Setup tabsheet.
Enabling/Disabling Resistivity

If wires with non-zero resistivity have been drawn previously and the whole structure must
now be considered as a perfect electric conductor, all resistivities can be disabled without
modifying the definitions of the wires.

Go to the Setup tabsheet in the main window and select the Settings panel, Fig. 1. If the
option Wire Resistivity in this panel is checked, the resistivities are enabled. Uncheck the
Wire Resistivity option to disable all of them.
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¥ Settings

Accuracy VSWR Ref, Impedance

Quadrature Tolerance E Ohm
=

Interaction Dista
Bra Stance OpﬁDnS
o wm
[J neF
Matrix Size Threshold
4000 Load Impedances

[] Exact Kernel Wire Resistivity

Wire Coating

Fig. 1: Wire Resistivity option in the Settings panel of
the Setup tabsheet. If this option is checked, all
resistivities are enabled, otherwise they are disabled.

Enabling/Disabling Coating

If wires with a coating shield or insulation have been drawn previously and the whole
structure must now be considered as composed of bare conductive wires, all coatings can
be disabled without modifying the definitions of the wires.

Go to the Setup tabsheet in the main window and select the Settings panel, Fig. 1. If the
option Wire Coating in this panel is checked, the coatings are enabled. Uncheck the Wire
Coating option to disable all of them.
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Settings

&

Accuracy
Quadrature Tolerance

[ Exact Kernel

Fig. 1: Wire Coating option in the Settings panel of the
Setup tabsheet. If this option is checked, all coatings are

VSWR Ref. Impedance
o |om
Options

(] NGF

4] Load Impedances

[ Wire Resistivity

enabled, otherwise they are disabled.

Cross-Section Equivalent Radius

The wire cross-section can be chosen from a combo-box in the Attributes page of the Draw

dialog box for the chosen wire type, Fig. 1.

Number of Segments

19

a [mm] S

Fig. 1: Cross-section combo-box in the Attributes
page of the Draw dialog box. A circular cross section

of radius “a” is chosen.
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There are six cross-section types available: Circular, Square, Flat, Elliptical, Rectangular,
and Triangular. AN-SOF computes an equivalent radius for the non-circular cross-sections.
The equivalent radius is the radius of a circular cross-section that produces the same
average electromagnetic fields around the wire and on its surface.

The cross-sections and their equivalent radii are the following:

Circular

A positive and non-zero radius “a” must be set. The equivalent radius is “a”.

Y

—E—

Square

A positive and non-zero width “w” must be set. The equivalent radius is 0.59017 w.

Flat

A positive and non-zero width “w” must be set. The equivalent radius is w/4.

Elliptical

The semi-axes “a” and “b” must be positive and non-zero. The equivalent radius is (a + b)/2.

Rectangular
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The widths “w” and “t” must be positive and non-zero. The equivalent radius is computed
using a polynomial and logarithmic approximation to the solution of an integral equation.

JAN

— N —

Triangular

A positive and non-zero width “w” must be set. The equivalent radius is 0.42 w.
Exporting Wires

You can export linear wires from AN-SOF to a text file in NEC format (extension .nec) by
navigating to File > Export Wires in the main menu. Linear wires will be saved as GW lines.
Additionally, the exported file will include GE (ground connections), GN (ground plane), TL
(transmission line), LD (load impedances and wire conductivity), IS (wire insulation), FR
(frequency), EX (excitation), EK (exact kernel), and RP (radiation pattern) cards.

Moreover, the exported file can be saved as a Scilab script, with a .sce extension. The
exported file will contain programming code that can be adjusted to create a new project,
allowing for variations in parameters such as wire lengths and positions, frequencies, and
ground conditions.

Adding Wires

Line
The “Line” refers to a linear or straight wire.

To access the “Line” dialog box for drawing a line, navigate to Draw > Line in the main
menu. This dialog box contains three pages: Line, Attributes, and Materials (Fig. 1).

Line Page

The Line page allows you to set the geometrical parameters for the line. Two options are
available: 2 Points and Start — Direction — Length.

The 2 Points option enables you to define the line by specifying two points: “From Point” and
“To Point” (Figs. 1 and 2).

If Start — Direction — Length is selected, the line will be drawn starting from the Start Point,
in the direction given by the Theta and Phi angles in spherical coordinates, and ending at a
point defined by the Wire Length measured along that direction (Figs. 3 and 4).
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After setting the geometrical parameters on the Line page, you can select the Attributes
page to specify the Number of Segments and Cross-Section. The Materials page allows

you to set the wire Resistivity and Coating.

Draw
{ Attributes Materials
|2F‘|:|ints v|
From Point [mm]
X110 | v1|1w0 | 21|10 |
To Point [mm]
x2 |20 | vz|a0 | 22|20 |
QK Cancel

Fig. 1: “2 Points” option in the Line page of the
Draw dialog box for the Line.
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2
Line wire
"2 Points" option
20
To Paint
(20,20,20)
10
From Point
(10,10,10)

10
20 ,

10
20

Fig. 2: A Line drawn using the “2 Points” option with the parameters
shown in Fig. 1.

‘Line” " Attributes Materials

Options: | Start - Direction - Length -~ |

Start Point [mm]

x10 | vilo | z1o |

Direction Angles [deqg]

e
-

oK Cancel

Fig. 3: “Start — Direction — Length” option in
the Line page of the Draw dialog box for the
Line.
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Line wire

"Start - Direction - Length"” option

Theta=45° &

Lenath = 50 mm

Start Point
(0,00

Phi = 45°

Fig. 4: A Line drawn using the “Start — Direction — Length” option with the
parameters shown in Fig. 3.
Arc

The “Arc” refers to a circular arc.

To access the “Arc” dialog box for drawing an arc, navigate to Draw > Arc in the main menu.
This dialog box contains three pages: Arc, Attributes, and Materials (Fig. 1).

Arc Page

The Arc page allows you to set the geometrical parameters for the arc. Two options are
available: 3 Points and Start — Center — End.

The 3 Points option enables you to define the arc by specifying three points: a Start Point,
a Second Point, and an End Point. An arc starting from the Start Point, passing through

the Second Point, and ending at the End Point will be drawn on the workspace (Figs. 1 and
2).
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If Start — Center — End is selected, the arc will be drawn starting from the Start Point, with
the center specified by Center and ending at a point determined by the End Point (Figs. 3
and 4). The End Point determines the arc’s aperture angle and the plane in which it lies.
Note that the End Point may not coincide with the actual ending point of the arc.

After setting the geometrical parameters on the Arc page, you can select the Attributes
page to specify the Number of Segments and Cross-Section. The Materials page allows
you to set the wire Resistivity and Coating.

CArc U Attributes  Materials

Options: | 3 Points w |

Start Point [mm]

X110 | vifo | z1a |

Second Paoint [mm]

leltl | ~r2|1|:| | 22|1E| |

End Point [mm]

x3[0 | v3|10 | z30 |

QK Cancel

Fig. 1: “3 Points” option in the Arc page of the
Draw dialog box for the Arc.
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z
Arc wire
*3 Points" option
15
10

Second Paint
(10,10,10)

Start Point 10
1000 L 2 End Point

10 (0.10,0)
15

15 Y

Fig. 2: An Arc drawn using the “3 Points” option with the parameters shown in
Fig. 1.

CArc ! attributes  Materials

....................

Options: | Start - Center - End - |

Start Point [mm]

x10 | v1fo | z1|10 |
Center [mm]
cxo | cylo | cz|o |

End Point [mm]

X210 | vz|10 | z2|10 |

QK Cancel

Fig. 3: “Start — Center — End” option in the Arc
page of the Draw dialog box for the Arc.
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Arc wire

"Start - Center - End™ option

Start Point
(0,0,10] 4.
N
\ End Point
\ (10,10,10)
\ +
\\
\
i
5 \'!1
Center
(0,00 +
5
: 10 y
10

Fig. 4: An Arc drawn using the “Start — Center — End” option with the parameters
shown in Fig. 3.
Circle

The Circle refers to a circular loop.

Go to Draw > Circle in the main menu to display the Draw dialog box for the Circle. This
dialog box has four pages: Circle, Orientation, Attributes and Materials.

The Circle page

In the Circle page the geometrical parameters for the Circle can be set. There are two
options: Center — Radius — Orientation and 3 Points.

The Center — Radius — Orientation option allows us entering the Circle by giving its Center,
Radius, and axis, Figs. 1 and 2. The circle axis can be set in the Orientation page, Fig. 3.
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[Gre” orentaon | Atrutes [ aterios

Options: [Center - Radius - Orientation v]

Radius [mm] 10

Fig. 1: “Center — Radius — Orientation” option in the
Circle page of the Draw dialog box.
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10
20

Phi = 45°

Fig. 2: A Circle drawn using the “Center — Radius — Orientation” option.
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Circle wire

“Center - RBadius - Onentation" option

Theta = 45°

Direction
(M= Ny,Nz)
Center
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Radius = 10 mm
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Phi [deg] 45

Rotation Angle [deg] 0

Lo« ] [ cn ]

Fig. 3: Orientation page in the Draw dialog box for the
Circle.

If the 3 Points option is chosen, the Circle will be drawn starting from First Point, passing
through Second Point and Third Point, and ending at First Point, Figs. 4 and 5. Thus, the
circle starts and ends at the same point. The Orientation page will be invisible when the 3

Points option is chosen.
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[Cirde | Attrbutes | Materials |

Options: (3Points

X1 0 Y10
Second Point [mm]

X2 0 Y20
Third Point [mm]

X3 0

Fig. 4: “3 Points” option in the Circle page of the Draw
dialog box.
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Circle wire

"3 Points" option

__F.-——‘—_‘-——._\___
- H—\___q_-\"

Second Point /_x""r

[nmy*m

l...'u
b First Point _ _ ;
[U,U,D] Third Paint
(0,10,0)
S 5 0 ’
5 H"“w-,__ _,-"’-—/

10

Fig. 5: A Circle drawn using the “3 Points” option.

Once the geometrical parameters in the Circle and Orientation pages have been set, the
Attributes > page can be selected, where the number of segments and cross-section can
be set. The wire resistivity and coating can be set in the Materials > page.

The Orientation page

In the Orientation page the orientation for the Circle can be set. There is a box with two
options: Angles and Vector, Fig. 3.

If Angles is selected, the circle axis can be defined by given an orthogonal direction to the
rest plane of the circle. Thus, the Theta and Phi angles determine the axis direction in
spherical coordinates.

If Vector is selected, the circle axis can be defined by given an orthogonal vector to the rest
plane of the circle. Thus, the Nx, Ny, and Nz components of that vector determine the axis
direction.

The circle can be rotated around its axis by given the Rotation Angle.
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Helix
The “Helix” refers to a wire curved into a circular helical shape.

To access the “Helix” dialog box for drawing a helix, navigate to Draw > Helix in the AN-SOF
main menu. This dialog box contains four tabs: Helix, Orientation, Attributes, and
Materials.

Helix Page

The Helix page allows you to set the geometrical parameters for the helix. Two options are
available: Start — Radius — Pitch — Turns and Start — End — Radius — Turns.

The Start — Radius — Pitch — Turns option enables you to define the helix by specifying its
Start Point, Radius, Pitch, and Number of turns, as shown in Figures 1 and 2. The Pitch
represents the spacing between turns. A positive (negative) pitch results in a right-handed
(left-handed) helix. The Number of turns does not need to be an integer, allowing you to
enter fractions of turns. Alternatively, you can enter the Diameter, Pitch Angle, and Wire
Length instead of the radius-pitch-number of turns combination. When entering the Radius
— Pitch — Turns combination, the Diameter — Pitch Angle — Wire Length set will be
automatically calculated, and vice versa. In any case, the helix’s axial height is displayed
automatically (calculated from the input data and cannot be entered).

The orientation of the helix axis can be set on the Orientation page (Fig. 3), as described
below.

Options: |Start - Radius - Pitch - Turns -~ |

Start Point [mm]

X1 [0 | y1|10 | z1o |

Radius [mm]| 10 m

Pitch [mm] E Angle [dea] [2.04308

M. DfTurns|: Length [mm]|318. 113
Height [mm]

QK Cancel

)

Fig. 1: “Start — Radius — Pitch — Turns” option
in the Helix page of the Draw dialog box for
the Helix.
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Mumber of turng = 5

T~

Start Point
(0,100

Fig. 2: A Helix drawn using the “Start — Radius — Pitch — Turns” option and with

Helix wire

“Start - Radius - Pitch - Turns" option

*__Radius = 10

Direction

Theta = 45"
Fhi = 90°

. Pitch =10

the parameters shown in Fig. 1.
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Drraw

Helxx Orientation | Attributes  Materials

Options
(® Angles i_Jvector

Theta [deg] Phi [deg]

Rotation Angle [deqg] ICI

QK Cancel

Fig. 3: Orientation page of the Draw dialog box
for the Helix with the Theta and Phi angles

If Start — End — Radius — Turns is selected, the helix will be drawn starting from the Start
Point and ending at the End Point, with the specified Radius and Number of turns, as
illustrated in Figures 4 and 5. The Number of turns must be an integer, and a positive
(negative) value results in a right-handed (left-handed) helix. The orientation of the helix axis
is determined by the starting and ending points. The helix can be rotated around its axis by
specifying a Rotation Angle. The Orientation page will be hidden when the Start — End —
Radius — Turns option is chosen, as the helix axis orientation is already defined by the line

shown in Figure 2.

connecting its start and end points.
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| Attributes

Options:

Start Point [mm]

Materials

| Start - End - Radius -Turns  ~ |

X1 (0

| v1[10 | z1o |

End Paint [mm]

X2 [0

| v2[10 | z2 |40 |

OK

Radus 10| Number

Rotation
Angle [deq]

Height [mm]

Cancel

Fig. 4: “Start — End — Radius — Turns” option in
the Helix page of the Draw dialog box for the
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Helix wire

"Start - End - Radius - Turns" option
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20
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Fig. 5: A Helix drawn using the “Start — End — Radius — Turns” option and with
the parameters shown in Fig. 4.

After setting the geometrical parameters on the Helix and Orientation pages, you can select
the Attributes page to specify the Number of Segments and Cross-Section. The
Materials page allows you to set the wire Resistivity and Coating.

Orientation Page

The Orientation page provides options for setting the helix orientation. A box with two
options is available: Angles and Vector (Fig. 3).

If Angles is selected, the helix axis can be defined by specifying its direction in 3D space
using the Theta and Phi angles in spherical coordinates.

If Vector is selected, the helix axis can be defined by entering a vector in the axis direction.
The Ny, Ny, and N, components determine this vector.

The helix can be rotated around its axis by specifying a Rotation Angle.
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Quadratic
The Quadratic refers to a quadratic wire or parabola.

Go to Draw > Quadratic in the main menu to display the Draw dialog box for the Quadratic.
This dialog box has three pages: Quadratic, Attributes, and Materials.

The Quadratic page

In the Quadratic page the geometrical parameters for the Quadratic can be set, Fig. 1.

The Quadratic is entered by giving three points. A quadratic curve starting from Start Point,
passing through Second Point and ending at End Point will be drawn on the workspace, as
shown in Figs. 2.

Once the geometrical parameters in the Quadratic page have been set, the Attributes >
page can be selected, where the number of segments and cross-section can be set. The
wire resistivity and coating can be set in the Materials > page.

[ Quadratc | attributes | Materiaks|

Start Point [m]

X10 Y11

Second Point [m]

X2 0 ¥2 0

End Point [m]

X3 0

Lo ] [ o ]

Fig. 1: Quadratic page of the Draw dialog box.
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Fig. 2: A Quadratic drawn using the points shown in Fig. 1.
Archimedean Spiral

The Archimedean Spiral refers to the Archimedes’ spiral with polar equation r(a) = rg + p/(21)
a, where rg is the starting radius and p is the pitch. For a spiral with an integer number of
turns, M, we have a = 21TM at its end point, so rgng = rg + pM, the pitch p being the
separation between turns. Besides, we have that the pitch equals the constant growth rate of
the spiral radius r(a) per turn, that is p = 2mrdr/da.

Go to Draw > Archimedean Spiral in the main menu to display the Draw dialog box for the
Archimedean Spiral. This dialog box has three pages: Archimedean Spiral, Attributes, and
Materials.

The Archimedean Spiral page

In the Archimedean Spiral page, the geometrical parameters for the Archimedean Spiral
can be set, Fig. 1.
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The Archimedean spiral is entered by giving the Start Point, Start Radius ry, Pitch p (positive
or negative) and Number of Turns M (complete turns and fractions of a turn can be set). The
spiral lies on a plane given by the Orientation Angles Theta and Phi (normal to the plane in
spherical coordinates) and can be rotated by setting a Rotation Angle, Fig. 2.

Once the geometrical parameters in the Archimedean Spiral page have been set, the
Attributes > page can be selected, where the number of segments and cross-section can
be set. The wire resistivity and coating can be set in the Materials > page.

[Archimedean Spral | Atributes | Materials

X10 Y1 0.5 zZ1 0

Start Radius [m] Orientation Angles [deg]

0.5 Theta 45

Pitch [m]
0.25

Phi S0

Number of Turns Rotation Angle [deqg]
2 0

L« ] [ o ]

Fig. 1: Archimedean Spiral page of the Draw dialog
box.
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Fig. 2: An Archimedean Spiral drawn using the data shown in Fig. 1.
Logarithmic Spiral

The Logarithmic Spiral refers to a spiral with polar equation r(a) = ry exp(ba), where rg is the
starting radius (r at a = 0), b = p/(21rg) and p is the starting pitch, that is, the derivative
2mdr/da at a = 0 (starting growth rate of the spiral radius r(a) per turn). The first two terms of
the Taylor expansion r(a) = ro + p/(21) a + ro(ba)?/2 + ... give the polar equation of an
Archimedean spiral.

Go to Draw > Logarithmic Spiral in the main menu to display the Draw dialog box for the
Logarithmic Spiral. This dialog box has three pages: Logarithmic Spiral, Attributes, and
Materials.

The Logarithmic Spiral page

In the Logarithmic Spiral page, the geometrical parameters for the Logarithmic Spiral can
be set, Fig. 1.

The logarithmic spiral is entered by giving the Start Point, Start Radius ry, Start Pitch p
(positive or negative) and Number of Turns (complete turns and fractions of a turn can be
defined). The spiral lies on a plane given by the Orientation Angles Theta and Phi (normal
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to the plane in spherical coordinates) and can be rotated by setting a Rotation Angle, Fig. 2.

Once the geometrical parameters in the Logarithmic Spiral page have been set, the
Attributes > page can be selected, where the number of segments and cross-section can
be set. The wire resistivity and coating can be set in the Materials > page.

[Logarithmic Spral | Atributes | Materials|

X10 Y10 Z1 0

Start Radius [m)] Orientation Angles [deg]

1 Theta 90

Start Pitch [m]
1

Phi

Number of Turns Rotation Angle [deg]
2.5 0

Lo« ] [ cana ]

Fig. 1: Logarithmic Spiral page of the Draw dialog
box.

https://antennasimulator.com/index.php/an-sof-user-guide/ 105/303


https://antennasimulator.com/index.php/knowledge-base/wire-attributes/
https://antennasimulator.com/index.php/knowledge-base/wire-materials/

12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software
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Start Radius =1
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Fig. 2: A Logarithmic Spiral drawn using the data shown in Fig. 1.
Tapered Wires

A tapered wire is a wire with a variable radius along its length. The cross section of tapered
wires is always circular. The radius is varied linearly along the wire and in defined steps, then
a wire with a stepped radius is obtained, as shown in Fig. 1.

5 wires

| | ] ]
2 segments 2 segments 2 segments

2 segments 2 segments

Fig. 1: Example of a tapered wire divided into 5 wire portions. Each portion is divided into 2 segments.
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Go to Draw > Tapered Wire in the main menu and select a wire type for drawing. The wire
types available are the same as in the Draw menu. As an example, Fig. 2 shows the Line
page of the Draw dialog box when a linear wire is selected.

[ TaperedLine | attrbutes | Materias |

Xx10 ¥10

To Point [m]

X20

Lo ] [ o ]

Fig. 2: Tapered Line page in the Draw dialog box. Go
to main menu > Draw > Tapered Wire > Tapered Line.

The wire must be divided into wire portions according to the desired steps in radius, as it is
indicated in Fig. 1. Also, each wire portion having a uniform radius must be divided into
segments as it is required by the Method of Moments used for the simulation.

The number of wire portions and the number of segments per wire can be set by going to the
Attributes tab, Fig. 3. In this page, the Start and End radii can be set. The resistivity for the
conductive wire and its coating material can be set in the Materials tab, Fig. 4. In this case,
a tapered coating shield can also be set by giving a Start and End thickness.

The wire portions will be displayed in alternating colors for easy identification in the
workspace.
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Number of Wires

Segments per Wire

Cross Section
Start Radius [mm]

5

End Radius [mm]
1

Fig. 3: Attributes page where the number of wire
portions and segments per wire can be set, as well as

Start and End radii.

| Tapered Line | Attrbutes || Materials |

Wire Resistivity [Ohm m] 1.7E-8
Wire Coating

Relative Permittivity eps 2

Relative Permeability mu 1.04

Start Thickness [mm] 0.5

End Thickness [mm] 0.1

L« ] [ o ]

Fig. 4: Materials page where the wire resistivity and
coating can be set. A tapered coating can be defined

by giving the Start and End thicknesses.
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Supported Formats

To import wires from an external file into AN-SOF, follow these steps:

1. Navigate to File > Import Wires in the main menu.
2. A sub-menu with four options will be displayed: AN-SOF, NEC, DXF, and MM formats.
3. Note that DXF and MM formats should contain only linear wires in ASCII text format.

AN-SOF Format

Wires can be imported into the AN-SOF workspace from another AN-SOF project. When a
project is saved, a corresponding file with a .wre extension is created in the same directory.
This file, named after the project, contains the geometrical description of all wires within the
project. For details on files generated during project saves, refer to File Formats.

To import wires into your project, navigate to the main menu and select File > Import Wires >
AN-SOF Format. Then, choose the specific .wre file you wish to import. You can import
multiple .wre files, one at a time, as needed.

NEC Format

There are slight differences between the commands supported by AN-SOF and the standard
NEC cards. To maintain compatibility with the NEC format, originally designed for data entry
using punch cards, some fields appear repeating, and others must be entered with a zero,
having no meaning. Lengths and wire radii are assumed to be in meters. If errors are
found while importing a file, an error report will be shown in the Note panel of the Setup tab.

The SY command for symbolic language is not supported. To run simulations with variable
geometric parameters, you can write scripts to generate the NEC files and then use the Run
Bulk Simulation command (refer to section “12.8 Running a Bulk Simulation”). See
examples here >.

GW - Linear Wire

One linear wire per line must be set, beginning with “GW” and ending with an Enter, as
follows:

GW Tag Segments X1 Y1 Z1 X2 Y2 Z2 Radius
[Enter]

Tag: Tag number for the linear wire (Tag > 0). The space between “GW” and Tag is optional.
A single tab or comma can also be used as a separator between the command name and
the first data field.
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Segments: Number of segments for the wire. If zero is entered, the minimum recommended
number of segments will be computed.

X1 Y1 Z1: Cartesian coordinates of the start point of the linear wire.
X2 Y2 Z2: Cartesian coordinates of the end point of the linear wire.
Radius: Wire radius.

Fields can be separated by up to two spaces, a single tab, a single comma, or a
comma and space. Each GW line, including the last one in a set of linear wires to be
imported, must end with an Enter (press Enter on the keyboard for a carriage return). The
text lines above the GW lines will be ignored, so comments can be added at the beginning of
the file.

The following are equivalent examples:

Write comments here

GW 1125.42 0.38 1.262 5.425 -0.378 1.261 0.01/Enter]
GW 257.4501.122 7.450 1.49 0.015/Enter]

GW 328.30.01.12 8.37 0.0 1.595 0.01/Enter]

Write comments here
GW1,12,5.42,0.38,1.262,5.425,-0.378,1.261,0.01/Enter]
GW2,5,7.45,0,1.122,7.45,0,1.49,0.015/Enter]

GW3,2,8.3,0.0,1.12,8.37,0.0,1.595,0.01/Enter]

CM and Other Commands

The following commands: CM (comment lines), GH (helical wire), GA (arc), GM (coordinate
transformation), GS (scale dimensions), GE (ground connections), GN (real ground
parameters), TL (transmission line), LD (load impedances and wire conductivity), IS
(insulated wire), FR (frequency), EX (excitation), EK (exact kernel), and RP (radiation
pattern), will also be read.

CM lines will be added to the Note panel of the Setup tabsheet after the NEC file is imported.
The comment termination card, “CE”, is not needed in AN-SOF. Comments without the CM
command at the beginning of the file will be ignored and not imported. The command
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names—‘CM”, “GW”, “GH”, etc.—are reserved words in AN-SOF and are used to
recognize the fields between these commands and the final Enter in each text line, so the
command names should not be used in comments.

IMPORTANT: CM lines must always be placed at the beginning of a .nec file and kept
separate from other commands.

The rest of the AN-SOF commands in NEC format are listed below, where all the indicated
fields are mandatory.

GH - Helix

The GH command is used to define a helix in AN-SOF with the following syntax:
GH Tag Segments Spacing Length R R R R Radius
[Enter]

Tag: A positive number representing the tag for the helix. The space between “GH” and the
Tag is optional. Note that the helix begins at the origin and develops along the positive z-
axis. To adjust the helix’s position or rotation, use the GM command described below. It's
important to mention that the GH command differs in NEC-4.

Segments: The number of segments for the helix. If zero is entered, AN-SOF will compute
the minimum recommended number of segments. Unlike NEC, AN-SOF uses conformal
segments that precisely follow the helix contour.

Spacing: Spacing between turns.

Length: Total length of the helix. A positive Length value results in a right-handed helix,
while a negative Length value produces a left-handed helix.

R: Radius of the helix (repeated four times).
Radius: Wire radius.

Note: AN-SOF uses conformal segments that exactly follow the helix contour,
distinguishing it from NEC.

GA - Arc

The GA command is utilized to define an arc in AN-SOF with the following syntax:

GA Tag Segments R Ang1 Ang2 Radius
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[Enter]

Tag: A positive number serving as the tag for the arc. The space between “GA” and the Tag
is optional. The arc is situated on the xz-plane, centered at the origin, making the y-axis the
axis of the arc. To manipulate the position or rotation of the arc, use the GM command
described below.

Segments: The number of segments for the arc. If zero is entered, AN-SOF will compute the
minimum recommended number of segments. It's worth noting that, unlike NEC, AN-SOF
uses conformal segments that precisely follow the arc contour.

R: Arc radius.

Ang1: The angle of the first end of the arc measured from the x-axis in a left-handed
direction about the y-axis, given in degrees.

Ang2: The angle of the second end of the arc, measured in degrees.
Radius: Wire radius.

Note: AN-SOF uses conformal segments that exactly follow the arc contour, distinguishing
it from NEC.

GB - AN-SOF’s Arc

The GB command is utilized to define an arc in AN-SOF with the following syntax:
GB Tag Segments Type X1 Y1 Z1 X2 Y2 Z2 X3 Y3 Z3 Radius
[Enter]

Tag: A positive number serving as the tag for the arc. The space between “GB” and the Tag
is optional.

Segments: The number of segments for the arc. If zero is entered, AN-SOF will compute the
minimum recommended number of segments. It's worth noting that, unlike NEC, AN-SOF
uses conformal segments that precisely follow the arc contour.

Type: Type of arc. Set Type = 0 for entering three points, and Type = 1 for entering the start
point, center, and end point.

X1 Y1 Z1: Cartesian coordinates of the start point of the arc.
X2 Y2 Z2: Cartesian coordinates of the second point of the arc if Type = 0, or the arc center

if Type = 1.
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X3 Y3 Z3: Cartesian coordinates of the end point of the arc.
Radius: Wire radius.

Note: AN-SOF uses conformal segments that exactly follow the arc contour, distinguishing
it from NEC. The “GB” command is exclusive to AN-SOF and cannot be found in any NEC
version.

GM - Coordinate Transformation

The GM command in AN-SOF facilitates coordinate transformations with the following
syntax:

GM 0 N rotX rotY rotZ DX DY DZ 0

[Enter]

N: If N is set to 0, it implies that the entire structure above the GM command must undergo
rotation and translation based on the specified values for (rotX, rotY, rotZ) and (DX, DY, DZ).
The coordinate transformations are applied sequentially in that order. If N is set to 1, it
indicates that the structure above the GM command must be copied, and the copy should be
moved to a new position (DX, DY, DZ) from the origin. You can use the “GM” command
below the “GW,” “GH,” and “GA” commands to rotate, move, and copy linear wires, helices,
and arcs as needed.

rotX: Angle of rotation about the X-axis, specified in degrees.
rotY: Angle of rotation about the Y-axis, specified in degrees.
rotZ: Angle of rotation about the Z-axis, specified in degrees.
DX: Translation along the X-axis, moving the structure by an amount DX.
DY: Translation along the Y-axis, moving the structure by an amount DY.

DZ: Translation along the Z-axis, moving the structure by an amount DZ.

GS - Scale Structure Dimensions

The GS command in AN-SOF is used for scaling structure dimensions. The syntax is as
follows:

GS 0 0 Scale

[Enter]
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Scale: This represents the scaling factor. Applying this command results in the multiplication
of all structure dimensions, including wire radii, by the specified scale value.

GE - Ground Connections

The GE command in AN-SOF is used for defining ground connections. The syntax is as
follows:

GE Type
[Enter]

Type = 0: No ground plane is present. If a “GE” command is used without specifying a type,
it will be interpreted as “GE 0”.

Type = 1: APEC ground plane is placed at z = 0, and wires ending on the ground plane will
be connected to the ground. If a real ground plane has been chosen, Type = 1 indicates
that the wire connections to the ground must be considered as zero-Ohm connections.

Type = -1: The wire connections to the ground are imperfect and produce power losses
when a real ground plane has been chosen.

GN - Real Ground

The GN command in AN-SOF is used for defining real ground parameters. The syntax is as
follows:

GN Type Screen 0 0 Epsilon Sigma Length WireRadius
[Enter]
Type: Type of ground plane.

Type = -1: Free space simulation; all ground parameters are ignored. “GN -1” can be
used in this case.

Type = 0: Reflection Coefficients/Asymptotic option.

Type = 1: PEC ground plane at z = 0; other parameters are ignored. “GN 1” can be
used in this case.

Type = 2: Sommerfeld-Wait/Asymptotic option.

Screen: Number of radials in a radial wire ground screen. Set Screen = 0 if no ground
screen is present.
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Epsilon: Ground plane relative permittivity or dielectric constant.
Sigma: Ground plane conductivity in [S/m].

Length: Length of radial wires if a radial wire ground screen is used. Enter zero if no ground
screen is used.

WireRadius: Radius of radial wires if a screen is used. Enter zero if no ground screen is
used.

TL — Transmission Line

The TL command in AN-SOF is used to define a transmission line. The syntax is as follows:
TL Tag1 Seg1 Tag2 Seg2 Zc Length Y1r Y1i Y2r Y2i

[Enter]

Tag1: Wire tag number to which the first port of the transmission line connects.

Seg1: Segment number of wire Tag1 to which the first port of the transmission line connects.
Tag2: Wire tag number to which the second port of the transmission line connects.

Seg2: Segment number of wire Tag2 to which the second port of the transmission line
connects.

Zc: Characteristic impedance of the transmission line in Ohms. A negative Zc can be entered
to set a “crossed” transmission line with a 180° phase reversal relative to the reference
directions of the segments. The characteristic impedance of the line is |Zc|.

Length: Length of the transmission line in meters. If Length = 0, the linear distance between
the transmission line ports will be considered as the length for the line. To simulate a zero-
length transmission line, enter 1E-10.

Y1r: Real part of the shunt admittance across end one of the transmission line [S].
Y1i: Imaginary part of the shunt admittance across end one of the transmission line [S].
Y2r: Real part of the shunt admittance across end two of the transmission line [S].
Y2i: Imaginary part of the shunt admittance across end two of the transmission line [S].

Refer to Adding Transmission Lines for a review of considerations when setting
transmission lines, including advanced settings not available with the TL command.
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LD - Load Impedance

The LD command in AN-SOF is used to define a load impedance. The syntax is as follows:
LD Type Wire# Seg# Seg# RL C
[Enter]

Type: Type of load. Series RLC loads, fixed impedances R+jX, and wire conductivity can be
set.

o Set Type = 0 for a series RLC load.

o Set Type = 4 for a fixed impedance R+jX. The reactance “X” must be entered in the
position of “L” (the “C” field will be ignored). The reactance is fixed, so it does not scale
with frequency.

o Set Type = 5 and Seg# = 0 to specify a wire conductivity [S/m] in the “R” field for the
wire number “Wire#”. Use the command LD 50 0 0 R 0 0 to set a conductivity “R
[S/m]” on all wires. “LD 5” command for setting wire conductivity must be below
all “LD 0” and “LD 4” lines.

Wire#: Wire tag number where the load or conductivity is placed.

Seg#: Segment number where the load is placed. Note that it appears twice due to a NEC
convention not used in AN-SOF, so the second Seg# will be ignored. Set Seg# = 0 if a wire
conductivity is to be entered.

R: Resistance in Ohms or conductivity in S/m.

L: Inductance in Henries when Type = 0, or reactance in Ohms when Type = 4 (it does not
scale with frequency). The “L” field is ignored if R is a conductivity, so a zero can be entered.

C: Capacitance in Farads; if none, enter zero. It is ignored if R is a conductivity, so enter
zero.

IS — Insulated Wire

The IS command in AN-SOF is used to define an insulated wire. The syntax is as follows:
IS 0 Wire# 0 0 Epsilon 0 Radius

[Enter]

Wire#: Wire tag number where the insulation or coating will be applied.

Epsilon: Relative permittivity of the dielectric sheath.
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Radius: Radius of the insulating sheath. Ensure it is greater than the wire radius.

FR - Frequencies

The FR command in AN-SOF is used to specify frequencies for simulations. The syntax is as
follows:

FR Type Num 0 0 Freq Df
[Enter]

Type: Type of frequency sweep. For a linear sweep, set Type = 0; for a logarithmic sweep,
set Type = 1.

Num: Number of frequency steps.
Freq: Frequency in MHz or starting frequency in a range.

Df: If Type = 0, it represents the frequency stepping increment in MHz. If Type = 1, itis the
multiplication factor for a logarithmic sweep.

EX — Excitation

The EX command in AN-SOF is used to define excitation sources for simulations. The syntax
is as follows:

EX Type Wire# Seg# 0 Real Imag
[Enter]

Type: Type of source. Use Type = 0 or 5 (the “5” corresponds to an old source model used in
NEC) for a voltage source. Set Type = 6 for a current source. Note that current sources in
AN-SOF automatically have a non-zero internal impedance set in parallel with the source
(1E6 Ohm).

Wire#: Wire tag number where the source is placed.
Seg#: Segment where the source is located.
Real: Real part of the source voltage or current.

Imag: Imaginary part of the source voltage or current.
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EK - Exact Kernel

The EK command in AN-SOF is used to force the use of the Exact Kernel. The syntax is as
follows:

EK
[Enter]

This command ensures that the Exact Kernel is utilized, even if this option is disabled. It's
important to note that AN-SOF has the Exact Kernel enabled by default.

RP - Radiation Pattern

The RP command in AN-SOF is used to set the radiation pattern parameters. The syntax is
as follows:

RP 0 Ntheta Nphi 1001 Theta Phi Dtheta Dphi R

[Enter]

Ntheta: Number of values of © at which the field is to be computed.
Nphi: Number of values of ¢ at which the field is to be computed.

(Note: The value “1001” is a NEC variable and will be ignored since AN-SOF always
computes the average power gain.)

Theta: Initial © angle in degrees.
Phi: Initial @ angle in degrees.
Dtheta: Increment for © in degrees.
Dphi: Increment for ¢ in degrees.

R: Radial distance in meters of the field point from the origin. R = 0 is takenas R =1 m.

DXF Format

The DXF file format is a standard format for storing CAD (Computer Aided Design)
geometrical data as ASCII text lines.

Only DXF files containing LINE objects can be imported into AN-SOF. The structure of a
LINE entity is as follows, where only the (X,Y,Z) coordinates of the starting and ending points
are read:
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LINE

8 // Subclass marker. Not read

0 // Thickness (default = 0). Not read

10 // Starting point — 10, 20, 30 are tags — Not read
-0.5000 // X value

20 // Not read

-0.5000 /'Y value

30 // Not read

1.000 // Z value

11 // Ending point — 11, 21, 31 are tags — Not read
0.5000 // X value

21 // Not read

-0.5000 /'Y value

31 // Not read

1.000 // Z value

0 // Extrusion direction (default = 0) — Not read

Since LINE objects have zero thickness, AN-SOF will set a wire radius equal to 0.5% of the
wire length. The LINE coordinates in the DXF file are in meters. AN-SOF will also set the
number of segments for each wire according to the operating frequency, so it is
recommended to set the frequencies before importing the DXF file. Wire radii and the
number of segments can be modified after importing the DXF file using the Modify
command > in the main menu.

Download examples of DXF files to import into AN-SOF >

MM Format

One linear wire per line must be defined as follows:

X1,[TABJY1,[TABJZA,[TABJX2,[TAB]Y2,[TABJZ2,[TABJRadius,[TAB]Segments
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[Enter]

X1 Y1 Z1 = Cartesian coordinates of the wire start point.
X2 Y2 Z2 = Cartesian coordinates of the wire end point.
Radius = Wire radius.

Segments = Number of segments.

The last text line must end with an Enter (press Enter in the keyboard for a carriage return).

Example:

5.42, 0.38, 1.262, 5.425, -0.378, 1.261, 0.01, 12
7.45, 0, 1.122, 745, 0, 1.49, 0.015, 5
8.3, 0.0, 1.12, 8.37, 0.0, 1.595, 0.01, 2

[Enter]

In the MM format, automatic segmentation of a wire can be obtained by entering any number
equal or less than zero as the number of segments. The units for the coordinates of the start
and end points of any wire must be consistent with the length unit chosen in the AN-SOF
Preferences dialog box. Also, the wire radius or diameter of any imported wire must be
expressed in the unit chosen in the Preferences > dialog box.

Tabular Input of Linear Wires

Linear wires can be entered and edited in a table using the following steps:

1. Navigate to Draw > Tabular Input (Ctrl + T) in the main menu to display the “Tabular
Input” window (Fig. 1).

2. Select the Wires tab and enter values as specified in the column titles. Each row
corresponds to a linear wire, and you can input information such as the number of
segments (Segs), coordinates of the starting (X1, Y1, Z1) and ending (X2, Y2, Z2)
points, wire radius, resistivity, and coating (dielectric insulation). Note that only wires
with a circular cross-section can be entered, and transmission lines are not
supported in the Tabular Input. We recommend avoiding the use of Tabular Input
when transmission lines are included in the model.

3. Right-click on the table to display a pop-up menu with standard options such as Cut
(Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V).

https://antennasimulator.com/index.php/an-sof-user-guide/ 120/303


https://antennasimulator.com/index.php/knowledge-base/preferences/

12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

4. Single cells can be selected by left-clicking on them or by using the TAB and arrow
keys on the keyboard.

5. Rows can be selected by clicking on the row number in the left column (No. column).
Use the mouse or the up and down arrows on the keyboard to select a single row. The
selected wire (row) is highlighted in red in the workspace. Double-click on a cell to
exit row selection mode.

6. Cut (Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V) options apply to selected rows.
Additionally, you can use Insert (Ins key) and Delete (Del key) options to add or
remove rows.

7. The Clear Contents (Ctrl + Del) option in the pop-up menu clears the content of a
selected cell or row.

8. Utilize the Sources and Loads tabs to input sources and loads. The Wire No. column
specifies the wire on which the source or load is placed.

9. While the “Tabular Input” window is open, wire numbers will be displayed in the
Workspace next to the corresponding wires (Fig. 2). These wire numbers indicate the
order of the wires in the table. Wires do not have tags in AN-SOF, so when a wire is
deleted, the numbers will adjust accordingly. Wire numbers are only used to identify
wires in the Workspace while the “Tabular Input” window is open.

10. Note: The Tabular Input feature performs additional error checks. Therefore, opening
and closing this window will require recalculating results, even if no cells in the table

were edited.
B mbular Input — O d
Wires | Spurces  Loads
Mo, Segs X1 ¥i Zi X2 ¥2 Z2 Radius Resistivity | Coat. Perm. Coat. Thick.

- - mm mm mm mm mm mm mm Ohm m - mm

%

3 7 232 330 0 222 330 0 Cut Ctrl+X 0
Copy Ctrl+C

4 7 218 550 o 218 550 0 0
Paste Ctrl+V

5 7 219 850 0 219 850 0 0

6 7 221 1150 0 221 1150 0 s = 0
Delete Del

7 7 213 1450 ] -219 1450 0 0
Clear Contents Ctrl+Del

Fig. 1: Tabular input of linear wires.
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m Tabular Input

Wires  Sources  Loads

Mo, Segs

Fig. 2: Tabular Input window with wire numbers displayed in the workspace.

Editing Wires

Selecting a Wire

Ways to Select a Wire

Any wire in the workspace can be selected in three different ways:

1. By clicking on the Select Wire button (arrow icon) on the toolbar and then left clicking

on the wire.
2. By right clicking on the wire. In this case, a pop-up menu will be displayed, Fig. 1.

3. By pressing F8 or F9 on the keyboard. In this case, the wires will be selected one by
one, forwards or backwards, in the order in which they were created.

A wire is highlighted in light blue when it is selected.
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B &N-50F - HeleGND

File Edit Draw View Toels Run  Results  Help
* (G @ S a8 XK B e 2 3 N Fy fy $3 (8| | XY yI

Setup  WorkSpace  Feedlne  Resuts

oy  Source/Load Cirl=Ins
P Madify Cerls M

Wire Color
Delete Ctri+Del
Copy Start Point
Copy End Point
g Plot Currents

1| List Currents...

Wire Properties... Ctrl=W

Wires: 291 Sources: 1 Loads=0 Segments: 439 Connections: 434 GMNDs: D Total: £93

Fig. 1: Pop-up menu displayed when a wire is selected by right
clicking on it.

The Pop-Up Menu

Right-clicking on a wire brings up a menu with the following commands:
Source/Load (Ctrl + Ins)

Displays the Source/Load toolbar for exciting or loading the selected wire.
Modify (Ctrl + M)

Displays the Modify dialog box for modifying the selected wire.

Wire Color

Displays a Windows(R) dialog box for changing the color of the selected wire.
Delete (Ctrl + Del)

Deletes the selected wire with all sources and loads placed on it.
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Copy Start Point

Copies the start point of the selected wire to connect this point to the start point of another
wire.

Copy End Point

Copies the end point of the selected wire to connect this point to the start point of another
wire.

Plot Currents

Executes the AN-XY Chart application for plotting the currents vs. position along the selected
wire. This command is enabled when the currents are already computed.

List Currents

Displays the List Currents toolbar for listing the currents vs. frequency at the selected wire
segment. This command is enabled when the currents are already computed.

Wire Properties (Ctrl + W)
Displays the Wire Properties dialog box where information about the selected wire is shown.
Draw

Contains a sub-menu with the Line, Arc, Circle, Helix, Quadratic, Archimedean Spiral, and
Logarithmic Spiral commands to draw these types of wires.
Modifying a Wire

Right-clicking on a wire brings up a menu. Choosing the Modify command from the pop-up
menu > shows the Modify dialog box, where the geometrical parameters and attributes of
the selected wire can be modified.

The Modify command can also be chosen by first selecting a wire by left clicking on it, and
next going to Edit > Modify in the main menu. This option is enabled when the Select Wire
button (arrow icon) in the main toolbar is pressed.

Deleting a Wire

Right-clicking on a wire brings up a menu. Choosing the Delete command from the pop-up
menu > deletes the selected wire with all sources and loads placed on it.
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The Delete command can also be chosen by first selecting a wire by left clicking on it, and
next going to Edit > Delete in the main menu. This option is enabled when the Select Wire
button (arrow icon) in the main toolbar is pressed.

Modifying a Group of Wires

AN-SOF allows the simultaneous editing of a group of wires. Click on the Selection Box
button on the main toolbar. Left-click on the workspace, drag a box with the mouse, and
select multiple wires (Fig. 1). All wires within the selection box will be highlighted in light blue.

Go to Edit > Modify in the main menu to modify the selected wires. The Modify command
displays the dialog box shown in Fig. 2, with three tabs: Attributes, Materials, and
Sources/Loads. Use the checkboxes to choose the parameters you want to modify. Note
that sources and loads will not be removed unless specified in the Sources/Loads tab.

B 21-50F - Yagi-Udas
File Edit Dravw Wiew Toals Fum Results Htlp

» I o x5 s ra . y y ' 17 ’
= = @ W N 2y & B ~ K Ty I g w | X¥ ¥yI Ix i il

Setp  WorkSpale  Fepdlline Reslls

Fig. 1: Box to select a group of wires.

In the Attributes tab, the Segments per Wire and Segments per Wavelength options
allow for the mass editing of wire segments. These options are mutually exclusive.
“Segments per Wire” sets a fixed number of segments for all selected wires, while
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“Segments per Wavelength” sets the number of segments for each wire based on its length
in wavelengths, considering the shortest wavelength corresponding to the highest
frequency set.

B Modify Wires - O ¥
Attributes  Materials = Sources [ Loads

[] Segments per Wire 0
Segments per Wavelength

[] cross section Circular

a [mm] 0

oK Cancel

Fig. 2(a): The Attributes tab in the “Modify
Wires” dialog box.

B Modify Wires - O X
Attributes  Materials  Spurces [ Loads

Wire Resistivity [Ohm m]

|Cnpper v| |1.I-'4E-B

Wire Coating

[] relative Permitivity & |1
[ ] relative Permeability 1 1

[] Thickness [mm] 0

oK Cancel

Fig. 2(b): The Materials tab in the “Modify
Wires” dialog box.
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B Modify Wires - O X
Attributes Materials | Sources /Loads |
] Delete Sources

[] Delete Loads

OK Cancel

Fig. 2(c): The Sources / Loads tab in the “Modify
Wires” dialog box.

Deleting a Group of Wires

Click on the Selection Box button in the main toolbar. Then, left clicking on the workspace a
box to select multiple wires can be expanded. The selected group of wires will be highlighted
in light blue, Fig. 1.

Go to Edit > Delete in the main menu to delete the selected group of wires. The Delete
command can also be executed by pressing Ctrl + Del or the Delete button on the toolbar.
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B AM-50F - Yagi-Udas
File Edit Drawr Yiew Tecks Run Resulis Help

= = - (B3N Fx fy 7 @ | XY ¥I x| TR M

Setup  WorkSpace  Feedline  Results

Fig. 1: Box to select a group of wires.
Wire Color

Right clicking on a wire shows a pop-up menu >. Choose the Wire Color command to
display a dialog box that allows us to select a color for the wire. This command is enabled
when a wire is selected.

The Wire Color command can also be accessed by first pressing the Select Wire button
(arrow icon) on the toolbar, then left clicking on the wire to select it, and finally going to Edit
> Wire Color in the main menu. The Wire Color command is also available as a button on
the toolbar.

The color of a group of wires can be changed by first selecting the wires and next clicking on
Edit > Wire Color in the main menu. A group of wires can be selected by expanding a
selection box as explained in Modifying a group of wires >.

Wire Properties

Right clicking on a wire will display a pop-up menu >, where the Wire Properties command
can be selected.
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The Wire Properties command can also be accessed by first pressing the Select Wire
button (arrow icon) on the toolbar, then left clicking on the wire to select it, and finally going
to Edit > Wire Properties in the main menu. The Wire Properties command is also available
as a button on the toolbar.

Execute the Wire Properties command to display the Wire Properties dialog box. There are
three pages: Geometry, Attributes, and Materials.

The Geometry page

It shows the geometrical properties of the selected wire, Fig. 1, namely,

o Start Point: Coordinates of the start point of the selected wire.

¢ End Point: Coordinates of the end point of the selected wire.

¢ Length: Wire length.

* Longest Segment: The length of the longest segment.

o Shortest Segment: The length of the shortest segment.

o Shortest Wavelength (A): The wavelength related to the highest frequency.

» Length/A: Wire length in wavelengths. The wavelength corresponds to the highest
frequency.

* Longest Segment/A: Length of the longest wire segment in wavelengths. The
wavelength corresponds to the highest frequency.

» Shortest Segment/A: Length of the shortest wire segment in wavelengths. The
wavelength corresponds to the highest frequency.
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Wire Properties >

Geometry  Atiributes  Materials

Start Point [m]

¥1(0.3 ¥1H0.22 Z1D
End Point [m]

¥2 0.3 ¥2 H0.22 20
Length [m] 0.6
Longest Segment [m] 0.0545455
Shortest Segment [m] 0.0545455

Shortest Wavelength [m] 3. 0.938851

Length / & 0.540443

Longest Segment [ 3, 0.0582221

Shortest Segment / A, 0.0532221
Ok

Fig. 1: Wire Properties dialog box. The
Geometry page shows the geometrical
properties of the selected wire.

The Attributes page

It shows the electrical properties of the selected wire, Fig. 2, namely,

e Number of Segments: The number of segments into which the selected wire has
been divided.

e Number of Sources: The number of sources placed on the wire.

o Number of Loads: The number of loads placed on the wire.

o Cross-Section: The cross-section type and its dimensions.

o Equivalent Radius: The cross-section equivalent radius >.

o Equivalent Radius/A: The cross-section equivalent radius as a fraction of the shortest
wavelength.

e Thin-Wire ratio: The wire diameter to the shortest segment length ratio. It must be
less than 3 when the Exact Kernel option is unchecked in the Settings panel > of the
Setup tabsheet. Check the Exact Kernel option to be able to calculate with any
value of the thin-wire ratio. For a non-circular cross-section, the wire diameter is two
times the equivalent radius of the cross-section.
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Wire Properties >

Mumber of segments 10

Mumber of Sources ]

Mumber of Loads 0

Cross Section Circular
a[mm] #

Equivalent Radius [mm] 4

Equivalent Radius [ & 0.00426962

Thin-Wire Ratio 0. 146667

Ok

Fig. 2: Wire Properties dialog box. The

Attributes page shows the segmentation used

for the selected wire, the number of sources

and loads placed on the wire, and the type of

cross section.

» Wire Resistivity: The resistivity of the selected wire in [Ohm m]. If the wire is coated, it

is the resistivity of the internal conductor.

* Wire Coating: The parameters of the coating shield of the selected wire.
» Relative Permittivity: The permittivity or dielectric constant of the coating material

relative to the permittivity of vacuum.

» Relative Permeability: The magnetic permeability of the coating material relative to

the permeability of vacuum.

It shows the properties of the materials the selected wire is made of, Fig. 3, namely,

e Thickness: The thickness of the coating shield.
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Wire Properties >

Wire Resistivity [Chmm] [

Wire Coating

Relative Permittivity g 1

Relative Permeability o [

Thickness [mm] o

QK

Fig. 3: Wire Properties dialog box. The
Materials page shows the material parameters
of the conductive wire and its coating shield or

insulation.

Connecting Wires

A wire junction is automatically established whenever the coordinates of a wire end are
identical to the end coordinates of a wire previously specified. However, two wires will be
also connected automatically when their ends are spaced one tenth of the wire radius. Wire
junctions must be established to satisfy Kirchhoff’s current law at the connection point.

Figure 1 shows the correct and incorrect ways to connect two wires. To connect the end of
wire 1 to a point on another wire 2 that is not another end, you must split wire 2 into two
wires. So, three wires will be needed instead of two to make the connection.
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Wire 2 Wire 2 Wire 3

WRONG x RIGHT /

Wire 1 — Wire 1

Fig. 1: Wrong and right ways to connect wires.

Two wires can be connected by copying and pasting their ends. The following procedure will
show how to connect the Start Point of a wire #1 to the Start Point of a wire #2.

Procedure for connecting two wires at their ends

1. Right clicking on wire #1 will display a pop-up menu.
2. Choose the Copy Start Point or Copy End Point command from the pop-up menu.

This command is also available in the Wire Properties window of the selected wire, Fig.

1.
3. In this example, wire #2 will be a Line. Then, choose Draw/Line in the main menu to

display the Draw dialog box for the Line.
4. Press the From Point button to paste the copied point, Fig. 2. Then, complete the
definition of wire #2.

By means of this procedure, any number of wires can be connected at the same point.
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Geometry | Attributes | Materials |

Start Point [m]

X10.07 Copy F'ointl 1P

X2 0.07 Y20 72 0.5
Length [m] 0.5
Longest Segment [m) 0.03125
Shortest Segment [m] 0.03125
Shortest Wavelength [m] WL D.99930819
Length / WL 0.5003461428
Longest Segment /WL 0.03127163392
Shortest Segment / WL 0.03127163392

Fig. 1(a): Wire Properties dialog box. Click on the
“Start Point” button to copy a wire end.
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x2 0.07 Copy Pointi 2205

Length [m] 0.5

Longest Segment [m] 0.03125

Shortest Segment [m] 0.03125

Shortest Wavelength [m] WL 0.99930819
Length / WL 0.5003461423
Longest Segment / WL 0.03127163392
Shortest Segment / WL 0.03127163392

Fig. 1(b): Wire Properties dialog box. Click on the
“End Point” button to copy a wire end.

Line | Attributes | Materials |

Options: | 2Points

[ From Point [m] l

X1 0 Paste Point

To Point [m]

X2 0

Fig. 2: Draw dialog box for wire #2. Click on the “From
Point” button to paste the copied end of wire #1.

Moving, Rotating, and Scaling Wires
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After drawing the wire structure, you may need to modify the position or size of individual
wires or groups of wires. To modify wires, you must first select them. Click on the Selection
Box button on the toolbar and then expand a box using the mouse with the left button
pressed. Enclose the wires you want to modify within the box (Fig. 1).

B 2n-50F - Project!
Edt  Dvww  View Togls Buen  Results Help

File
1§ Unde ClsZ | K | & -_-\ fy ¥y ¥1 4 L | ¥ wr ozx | B B b b = >
I

Selection Box

P Mo dify Cirl+ M

& Wire Color

Delete Cel= el

Cogry Start Pesnt

Cepy End Point

Copy Wines_.

Mo Wires...
Rotate Wires

Scabe Wires...

Stack Wires...

Fig. 1: “Selection Box” button on the toolbar to select a group of wires and commands in the Edit menu to
move, rotate, and scale the selected wires.

Once the wires are selected, go to the Edit menu and choose one of the following
commands:

Move Wires

Displays the Move Wires dialog box for moving the selected wire or group of wires to a
different position (Fig. 2). You can enter a different shift along each coordinate X, Y, and Z.
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Mowe Wires
Move X by m
Move ¥ by m
Move Z by m
OK Cancel

Fig. 2: Move Wires dialog box.

Rotate Wires

Displays the Rotate Wires dialog box for rotating the selected wire or group of wires around
the chosen axis (Fig. 3). In addition to the Cartesian axes X, Y, and Z, the “Custom” option
allows you to set a rotation axis using spherical coordinates (Theta, Phi). You can also set
the Rotation Center if you want to rotate around a point other than the origin.

Rotate Wires

Rotation Axis

®x Oy iz () Custom

Axis Orientation [deq] Rotation Center [m]

Theta |90 %0 |15

Phi 0
Y0

Rotation Amount [deq]

QK Cancel

JII[

Fig. 3: Rotate Wires dialog box.

Scale Wires

Displays the Scale Wires dialog box for scaling the selected wire or group of wires (Fig. 4).
Three options are available:

Single Factor: Allows you to set a single scale factor that will be applied to all the point
coordinates of the selected wires. You can also scale the wire cross-section and
coating thickness by the same factor by checking the corresponding boxes.
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factor and specify an anchored point: the line’s start point P1 or end point P2. By

specifying an anchored point, you can lengthen or shorten the line while keeping one of

its ends fixed.

Advanced: Allows you to set a different scale factor for each Cartesian coordinate of

the selected wires. This option enables you to stretch or contract a group of wires
along the direction of one of the Cartesian axes: X, Y, or Z.

Scale Wires

(®) Single Factor (C)Line Length () Advanced

Scale Factor

Scale Wire Cross-Section

[] Scale Coating Thickness

Scale Wires

(O Single Factor (®)Line Length () Advanced

Scale Factor

Anchor
(®) StartPoint P1

() End Point P2

Scale Wires

() Single Factor (_)Line Length (@) Advanced

¥ Scale Factor
¥ Scale Factor
Z Scale Factor

OK Cancel OK Cancel OK Cancel

Fig. 4: Scale Wires dialog box. (Left) “Single Factor” option. (Center) “Line Length” option. (Right)
“Advanced” option.
Copying and Stacking Wires

When drawing a wire structure, it is often necessary to copy wires from one position to
another. An antenna array is an example of such a scenario. To copy wires, you must first
select them by pressing the Selection Box button on the toolbar and then expanding a box
using the mouse to enclose the wires you wish to copy, as explained in the Moving,
Rotating and Scaling Wires section.

In the Edit menu, you will find the following commands for copying the selected wires:

Copy Wires

Displays the Copy Wires dialog box for copying the selected wire or group of wires (Fig. 1).
You can specify the number of copies of the selected group of wires. The first copy will be
offset from the original wire group according to the entered X, Y, and Z offsets and/or rotated
around each axis according to the entered angles. Subsequently, each copy will be offset
and/or rotated relative to the previous copy.
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Copy Wires
Move X by D m Rotate around ¥ axis by IZI deg
Maove ¥ by m Rotate around Y axis by ICI deg
Maove Z by D m Rotate around Z axis by deg

Ok Cancel

)

Mumber of Copies

Stack Wires

Fig. 1: Copy Wires dialog box.

Displays the Stack Wires dialog box for stacking the selected wire or group of wires along
the specified direction and according to the given number of elements in the stack (Fig. 2).
An “element” in the stack is composed of the selected wires, so an element could be a single
wire or a group of wires. You must also specify the spacing between the elements.

Stack Wires..,

Stacking Axis
% (OF iz () Custom
Axis Orientation [deq] Position

Theta 20
(@ Center the Stack

Phi 20

Spading [mm] () Stack Forward

Mumber of Elements

s ]

Ok Cancel

() Stack Backward

Fig. 2: Stack Wires dialog box.

Grids and Surfaces

Types of Grids and Surfaces

The grids are wire frameworks with holes on the surface they depict, whereas the surfaces
represent solid metal sheets without holes. The wires of a grid do not overlap but are
connected to each other. Wires used in grids or surfaces can be straight or curved.
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AN-SOF offers various types of grids and surfaces, each with its unique geometric
parameters and attributes that can be configured in dedicated Draw dialog boxes.

To access these options, navigate to Draw > Wire Grid / Solid Surface in the main menu,
where you will find the following choices:

o Patch: Opens the Draw dialog box for creating a rectangular patch parallel to the xy-
plane.

o Plate: Opens the Draw dialog box for creating a plate or bilinear surface.

e Disc: Opens the Draw dialog box for creating a disc.

» Flat Ring: Opens the Draw dialog box for creating a flat ring, which is a disc with a
hole at its center.

e Cone: Opens the Draw dialog box for creating a cone.

e Truncated Cone: Opens the Draw dialog box for creating a truncated cone.

e Cylinder: Opens the Draw dialog box for creating a cylinder.

o Sphere: Opens the Draw dialog box for creating a sphere.

o Paraboloid: Opens the Draw dialog box for creating a paraboloid.

Tip

Go to View > Drawing Panel in the main menu to quickly access the wire grids and

solid surfaces.
Grid/Surface Attributes

The Attributes page is part of the Draw dialog box for various wire grids and solid surface
types. As shown in Fig. 1, this example illustrates the Attributes page for the Plate, but note
that all grids and surfaces share the same Attributes page.
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Draw Draw
Plate  Attributes  Materials Plate  Attributes  Materials
Mumber of Facets |1EI | x |1EI | Mumber of Facets |1EI | x |1EI |
Segments per Wire |2 | Segments per Wire |2 |
Cross Section | v| Cross Section | v|

Auto-calculated 'w' for
2.5
a [mm] _ solid surface

— N —

QK Cancel QK Cancel

Fig. 1: Attributes page in the Plate Draw dialog box. Selection of Circular cross-section
represents a wire grid, while Flat or Rectangular cross-section represents a solid surface.

To select between a wire grid or a solid surface, refer to the “Cross-Section” field below.
Wire grids consist of wires with a specified circular cross-section, leaving gaps between
them, while solid surfaces use flat wires whose width is automatically adjusted to cover the
surface without gaps.

On the Attributes page, you can set the following parameters:

Number of Facets

Each grid or surface consists of a specific number of facets. For instance, the plate shown
here has a 10x10 arrangement of facets, while the disc here has 6x12 facets. Each facet is
a quadrilateral formed by four wires, with each wire divided into segments.

For solid surfaces, the wires are essentially flat strips that cover the entire surface. In the
AN-SOF workspace, only the strip axes are displayed. During the simulation process, an
unknown current is determined for each wire segment.

You have the flexibility to individually edit any curved or straight wire that comprises a grid or
surface. Refer to Modifying a Wire for details on editing individual wires. If you need to
make mass edits to the wires that make up a grid or surface, please refer to Modifying a
Grid/Surface.

In the case of a Patch, setting the number of facets to 0x0 results in an automatic
calculation. The calculation considers 10 segments per wavelength along each side of the
patch, with the wavelength corresponding to the highest frequency defined.
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Segments per Wire

This parameter determines the number of segments for each wire within the grid/surface. If
“Segments per Wire” is set to zero, each wire will be automatically divided into segments,
with the calculation based on a default value of 10 segments per wavelength.

Please note that the Patch type does not offer the option to specify “Segments per Wire”
since its facets are composed of one-segment wires and the number of facets can be
automatically computed by setting 0x0 facets.

Cross-Section

To define a wire grid, choose a Circular cross-section and set the radius of the wires
comprising the grid, as shown in Fig. 1 on the left. Wire grids cannot have infinitesimally thin
wires, so the cross-section radius “a” must be greater than zero.

To define a solid surface, select either the Flat or Rectangular cross-section for the wires
that constitute the surface, as shown in Fig. 1 on the right. These wires are essentially flat
strips that completely cover the surface. With the ‘Rectangular’ cross-section option, you
can specify the thickness of the solid surface.

Modifying a Grid/Surface

A grid or surface can be modified using the procedure described in Modifying a Group of
Wires. To select multiple wires, wire grids, or solid surfaces, click on the Selection Box
button on the main toolbar. Left-click on the workspace, drag the mouse to create a selection
box, and all wires within it will be highlighted in light blue, as shown in Fig. 1.

To apply modifications to the selected wires, go to Edit > Modify (you can also use the
shortcut Ctrl + M), or use the Modify button on the toolbar. This command becomes active
when you have a group of wires, a wire grid, or a solid surface selected. For details on the
dialog window that allows you to modify selected wires, please refer to Modifying a
Group of Wires.

If you need to perform actions such as moving, rotating, scaling, copying, or stacking
wire grids and solid surfaces, please consult Moving, Rotating and Scaling Wires
and Copying and Stacking Wires for more information.
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Fig. 1: A wire grid selected by the Selection Box.
Deleting a Grid/Surface

Click on the Selection Box button in the main toolbar. By left-clicking on the workspace and
dragging a box with the mouse, you can select a wire grid or a solid surface, as explained in
Modifying a Grid/Surface or Modifying a Group of Wires. All wires inside the selection
box will be highlighted in light blue.

Go to Edit > Delete (Ctrl + Del) in the main menu to delete the selected grid or surface.
There is also a button on the toolbar with the Delete command. This command is enabled
when a group of wires, a wire grid, or a solid surface is selected.

Grid/Surface Color

Click on the Selection Box button in the main toolbar. By left-clicking on the workspace and
dragging a box with the mouse, you can select a wire grid or a solid surface, as explained in
Modifying a Grid/Surface or Modifying a Group of Wires. All wires inside the selection
box will be highlighted in light blue.

Go to Edit > Wire Color in the main menu to change the color of the selected grid or
surface. A dialog window will be opened where a color can be chosen. There is also a button
on the toolbar with the Wire Color command. This command is enabled when a group of
wires, a wire grid, or a solid surface is selected.
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Adding Wire Grids/Solid Surfaces

Patch

A Patch in AN-SOF represents a solid rectangular conductive surface lying on the xy-
plane or a plane parallel to it (z = constant). This structure consists of wires with a flat or
rectangular cross-section that cover the entire surface of the patch.

You can use this command to model patch antennas, where the patch is a solid
rectangular metal sheet. To do this, you must choose the Substrate option as the ground
plane by navigating to the Setup tab > Environment panel > Ground Plane box.

If you need to model a solid rectangular surface or a rectangular wire grid in free space or
above a real ground plane, use the Plate command instead of Patch.

To access the Patch command, go to Draw > Wire Grid / Solid Surface > Patch in the main
menu. The displayed dialog box consists of three pages: Patch, Attributes, and Materials,
detailed in Fig. 1.

The Patch page

On the Patch page, you can configure the geometric parameters for the Patch. To define the
Patch, specify the coordinates of two opposite corner points in a plane z = constant, as
illustrated in Fig. 2.

Once you’ve configured the geometric parameters on the Patch page, you can proceed to
the Attributes page, where you can specify the number of facets for the Patch. See
Grid/Surface Attributes for additional parameters in the Attributes page and Wire
Materials for parameters in the Materials page.
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| Attributes | Materials |

Point 1 [mm]
X1 -50 Y1 -100

Point 2 [mm]
X2 50

Fig. 1: Patch page of the Draw dialog box.
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Fig. 2: A Patch drawn using the input data of Fig. 1.
Plate

The Plate command refers to a plate or bilinear surface.

To access the Plate command, go to Draw > Wire Grid / Solid Surface > Plate in the main
menu. The dialog box for the Plate command contains three pages: Plate, Attributes, and
Materials, detailed in Fig. 1.

The Plate page

In the Plate page, you can set the geometrical parameters for the Plate. The Plate is defined
by specifying the coordinates of its four corner points. In general, a plate or bilinear surface
is a non-planar quadrilateral, uniquely defined by its four vertices, as shown in Fig. 2. In
some cases, the bilinear surface degenerates into a flat quadrilateral.
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After setting the geometrical parameters on the Plate page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Plate and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Plate | Attributes | Materials |

Point 1 [m]
X10
Point 2 [m]
X2 0
Point 3 [m]
X3 0
Point 4 [m]

X4 0

Fig. 1: Plate page of the Draw dialog box.
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Fig. 2: A Plate drawn using the input data of Fig. 1.
Disc

The Disc command is used to create a disc or circular surface.

To access this command, go to Draw > Wire Grid / Solid Surface > Disc in the main menu.
This action will open the Draw dialog box for the Disc. The dialog box consists of three
pages: Disc, Attributes, and Materials, as detailed in Fig. 1.

The Disc page

In the Disc page, you can configure the geometrical parameters for the Disc. Here, you'll find
a combo-box offering two options: Curved segments and Straight segments. Select
Curved segments for an exact representation of the disc’s curvature. The Straight
segments option provides an approximation using linear wires.

The Disc is defined by specifying the Center coordinates, Radius, and orientation angles,
Theta and Phi. These parameters uniquely define a planar disc surface, as illustrated in Fig.
2.
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After setting the geometrical parameters on the Disc page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Disc and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

1| attributes | Materials

Options: [Straight segments

Center [m]
Cx0 Cy 0

Disc Radius [m] 10

Orientation Angles [deg]

Theta 90

Fig. 1: Disc page of the Draw dialog box.
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Fig. 2: A Disc drawn using the input data of Fig. 1.

Theta = 90°
Phi=0°

Flat Ring
The Flat Ring command creates a disc with a hole at its center.

To access this command, go to Draw > Wire Grid / Solid Surface > Flat Ring in the main
menu. This action opens the Draw dialog box for the Flat Ring. The dialog box comprises
three pages: Flat Ring, Attributes, and Materials, detailed in Fig. 1.

The Flat Ring page

On the Flat Ring page, you can specify the geometrical parameters for the Flat Ring. Here,
you’ll find a combo-box offering two options: Curved segments and Straight segments.
Choose Curved segments for an exact representation of the flat ring’s curvature. The
Straight segments option provides an approximation using linear wires.

The Flat Ring is defined by providing the Center coordinates, Inner Radius (hole radius),
Outer Radius, and orientation angles, Theta and Phi. These parameters uniquely define a
planar flat ring surface, as illustrated in Fig. 2.
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After setting the geometrical parameters on the Flat Ring page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Flat Ring and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Ring || Attributes | Materials |

Options: [Slraight segments

Center [m]

Cx 0 Cy0 Cz 0

Inner Radius [m] Outer Radius [m]
5 10

Orientation Angles [deg]

Theta 90

Fig. 1: Flat Ring page of the Draw dialog box.
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Fig. 2: A Flat Ring drawn using the input data of Fig. 1.
Cone

The Cone command creates a cone-shaped structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Cone in the main
menu, which opens the Draw dialog box for the Cone. The dialog box comprises three
pages: Cone, Attributes, and Materials, as detailed in Fig. 1.

The Cone page

On the Cone page, you can set the geometrical parameters for the Cone. You'll find a
combo-box with two options: Curved segments and Straight segments. Choose Curved
segments for an exact representation of the cone’s curvature, while the Straight segments
option provides an approximation using linear wires.
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The Cone is defined by specifying the Vertex coordinates, Aperture Angle, Aperture
Radius, and orientation angles, Theta and Phi. These parameters uniquely define the
cone’s surface, as illustrated in Fig. 2.

After setting the geometrical parameters on the Cone page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Cone and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

[ Cone | Attrbutes [ materias

Options: [Strai;ht segments V]

Vertex [m]

vx 0 Vy O vz O

Aperture Angle [deg] Aperture Radius [m]
45 10

Orientation Angles [deg]

Theta 90 Phi S0

[ o | [ cond ]

Fig. 1: Cone page of the Draw dialog box.
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Fig. 2: A Cone drawn using the input data of Fig. 1.
Truncated Cone

The Truncated Cone command creates a truncated cone-shaped structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Truncated Cone in the
main menu, which opens the Draw dialog box for the Truncated Cone. The dialog box
comprises three pages: Truncated Cone, Attributes, and Materials, as detailed in Fig. 1.

The Truncated Cone page

On the Truncated Cone page, you can set the geometrical parameters for the Truncated
Cone. You'll find a combo-box with two options: Curved segments and Straight segments.
Choose Curved segments for an exact representation of the truncated cone’s curvature,
while the Straight segments option provides an approximation using linear wires.

The Truncated Cone is defined by specifying the Base Point coordinates, Base Radius,
Top Radius, Aperture angle, and orientation angles, Theta and Phi. These parameters
uniquely define the truncated cone’s surface, as illustrated in Fig. 2. Depending on its
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parameters, a truncated cone can take on various shapes, including a cylinder, a cone, a

disc, or a flat ring.

After setting the geometrical parameters on the Truncated Cone page, you can move on to
the Attributes page. Here, you can specify the number of facets for the Truncated Cone
and choose whether it should be a wire grid or a solid surface. See Grid/Surface
Attributes for additional parameters in the Attributes page and Wire Materials for

parameters in the Materials page.

AN-SOF User Guide » AN-SOF Antenna Simulation Software

[ Truncated Cone || Attrbutes | Materiais

Options:

straight segments v |

Base Point [m]

Px 0

Py 0 Pz O

Base Radius [m] Top Radius [m] Aperture [deg]

5

10 45

Orientation Angles [deg]

Theta 0 Phi 0

Fig. 1: Truncated Cone page of the Draw dialog box.
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Fig. 2: A Truncated Cone drawn using the input data of Fig. 1.
Cylinder

The Cylinder command creates a cylindrical structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Cylinder in the main
menu, which opens the Draw dialog box for the Cylinder. The dialog box comprises three
pages: Cylinder, Attributes, and Materials, as detailed in Fig. 1.

The Cylinder page

On the Cylinder page, you can set the geometrical parameters for the Cylinder. You'll find a
combo-box with two options: Curved segments and Straight segments. Choose Curved
segments for an exact representation of the cylinder’s curvature, while the Straight
segments option provides an approximation using linear wires.

The Cylinder is defined by specifying the Base Point coordinates, Length, Radius, and
orientation angles, Theta and Phi. These parameters uniquely define the cylinder’s surface,
as illustrated in Fig. 2.

After setting the geometrical parameters on the Cylinder page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Cylinder and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
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additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Options: |Straight segments

Base Point [m]
Px 0 Py 0 Pz -5

Length [m] Radius [m]
10 2.5

Orientation Angles [deg]

Theta 0

Fig. 1: Cylinder page of the Draw dialog box.
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Fig. 2: A Cylinder drawn using the input data of Fig. 1.
Sphere

The Sphere command creates a spherical structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Sphere in the main
menu, which opens the Draw dialog box for the Sphere. The dialog box comprises three
pages: Sphere, Attributes, and Materials, as detailed in Fig. 1.

The Sphere page

On the Sphere page, you can set the geometrical parameters for the Sphere. You'll find a
combo-box with two options: Curved segments and Straight segments. Choose Curved
segments for an exact representation of the sphere’s curvature, while the Straight
segments option provides an approximation using linear wires.
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The Sphere is defined by specifying the Center coordinates, Radius, and orientation angles,
Theta and Phi. These parameters uniquely define the sphere’s surface, as shown in Fig. 2.

After setting the geometrical parameters on the Sphere page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Sphere and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

Sphere || Atirbutes | Materiais |

Options: [Strai#‘nt segments ']

Center [m]

Cx 0 Cy 0

Radius [m] 5

Orientation Angles [deg]

Theta 0

Fig. 1: Sphere page of the Draw dialog box.
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Fig. 2: A Sphere drawn using the input data of Fig. 1.
Paraboloid

The Paraboloid command creates a paraboloidal structure.

To access this command, go to Draw > Wire Grid / Solid Surface > Paraboloid in the main
menu, which opens the Draw dialog box for the Paraboloid. The dialog box comprises three
pages: Paraboloid, Attributes, and Materials, as detailed in Fig. 1.

The Paraboloid page

On the Paraboloid page, you can set the geometrical parameters for the Paraboloid. You'll
find a combo-box with two options: Curved segments and Straight segments. Choose
Curved segments for an exact representation of the paraboloid’s curvature, while the
Straight segments option provides an approximation using linear wires.
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The Paraboloid is defined by specifying the Vertex coordinates, Focal Distance, Aperture
Radius, and orientation angles, Theta and Phi. These parameters uniquely define the
paraboloid’s curved surface, as shown in Fig. 2.

After setting the geometrical parameters on the Paraboloid page, you can move on to the
Attributes page. Here, you can specify the number of facets for the Paraboloid and choose
whether it should be a wire grid or a solid surface. See Grid/Surface Attributes for
additional parameters in the Attributes page and Wire Materials for parameters in the
Materials page.

[ Parabolod || attrbutes | Materiais|

Options: [Strai;ht segments V]

Vertex [m]

vx 0 Vy O vz O

Focal Distance [m] Aperture Radius [m]
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Fig. 1: Paraboloid page of the Draw dialog box.
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Aperture
Radius =10 m

Vertex #i
{0!090} h:".,
9 Theta = 90°
10 Phi = 90°

Fig. 2: A Paraboloid drawn using the input data of Fig. 1.

Sources and Loads

Types of Excitations and Loads

Discrete Sources, Incident Field, and Loads

A structure can be excited by discrete sources or an incident field. Refer to Excitation by an
Incident Field > for the second case. Discrete sources can be located on any wire segment
and there can be more than one source, as many as there are segments.

A source is used to model the feed point of a transmitting antenna or generator in an
electrical circuit. There are two types of sources:

+ Voltage sources
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e Current sources
Current sources can be used to model impressed currents.

For each source, its amplitude and phase must be set. Internal impedances can also be
added to model imperfect sources, which can be series RL, series RC, or R+jX impedances.

Lumped loads can also be added to any wire segment, representing resistors, inductors,
capacitors, or fixed impedances. There are three types of loads:

» Series RL impedance (inductive)
» Series RC impedance (capacitive)
» Fixed R+jX impedance (the reactance X does not scale with frequency)

To model a pure resistor, add an inductive impedance with L = 0. The unit of inductance can
be pH, nH, uH, mH or H, while that of capacitance can be pF, nF, uF, mF or F. These units
can be set going to main menu > Tools > Preferences >.

Tips

Sources are displayed as a yellow circle in the workspace, while loads are
displayed as a green highlighted segment. To change the default colors, go to
main menu > Tools > Preferences > Workspace tab.

Voltage sources have their internal impedance in series, so set a null
impedance to model a perfect source.

Current sources have their internal impedance in parallel, so set a very large
impedance (1E6 Ohm) to model a nearly perfect source.

Excitation by Sources

To excite the wire structure with discrete sources, go to the Setup tab > Excitation panel
and select the Discrete Sources option, Fig. 1.

If the Set Input Power option is checked, you can set the total input power to the structure.
In this case, the amplitudes of the voltage and current sources will be adjusted to achieve
the specified input power.
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Fig. 1: Discrete Sources option in the Excitation panel of the Setup tabsheet.
The Source/Load/TL Toolbar

The Source/Load/TL toolbar is used to connect a source, load, or transmission line to a
selected wire segment. This toolbar also provides the means to edit sources, loads, and

transmission lines.

When you right-click on any part of a wire, a pop-up menu will appear. Click on the
Source/Load/TL (Ctrl + Ins) command from the pop-up menu to open the Source/Load/TL

toolbar, Fig. 1.

The Source/Load/TL command is also accessible from the main toolbar or by going to the

main menu and selecting Edit > Source/Load/TL (Ctrl + Ins). To enable this command, first
click on the Select Wire button (the arrow icon) on the main toolbar and then left-click on the

wire where you want to place the source or load.

The Source/Load toolbar has the following components:

I
X

4 | X

Fig. 1: Source/Load/TL toolbar.
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The Slider

Each position of the slider corresponds to the position of a segment in the selected wire. So,
the slider allows us to select a particular segment on the wire. At the right corner of this
toolbar, the position of the selected segment is shown. The segment’s position as a
percentage of the wire length is also shown. It is measured from the starting point of the wire
to the middle point of the selected segment and is defined as follows:

% position = 100 (position / wire length)

The 50% button

The 50% button is used to position the slider in the middle of the wire. Discrete sources and
loads are often added at the center of wires, so you can click this button to quickly select the
segment at the wire’s center. Please note that the wire must have an odd number of
segments for it to have a segment at its center.

The Add Source button

Click the Add Source button to display a dialog box for adding a source to the selected wire
segment, as shown in Fig. 2. This dialog box allows you to set the type of source, its
amplitude, phase, and internal impedance.

Add Source
| Source | Impedance Zs
Type
@ Voltage Source l:::l Current Source
Voltage (Vs)
| ey
W
oseiesl |
Ok Cancel

Fig. 2: Add Source dialog box.

The Add Load button

Click the Add Load button to display a dialog box for adding a load to the selected wire
segment, as shown in Fig. 3. A load can represent either a resistor in series with an inductor
(RL), a resistor in series with a capacitor (RC), or a fixed impedance (R+jX) where the
reactance X does not scale with frequency.
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Add Load

Type

® RL C) RC () R+HX

Resistance 100 Chm
Inductance ICI mH

QK Cancel

Fig. 3: Add Load dialog box.

The Transmission Lines button

Click on the Transmission Lines button to display a dialog box for connecting a
transmission line to the selected wire segment. Refer to Adding Transmission Lines for
further details.

The Delete button

If the selected segment has a source or a load on it, you can click the Delete button to
remove the source or load from the segment.

The Modify button

If the selected segment has a source or a load on it, you can click the Modify button to open
the Modify dialog box, allowing you to edit the source or load.

The Exit button

Click the Exit button to close the Source/Load/TL toolbar.
Adding Sources

A source can be added to a selected wire segment by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.

2. Choose the Source/Load/TL command from the pop-up menu to display the
Source/Load/TL toolbar.

3. Move the slider to select the desired segment.

. Click on the Add Source button to display the Add Source dialog box.

5. Set the type of source, its amplitude (rms value), phase and internal impedance. Then,
press the OK button.

6. Click on the Exit button to close the Source/Load/TL toolbar.

N
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Editing Sources
A source can be edited by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.

2. Choose the Source/Load/TL command from the pop-up menu to display the
Source/Load/TL toolbar.

3. Move the slider to select the segment where the source is placed.

4. Click on the Modify button to display a dialog box where the source can be edited. The
source can be deleted by clicking on the Delete button.

5. Click on the Exit button to close the Source/Load/TL toolbar.

Adding Loads
A load can be added to a selected wire segment by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.

2. Choose the Source/Load/TL command from the pop-up menu to display the
Source/Load/TL toolbar.

3. Move the slider to select the desired segment.

. Click on the Add Load button to display the Add Load dialog box.

5. Set the type of load and the values of resistance and inductance or capacitance. Then,
press the OK button.

6. Click on the Exit button to close the Source/Load/TL toolbar.

N

Editing Loads
A load can be edited by means of the following steps:

1. Right click on any part of a wire to display the pop-up menu.

2. Choose the Source/Load/TL command from the pop-up menu to display the
Source/Load/TL toolbar.

3. Move the slider to select the segment where the load is placed.

4. Click on the Modify button to display a dialog box where the load can be edited. The
load can be deleted by clicking on the Delete button.

5. Click on the Exit button to close the Source/Load/TL toolbar.

Enabling/Disabling Loads

All the loads can be enabled or disabled at the same time. This option avoids deleting the
load impedances when loads must not be considered in a simulation.

Go to Setup tab > Settings panel > in the main window. If the option Load Impedances is
checked, the loads are enabled, otherwise they are disabled, Fig. 1.
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Fig. 1: Load impedances option in the Settings panel of the Setup tabsheet.

Incident Field

Excitation by an Incident Field

To choose an incident plane wave as excitation of the structure, go to the Setup tab >
Excitation panel > and select the Incident Field option, Fig. 1. When this option is
selected, if there are discrete sources on the structure, none will be considered in the

simulation.
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Fig. 1: Incident Field option in the Excitation panel of the Setup tabsheet.
Incident Field Parameters

The following incident field parameters can be set in the Excitation panel > of the Setup
tabsheet after clicking on the Incident Field option:

E-Field Major Axis: Amplitude, in V/m (Volts rms per meter), of the linearly polarized

incoming electric field. For elliptical polarization, it is the length of the major ellipse axis.

Axial Ratio: For an elliptically polarized plane wave, it is the ratio of the minor axis to
the major axis of the ellipse. A positive (negative) axial ratio defines a right-handed

(left-handed) ellipse. If the axial ratio is set to zero, a linearly polarized plane wave is
defined.

Phase Reference: Phase, in degrees, of the incident plane wave at the origin of
coordinates. It can be used to change the phase reference in the calculation. Its value
only shifts all phases in the structure by the given amount.

Gamma: Polarization angle of the incident electric field in degrees. For a linearly
polarized wave, Gamma is measured from the plane of incidence to the direction of the
electric field vector, Fig. 1. For an elliptically polarized wave, Gamma is the angle
between the plane of incidence and the major ellipse axis.

Theta: Zenith angle of the incident direction in degrees, Fig. 1.

Phi: Azimuth angle of the incident direction in degrees, Fig. 1.
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Fig. 1: Parameters of an incident field.

Note

When an incident plane wave is used as excitation, all discrete sources, if any, will not
be considered in the simulation.
The 3D-View Interface

The 3D-View interface allows us entering the parameters of the incident field in a graphical
way. Follow these steps:

1. Go to the Setup tabsheet and select the Incident Field option in the Excitation panel
>,

2. Click on the 3D View button to open the interface and display the Incident Wave dialog
box, Fig. 1.

3. Set the Gamma, Theta and Phi angles and press ENTER. You can also use the small
arrows to change these angles.

4. Close the Incident Wave dialog box. The angles that have been entered in the dialog
box will appear in the Excitation panel, Fig. 2.
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Gamma -45

Theta 45

Phi  -100

Fig. 1: 3D-View interface for the definition of the incident field. The
Incident Wave dialog box is also shown. Gamma, Theta, and Phi are set
to —45, 45 and —100 deg., respectively.
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Fig. 2: The Gamma, Theta and Phi angles entered in the Incident Wave dialog box will appear in the
Excitation panel of the Setup tabsheet.
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Ground Planes

Adding a PEC Ground Plane

A perfectly electric conducting (PEC) ground plane, parallel to the xy-plane, can be added to
the model by means of the following procedure:

1. Go to Setup tab > Environment panel >.
2. Select the Perfect option in the Ground Plane box, Fig. 1.
3. Set the ground plane position under the Position label (Z-coordinate).

¥ Environment
Medium
Permittivity €, [1 |  Permeabiity 1, [1 ]
Ground Plane
Type

() None

Position [m]

@ Perfect Z 0

O Real

(O Substrate

Fig. 1: Perfect option in the Ground plane box of
the Environment panel.

When the perfect ground is selected, an infinite PEC ground plane will be placed at the
specified position, Z, from the xy-plane.

If Z> 0, the PEC ground plane will be above the xy-plane.
If Z =0, the PEC ground plane will be the xy-plane.
If Z < 0, the PEC ground plane will be below the xy-plane.

Adding a Real Ground Plane

A real ground plane, located on the xy-plane (Z = 0), can be added to the model by means of
the following procedure:

1. Go to Setup tab > Environment panel >.
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2. Select the Real option in the Ground Plane box, Fig. 1.

3. Specify the Real Ground Option: Sommerfeld-Wait/Asymptotic >, Reflection
Coefficients/Asymptotic >, or Radial Wire Ground Screen >.

4. Set the ground Permittivity and Conductivity. Also, set the radial length, number of
radials and wire radius if a ground screen has been chosen.

¥ Environment
Medium
Permittivity €_ |1 Permeabiity | Il
Ground Plane
Type Real Ground Options
IRadlal wire ground screen| w ‘
() None :
Custom w
O Perfect [] zero-Ohm connections to gnd

Conductivity [S/m] Permittivity
@ Real Glooos | g3
Nr. of Radials Length [m]

Wire Radius [mm] 1

Fig. 1: Real option in the Ground Plane box of the
Environment panel.

Adding a Dielectric Substrate

To incorporate a dielectric substrate beneath the xy-plane (Z < 0) into the model, follow
these steps:

1. Navigate to the Setup tab > Environment panel.
2. In the Ground Plane box, select the Substrate option (see Fig. 1).
3. Choose between an infinite or finite slab in the Substrate Slab Options box.

4. Choose a substrate material from the provided list, or select Custom to specify the
substrate’s Permittivity. Set the slab’s Thickness (h) and, if you’ve chosen a finite
slab, configure its dimensions along the X and Y axes.

Note that the substrate slab is backed by a PEC ground plane, which runs parallel to the xy-
plane at Z = -h, and cannot be removed from the simulation.
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¥ Environment
Medium

Permittivity &, Permeability W, IZI

Ground Plane
Substrate Slab Options

Type
| PEC Grounded finite slab e |
O MNone
|Ro4|:u:|3c (Rogers) v|
() Perfect Permittivity Thickness [mm]
£, 3.55 h|1.524
() Real
X-width [mm] Y-width [mm]
|100 | 200 |
(®) Substrate

Fig. 1: Substrate option in the Ground Plane box of
the Environment panel.
Connecting Wires to the Ground

A wire will automatically connect to the ground plane when the z coordinate of one of its
ends coincides with the position of the ground plane.

 When a PEC ground plane > is chosen, the ground position is specified by the value
of Z in the Environment panel > Ground Plane box.

e When a real ground > is chosen, the ground position is Z = 0 (xy-plane).

e When a substrate > is chosen, a PEC ground plane is placed at Z = -h (h: substrate
thickness).

Wire connections to the ground plane are shown with 3D symbols, Fig. 1.
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Fig. 1: 3D symbols showing ground connections.

WARNING!

All wires must be above the ground plane. Wires that cross the ground plane from
one side to the other are not allowed.
Removing the Ground Plane

To remove the ground plane, do the following:

1. Go to Setup tab > Environment panel >.
2. Choose the None option in the Ground Plane box, Fig. 1.
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¥ Environment

Medium

Permittivity € |1 Permeability pu_ (1

Ground Plane

Type

(®) None

(O Perfect

(O Real

(O Substrate

Fig. 1: None option in the Ground Plane box of
the Environment panel.

Running Calculations

The Run ALL Command

Once the frequencies, the environment, the geometry of the structure, the excitation, and the
points of observation of the radiated field have been set, AN-SOF is ready to execute the
calculations. First, the current distribution on the wire segments will be calculated, which
allows us to obtain the input impedance when we have a transmitting antenna. Later, the far
and near fields can be calculated from the currents in the segments.

The Run ALL (F10) command allows us to run the calculation of the current distribution and
the near and far fields sequentially and automatically. Go to main menu > Run > Run ALL
to run this command, Fig. 1, or click on the Run ALL button on the toolbar.

B AN-SOF - Project!
File Edit Draw View Tools Run Results Help
"EE €  RunALL F10 |G< fy Fz || 4| x vz ozx | ¥R Bl P b L ¥y e
Setup Workspace  Feedline Resul Run Currents and Far-Field F11 |
Run Currents and Mear-Field F12

Run Currents

Run Bulk Simulation

Fig. 1: The Run ALL command in the main menu. There are also buttons on the toolbar to run the
calculations.
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If the near field is not required, the calculation can only be run for currents and far fields by
clicking on the Run > Run Currents and Far-Field (F11) command. This command is also
available on the toolbar.

If the far field is not required, the calculation can only be run for currents and near fields by
clicking on the Run > Run Currents and Near-Field (F12) command. This command is also
available on the toolbar.

The currents, far and near fields can be computed separately as it is explained in the next
articles >.
Calculating the Current Distribution

When the frequencies, the environment, the geometry, and the excitation are set, AN-SOF is
ready to compute the currents flowing on the wire segments.

Go to Run > Run Currents in the main menu to run the calculation of the current
distribution, Fig. 1.

Bl An-50F - Project
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Setup Workspate  Feedline Resul ~ Run Currents and Far-Field F11
Run Currents and Mear-Field F12

Run Currents

Run Bulk Simulation

Fig. 1: The Run Currents command in the main menu.
Tip

When we are modeling a transmitting antenna and we only need the input
impedance, this command allows us to save time since the radiated field is not
calculated.

Calculating the Far Field

Once the current distribution on the structure has been obtained, the far-field in the angular
ranges set in the Far-Field panel > of the Setup tabsheet can be computed.

Go to Run > Run Far-Field in the main menu to run the calculation of the far-field, Fig. 1.
This command is only enabled when the current distribution has already been calculated.
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Fig. 1: The Run Far-Field command in the main menu.
Tip
To run the calculation of the current distribution and the far field sequentially and

automatically, click on the Run Currents and Far-Field (F11) button on the toolbar.
Calculating the Near E-Field

Once the current distribution on the structure has been obtained, the near electric field at
those points in space set in the Near-Field panel > of the Setup tabsheet can be computed.

Go to Run > Run Near E-Field in the main menu to run the calculation of the near electric
field, Fig. 1. This command is only enabled when the current distribution has already been
calculated.
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Fig. 1: The Run Near E-Field command in the main menu.
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To run the calculation of the current distribution and the near fields sequentially
and automatically, click on the Run Currents and Near-Field (F12) button on the
toolbar. This command also runs the calculation of the near H-Field.

To avoid the calculation of the H-Field, go to main menu > Tools > Preferences
> Options > and uncheck the “Run ALL” also calculates the H-Field option.
Calculating the Near H-Field

Once the current distribution on the structure has been obtained, the near magnetic field at
those points in space set in the Near-Field panel > of the Setup tabsheet can be computed.

Go to Run > Run Near H-Field in the main menu to run the calculation of the near magnetic
field, Fig. 1. This command is only enabled when the current distribution has already been

calculated.
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Fig. 1: The Run Near H-Field command in the main menu.

To run the calculation of the current distribution and the near fields sequentially
and automatically, click on the Run Currents and Near-Field (F12) button on the
toolbar. This command also runs the calculation of the near electric field.

Go to Tools > Preferences > Options > in the main menu and check the “Run
ALL” also calculates the H-Field option to enable the calculation of the H-field.

Aborting the Calculations

When a calculation is executed using the commands under the Run menu >, the
Processing window will be displayed, Fig. 1. There is a button to abort the calculation at any
time. Note that you will be prompted to save the project before aborting, as AN-SOF will

restart.
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Processing...

ﬁ Fequency: 100 MHz
o Allocating memory for matrix
o Calculating matrix elements for wires
o Calaulating connection elements
¢ Calculating ground point elements
o Adding loads, resistivity and coating
¢ Calculating excitation vector elements
@ Solving matrix equations

Storing Current Distribution
== Computing Far-Field
@ Computing Near E-field
@ Computing Near H-field

Finished

Progress 73%

Abort

Fig. 1: The Processing window.
Numerical Green’s Function

There are simulations in which we need to change the excitation of the structure frequently.

For example, when we must often adjust the amplitudes of discrete sources or alter the
direction of arrival of an incident field. In these cases, we can save a significant amount of
time by enabling the NGF (Numerical Green’s Function) option in the Settings panel of
the Setup tab, as shown in Fig. 1.

When an NGF calculation is performed, the LU-decomposed matrix of the system is stored
in a file after the initial calculation. Subsequently, by reusing this stored matrix, new
calculations can be performed more quickly than the initial one.

When transmission lines are included in the model, the NGF option will be automatically
enabled.
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¥ Settings
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Quadrature Tolerance 50 ‘ o
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Interaction Distance Options
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NGF
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Exact Kernel [] wire Resistivity
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Fig. 1: NGF option in the Settings panel of the Setup tabsheet.
Running a Bulk Simulation

AN-SOF is capable of importing a sequence of input files to obtain a corresponding
sequence of output files, all without requiring any user intervention during the process. The
input files must adhere to the NEC format and have a .nec extension. The supported NEC
commands for importing wires are described here: Importing Wires.

The output data consists of power budget or RCS (Radar Cross Section), input impedances,
far field, and near fields, all provided in CSV format. For each NEC input file, AN-SOF
generates an individual project containing .emm and .wre files (see File Formats). This way,
each project can be opened separately once the bulk simulation is completed.

To initiate a bulk simulation, navigate to the main menu and choose Run > Run Bulk
Simulation. A prompt will appear, asking whether you want to save the changes in the
current project, as the bulk simulation requires closing the currently open project.
Subsequently, a dialog box will be displayed, allowing you to select a directory and the input
.nec files. Upon selecting the desired files and clicking the “Open” button, the bulk simulation
will commence, with the input files being imported and computed one after another in
alphabetic order.

For instance, if we consider an input file named “InputFile.nec,” the following files will be
generated:

Files of the AN-SOF project
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InputFile.emm > main file of the project (it can be opened with AN-SOF)
InputFile.wre > geometry data (wires, segments, connections)
InputFile.txt > comments

InputFile.cur > current distribution

InputFile.pwr > input and radiated powers, directivity, gain, etc.
InputFile.the > Theta component of the far field

InputFile.phi > Phi component of the far field

InputFile.nef > near electric field

InputFile.nhf > near magnetic field

Output CSV Files with Results

InputFile_PowerBudget.csv > input and radiated power, efficiency, gain, etc.
InputFile_Zin.csv > input impedances

InputFile_FarFieldX.csv > E-theta and E-phi far field components
InputFile_EFieldX.csv > near electric field components
InputFile_HFieldX.csv > near magnetic field components

where “X” represents the frequency in Hz (e.g., X = 300000000 for a frequency of 300 MHz).
Consequently, a FarField, EField, and HField file will be generated for each frequency if a
frequency sweep simulation has been configured.

Bulk simulations serve the purpose of automating the calculation process for multiple NEC
files, even if they are not directly related, eliminating the need for manual calculations file by
file. Conversely, they are also useful for sequentially running calculations on NEC files
generated with varying geometric parameters in an antenna. Subsequently, the results can
be analyzed by reading data from the generated CSV files.

For instance, you can create a script to generate a sequence of NEC files for a Yagi-Uda
antenna, where the spacing between its elements varies. To understand how to accomplish
this and read the output data from the CSV files, you can refer to the following link: Element
Spacing Simulation Script for Yagi-Uda Antennas.
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Displaying Results

Types of Results

Commands to Display Results

The output data of a simulation can be listed in tables or displayed in graphs. All results are
found under the Results menu >, and are categorized into four groups:

Results related to current distribution

¢ Run > Plot Current Distribution command.
¢ Run > Plot Currents command.

e Run > List Currents command.

¢ Run > List Input Impedances command.

Results related to the far field

¢ Run > Plot Far-Field Pattern command.

e Run > Plot Far-Field Spectrum command.
¢ Run > List Far-Field Pattern command.

¢ Run > List Far-Field Spectrum command.
e Run > Power Budget/RCS command.

Results related to the near E-Field

¢ Run > Plot Near E-Field Pattern command.
e Run > Plot Near E-Field Spectrum command.
¢ Run > List Near E-Field Pattern command.
¢ Run > List Near E-Field Spectrum command.

Results related to the near H-Field

Run > Plot Near H-Field Pattern command.
Run > Plot Near H-Field Spectrum command.
Run > List Near H-Field Pattern command.
Run > List Near H-Field Spectrum command.

Tip

See the most relevant results for transmitting antennas in the Results tab > of the
main window.
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Lists and Plots

Listing the currents or input impedances means tabulating them as a function of frequency.

In the case of fields, they can be listed at a given point versus the frequency (Spectrum) or
at a given frequency versus the observation point (Pattern).

AN-SOF includes a suite of four tools for plotting results: AN-XY Chart >, AN-Smith >, AN-
Polar > and AN-3D Pattern >.
The Results Tab

In the AN-SOF main window, you will find a Results tab (see Fig. 1) that displays a table
with the primary results for a transmitting antenna, including Input Impedance (Rin + j Xin),
VSWR, S44, Directivity, Gain, Efficiency, and the Horizontal (H) and Vertical (V) Front-to-
Rear (F/R) and Front-to-Back (F/B) Ratios.

This table is automatically populated only when the structure has been excited by a discrete
source and will not be filled when the excitation is an incident wave. The tabulated results
persist until a new calculation is performed, allowing you to reference them at any time, even
when making changes to the project. To export these results to a CSV file, simply click the
Export Results button on the toolbar.

The column headings, from Rin through F/B V, are buttons that you can click to display
plots.
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Fig. 1: “Results” tab in the main window. The “Export Results” button in the toolbar is highlighted.
The Plots Tab

Select the Plots tab in the AN-SOF main window to visualize the plots of the main results for
a transmitting antenna as a function of frequency, as shown in Fig. 1. These results are
obtained from the table in the Results tab.

The left column in the Plots tab presents the real and imaginary parts of the input
impedance and VSWR. On the right column are the antenna gain in dBi and the front-to-
rear (F/R) and front-to-back (F/B) ratios in dB. These plots are aligned vertically to make it
easy to compare.

Use the controls on the right side of the Plots tab to change different aspects of the graphics,
including line thickness, visualization of points and marks, scales, axes, and also to choose
between VSWR or S44 and horizontal (H) or vertical (V) F/R vs. F/B ratios. Each plot can
be maximized by clicking on the “Maximize” checkbox located at its upper right corner.

The input impedance and VSWR/S44 plots can represent the antenna input impedance, the
feeder + antenna input impedance, or the tuner input impedance. The tuner and feeder
can be configured in their corresponding tabs next to the Results tab. Every time a tuner or
feeder parameter is changed, the recalculated results in the Results and Plots tabs can be
refreshed by clicking the desired option under the “Zin” box highlighted in Fig. 1 below.
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If the Tuner option is chosen to display the plots and results, note that the input impedance
of the tuner will be displayed, and if the tuner is connected to a combination of feeder +
antenna, the input impedance and VSWR/S44 of the tuner + feeder + antenna system will
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Fig. 1: Plots tab in the AN-SOF main window.

Current Distribution

Plotting the Current Distribution

Go to Results > Plot Current Distribution in the main menu to display a 3D graph of the
current distribution on the structure. This command executes the AN-3D Pattern >
application where the amplitude of the currents is displayed on the structure using a color
scale. Additionally, the currents in phase, real, and imaginary parts can be plotted selecting
these options in the Plot menu of AN-3D Pattern, Fig. 1.
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Fig. 1: Current distribution in amplitude plotted by AN-3D Pattern.

A 2D plot of the current distribution along a selected wire can be shown by right clicking on
the wire and choosing Plot Currents from the pop-up menu, Fig. 2. The Plot Currents
command executes the AN-XY Chart > application, where the current is plotted in amplitude
vs. position along the selected wire. The current distribution can also be plotted in phase,
real and imaginary parts by choosing these commands under View in the AN-XY Chart main
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Fig. 2: The Plot Currents command in the pop-up menu and the current distribution in amplitude plotted by
AN-XY Chart.

A wire can also be selected by first clicking on the Select Wire button (arrow icon) on the
toolbar and then left clicking on the wire. Once the wire is selected, go to Results > Plot
Currents in the main menu to plot the current along that wire. This command is enabled
when the current distribution has been calculated.

Tips

The graph plotted by AN-XY Chart can be zoomed by expanding a box with the
left mouse button pressed on the plot.

Right click on the graph and drag the mouse to move it.
Left click and expand a rectangle up to return to the original view.

There are options to change the units of the plotted magnitudes and to export
data in the AN-XY Chart main menu.
The List Currents Toolbar

Right clicking on a wire shows a pop-up menu >. Click on the List Currents command to
display the List Currents toolbar, Fig. 1. This toolbar allows us to select a wire segment to
see the current flowing through that segment versus frequency. If the segment has a source
or load, the list of input impedances, admittances, voltages, powers, reflection coefficient,
VSWR, return and transmission losses can also be displayed.
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A wire can also be selected by first clicking on the Select Wire button (arrow icon) on the
toolbar and then left clicking on the wire. Once the wire is selected, go to Results > List

Currents in the main menu. This command is enabled when the current distribution has

been calculated.

The List Currents toolbar has the following components:

a L s Z; Z; E3 Segment: 8of 15  Position: 50%

Fig. 1: The List Currents toolbar.

The Slider

Each position of the slider corresponds to the position of a segment along the selected wire.
Thus, the slider allows us selecting the desired wire segment. The position of the selected
segment is shown at the right corner of this toolbar. The segment position is shown as a
number and as a percentage of the wire length. The percentage position is measured from
the starting point of the wire to the middle point of the segment, namely,

% position = 100 (position / wire length)

The 50% button

Moves the slider towards the center of the wire. Note that there must be an odd number of
segments for there to be a segment at the midpoint of the wire.

The Current on Segment button

Displays the Current on Segment dialog box, Fig. 2, showing a list of the current in the
selected segment versus frequency. Click the Plot button to plot the current in the segment
as a function of frequency.

B Current on Segment — O x
M. Frequency Real Part Imag Part .
MHz A A
1 1 0.0348331 0.0283218 0
2 .'D.DJ-DDIIE 0.0287011 0.
3 292 0.04563451 0.0276191 0
4 293 0.0538794 0.0243143 0 Flot
3 294 0.062212 0.0191735 0. y
< > S

Fig. 2: The Current on Segment dialog box.
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The Input List button

If the selected segment has a source on it, the Input List button will be enabled. Click this
button to display the Input List dialog box, Fig. 3, where the list of input impedances,
admittances, currents, voltages, and powers is shown. Select an item from the list in the
upper right corner of the window and then press the Plot button to plot the selected item
versus frequency. The input impedance can be plotted in a Smith chart by pressing the
Smith button. Click the Export button to save the list in CSV format.

B input List - X
Double-click to display plots
No. Frequency Real (Zin) Imag (Zin) A
Current vs. Freq
— MHz Ohm Ohm Voltage vs. Freq
................... Power vs. Freq
1 290 { 16.2719 -19.1755 2 Rho vs. Freq
H et i VSWR vs. Freq
2 291 15.7387 -16.9597 2: Return Loss vs. Freq
Trans. Loss vs. Freq
3 292 15.1679 -14.6643 21 B
- 293 14,5685 -12,286 15 Plot
5 294 13.9489 -9.82273 17
6 295 13.3171 -7.2734 18 Export
7 296 12.6806 -4.63762 1z
w Smith
< >

Fig. 3: The Input List dialog box.

The Source List button

If the selected segment has a source on it, the Source List button will be enabled. Click this
button to display the Source List dialog box, Fig. 4, where the list of currents, voltages, and
powers in the source internal impedance is shown. Select an item from the list in the upper
right corner of the window and then press the Plot button to plot the selected item versus
frequency. Click the Export button to save the list in CSV format.
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Fig. 4: The Source List dialog box.

The Load List button

If the selected segment has a load on it, the Load List button will be enabled. Click this
button to display the Load List dialog box, Fig. 5, where the list of load impedances, currents,

voltages, and powers in the segment is shown. Select an item from the list in the upper right

corner of the window and then press the Plot button to plot the selected item versus
frequency. Click the Export button to save the list in CSV format.
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Mo. Fregquency Real (ZL)
MHz Ohm
1 290 { 100
_ — -
3 292 100
4 293 100
5 294 100
<

Imag (2L)

-548.81

-546.924
=545.051
-543.191

-541.343

Ohm

]

CuTent‘.'s Freq
Voltage vs. Freg
Power vs. Freg

Export

l

Fig. 5: The Load List dialog box.

The Exit button

Closes the List Currents toolbar.
Listing the Currents in a Segment

The following procedure allows us to select a wire segment to tabulate currents versus

frequency:

1. Right click on the wire to display the pop-up menu >.

2. Click on the List Currents command to display the List Currents toolbar >.
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3. Move the slider and select the desired segment on the wire.

4. Click on the Current on Segment button to display the Current on Segment dialog
box, where a list of the currents versus frequency is shown. Currents are shown in
amplitude, phase, real and imaginary parts. Click the Plot button to plot the current in
the selected segment as a function of frequency.

Input Impedances

Listing the Input Impedances, VSWR, and S11

The following procedure allows us to select a segment that has a source to tabulate input
impedance versus frequency:

1. Right click on a wire that has a source to display the pop-up menu.
2. Click on the List Currents command to display the List Currents toolbar.
3. Move the slider and select the segment where the source is placed.

4. Click on the Input List button to display the Input List dialog box, where the list of
input impedances, admittances, currents, voltages, powers, reflection coefficient,
VSWR, S44 in decibels, return and transmission losses is shown. Select an item from
the list in the upper right corner of the window and then press the Plot button to plot
the selected item versus frequency. Click the Smith button to plot the input impedance
in a Smith chart.

Tips

The reference impedance for reflection calculations (VSWR, S;4, and Return
Loss) can be set in the Settings panel of the Setup tabsheet.

When there is a single source on the structure, you can quickly access the input
impedance by going to the main menu > Results > List Input Impedances or by
clicking on the ‘List Input Impedances’ button on the toolbar.

Tuner for Impedance Matching

The Tuner Calculator

AN-SOF features a tuner calculator that enables impedance matching of an antenna input
impedance, an antenna with a feeder already connected to its terminals, or a given custom
load.
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To access the tuner calculator, choose the Tuner tab in the AN-SOF main window (Fig. 1).
Here, you can set the tuner parameters on the left side of the window and view the results on
the right side. The tuner consists of three components, each of which will be described in the

following sections:

Impedance Matching Network: This component allows the synthesis of an
impedance matching network based on the impedance seen at the network output and
the desired impedance at the network input. The quality factors of the network,
inductors, and capacitors can be adjusted to model real-world scenarios.

Stray Capacitance: Some networks, particularly high-pass Tee networks, exhibit a
parallel stray capacitance at the network output. This capacitance can be specified to

account for this effect.

Impedance Transformer: An impedance transformer can be specified at the network
output to transform the input impedance of an antenna, the input impedance of a
feeder connected to an antenna, or a custom load entered by the user.

Setup  Workspace TUnMer  Feeder Results  Plots

Tuner = Matching Network + Cstray + Transformer

Results

Ro X Cstray 10 Antenna Network Q ut
T T 0.452559 ]
Impedance R § j|33.9419 | Ohm 11,1219 |pF
Matching A ZL = )
4
Netwaork F j|-143.101 | Ohm
0
Source - Load Source Load
Tuner Parameters At Tuner Input At Tuner Load
Tuner Transformer - -

Netwark Type Input Impedance  |75.1046 +j 0.0355835 | Ohm Load Impedance | 333.453 +j 62,6534 Ohm

Impedance Factor 1:

ini 75.1046 0.0271455 d 339.288 Chi t | 10,6414

Minimum Q Cl Nominal Impedance ohm | s | | = | m = ‘ | deg
Inductor Q Insertion Loss 0.25 dB Rho 0.000735774 Rho 0.643561
Capacitor Q VSWR 1.00147 VSWR 461105

Input Power (PEF) w
sweyeap. [0 |F A Return Loss [62.6651 ds Return Loss |3.82821 d8

w

owoee  [m 5 »

Frequency 100 ~ | MHz .
[ Power atLoad 94,175 w Radiated Power 94,1302 w

Time Transmitting =1

Load Impedance Source Impedance Power Lost in Network 0.243762 W Antenna Loss 0.0457527 W
Power Lostin Tuner Trafo |5.58028 w Total Feeder Loss l:l W
() Feeder + Antenna
Load Impedance

O Custom Load AL [333.953 Ohm 52.5534 Shm Total Tuner Loss 5.82404 w Total System Loss 5.86979 w

Fig. 1: Tuner tab in the AN-SO

Impedance Matching Network

A

main window where an antenna tuner can be configured.

In the Tuner Parameters box, you can configure the impedance matching network, as

shown in Fig. 2.
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Tuner Parameters

Metwork Type |L - Low-pass v|

ﬂ

Minimum Q

Inductor Q 250

Capaditor Q 1000

Fig. 2: Tuner Parameters box in the
Tuner tab, showing options to specify the
network type, minimum Q, and inductor
and capacitor Q values.

By expanding the Network Type dropdown menu, you have the following options:

No Network: Select this option to bypass the matching network, making the network
input impedance equal to the impedance at the network output.

Based on the impedance seen at the network output and the source impedance
connected to the network input side, AN-SOF can synthesize the following networks:
o L - Low-pass

o L - High-pass
o Pl - Low-pass
o Pl - High-pass
o T - Low-pass

o T - High-pass

The network components will be automatically calculated to match the source impedance
(Rs + jXs) connected to the network input side. If the source impedance has a reactance
component, jXs, the network will “absorb” this reactance so that the input impedance of the
network plus jXs will match the real part, Rq, of the source impedance. The same principle
applies to the load impedance seen at the network output side. If the network load
impedance has an imaginary part, it will be absorbed by the network to synthesize the
network components (inductors and capacitors).

Note that a low-pass network could include series capacitors instead of inductors or parallel
inductors instead of capacitors, depending on the complex impedances (with real and
imaginary parts) being matched. Similarly, a high-pass network might involve series
inductors instead of capacitors or parallel capacitors instead of inductors.
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You can specify a minimum Q for the network synthesis calculations, as well as the Q for
the inductors and capacitors. This allows you to account for component losses to
represent real-world components. To model ideal zero-loss components, enter high Q
values, such as 1ES8.

Stray Capacitance

Stray capacitance, also known as parasitic capacitance, refers to unintended capacitance
between two conductors separated by a dielectric or free space. This effect is particularly
noticeable at the network output side when a transmission line is connected. AN-SOF
allows for the configuration of a feeder composed of a transmission line to feed an antenna,
enabling modeling of stray capacitance to accommodate this scenario. While stray
capacitance is commonly observed in Tee high-pass networks, it can be added in any case.
Typical values range from around 10 pF in HF bands.

Impedance Transformer

In the Tuner Parameters box, an impedance transformer, also known as a “trafo” in RF
jargon, can be specified, as shown in Fig. 3.

Tuner Transformer

Impedance Factor 1: (4

Mominal Impedance 75 Chm

Insertion Loss 0,25 dB

Fig. 3: Specification of a tuner transformer
giving its impedance transformation factor,
nominal impedance, and insertion loss.

The transformer allows us to divide a load impedance by a factor, n, making ita 1:n
transformer. It's important to note that this is the impedance transformation factor, not
the voltage transformation factor, which is n"'2 and is determined by the primary-to-
secondary winding relationship of a transformer. A transformer can be used to reduce a high
impedance to approach the standard 50 or 75 Ohms used in transmission lines and RF
devices. Both the real and imaginary parts of the load impedance will be divided by n.

If nis in the range 0 < n < 1, the transformed impedance will be higher than the load
impedance connected to the output side of the transformer. A factor n =1 can be used to
model a 1:1 transformer, also known as an isolation transformer, which is used to transfer
voltage from one electrical circuit to another and to isolate a powered device from the power
source. The 1:1 ratio transformer has the same input and output voltage and current. It is
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used to protect secondary circuits and individuals from electrical shocks between energized
conductors and earth ground. It also reduces voltage spikes in the power supply line caused
by rapid changes in lighting, static electricity, or voltage.

Real-life transformers are manufactured for a specified nominal impedance transformation.
The nominal impedance can be entered in the Tuner Transformer box, as well as the
transformer insertion loss in decibels. Manufacturers specify a transformer insertion loss
relative to a nominal impedance, so it is important to specify the nominal impedance as well.
The insertion loss is defined as the power lost inside the transformer, measured in dB
relative to the input power. Thus, the output power delivered by the transformer to the load
impedance will be lower than the input power due to losses inside the transformer materials
(coil conductor losses, magnetic core losses, etc.).

Tuner Frequency and Input Power

The components synthesized in the impedance matching network of the tuner will be
automatically calculated for a specified frequency, which can be chosen from a dropdown
menu in the Tuner Parameters box, as shown in Fig. 4.

Tuner Parameters
Tuner Transformer

Metwork Type |L - Low-pass v|

Impedance Factor 1:|4

Minimum Q Mominal Impedance |75 Ohm

Inductor Q 250 Insertion Loss 0.25 dB

Capacitor Q 1000

AL

Input Power (PEF) W
Stray Cap. PF Transmit Mode |FM v
Duty Cyde 100 S
Freguency 100 w | MHz
100 ~ Time Transmitting 100 =
101
Load Impedancs o Source Impedance

Chm

104

() Feeder + An
105 Load Impedance
106

(O Custom Load 107 v RL |333.453 Ohm XL |62.6534 Ohm

il

Fig. 4: The tuner design frequency and input power can be set in the Tuner Parameters box.

This list of frequencies is taken from the Frequency panel in the Setup tab, where a single
frequency, a list of frequencies, or a frequency sweep can be configured. Therefore, to
change the list of frequencies available in the Tuner tab, go to the Setup tab and enter the
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desired frequencies in the Frequency panel. Note that the frequency chosen for the tuner will
be its design frequency; thus, the tuner components, inductors, and capacitors will be
recalculated if the design frequency changes.

The Input Power to the tuner can also be specified in the Tuner Parameters box. This is the
power delivered by the source connected to the input side of the impedance matching
network of the tuner. This input power affects the powers calculated in the Results box on
the right side of the Tuner tab, as explained below. It is worth mentioning that the tuner input
power is not the power delivered to the antenna terminals, which can be set in the
Excitation panel of the Setup tab. However, if the tuner is connected to an antenna, we can
specify that the tuner output power be delivered to the antenna terminals, as detailed below.

Transmit Mode, Duty Cycle, and Time Transmitting

The input power specified is the transmitter’'s Peak Envelope Power (PEP). However, when
performing RF exposure evaluations, the average power supplied by the transmitter over
time is the critical factor. The average power is a fraction of the PEP, determined by the duty
cycle (or duty factor) of the selected transmit mode. The transmit mode can be chosen,
and the corresponding percentage duty cycle will be displayed, as shown in Fig. 5. To enter
a custom duty cycle, select “Custom” as the transmit mode.

It is also important to account for the percentage of time the transmitter remains active within
a specific period, such as 6 minutes. For example, if the telegraph mode transmits for only 3
minutes in every 6-minute period, the power considered for RF exposure calculations is
reduced by 50%. Therefore, the Time Transmitting parameter can be set as a percentage.
Both the duty cycle and the time transmitting percentage will affect the PEP, and an average
input power will be calculated accordingly.

Input Power {PEFP) 100 W

Transmit Mode | CW (Morse code) - |

-

Time Transmitting 100 %o

-

Fig. 5: Transmit Mode, Duty Cycle, and
Time Transmitting settings will affect the
entered Input Power (PEP).

Tuner Source and Load Impedances

The source impedance connected to the tuner input side can be set in real (Rg) and
imaginary (Xg) parts, as shown in Fig. 6.
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vl o Source Impedance

(® Antenna Impedance Rs L Hs D .

O Feeder + Antenna Load Impedance

() Custom Load RL (333.453 Ohm ¥L |62.6534 Ohm

Fig. 6: Specification of the tuner source and load impedances.

When a non-null source reactance, X, is entered, it will be absorbed by the impedance
matching network calculations. Thus, the net input impedance of the network, after adding
iXs, will be matched to the real part of the source impedance, Rq. Click on the checkbox
next to the “Rs” label to set this resistance as the reference impedance for VSWR
calculations. This same resistance will be automatically set in the Settings panel as the
“VSWR Ref. Impedance”.

There are three options for the tuner load impedance (R + jX,):

Antenna Impedance: Select this option to set the antenna input impedance as the
tuner load. Note that the antenna impedance varies with frequency, so changing the
design frequency for the tuner will trigger a recalculation of the impedance matching
network.

Feeder + Antenna: This option allows us to set the combination of feeder + antenna
as the tuner load. In this case, the feeder parameters will be taken from the Feeder
tab at the chosen design frequency. Therefore, the load impedance connected at the
tuner output is a function of frequency since it is the input impedance to the feeder
connected to the antenna.

Custom Load: This option allows setting a tuner load impedance manually by
specifying its real (R ) and imaginary (X|) parts. The Tuner tab can be used as an
independent impedance matching calculator in this case.

Tuner Results

The results of the calculations based on the configured tuner parameters are displayed in the
Results box on the right side of the Tuner tab, as shown in Fig. 7.
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Results
Network Q 540202 |nH Network Results
0,452555 - = ~
] - I 11,1219 |pF
j|-143.101 | Ohm

- -
Source Load
At Tuner Input At Tuner Load

Input Impedance |?5.1[J"-16 +j0.0355835 |Dhm

75.1040 Ohm at [0.0271459 deg

Load Impedance

335,238

|333.453 +]62.6534 | Ohm

Ohm at |10.6414 deg

Power Results

Power Lost in Tuner Trafo |5.58028 Total Feeder Loss

Total Tuner Loss

[4,] [ ]
oo +
=) [
gu

=

w Total System Loss

Rho 0.000735774 Rho 0.5643561
Input and Load
VSWR 1.00147 Impedances VswR 4.61105
Return Loss |62.6651 dB Return Loss |3.82321 dB
[ ] Power at Load W Radiated Power 94,1302 W
Power Lost in Netwark 0.243762 W Antenna Loss 0.0457527 W

WL

5.86979 W

Fig. 7: Tuner Results box on the right side of the Tuner tab.

The results are categorized into three sections: Network results, input and load

impedances, and power results.

Network Results

The network results shown include the resulting network Q and a diagram illustrating the
network components, including inductors and capacitors. For inductors, their inductance
in Henry and reactance in Ohms will be displayed, while for capacitors, their capacitance in
Farads and reactance in Ohms will be shown. The units of inductance and capacitance

displayed can be changed to pH, nH, uH, mH, H, or pF, nF, uF, mF, F, respectively, by
navigating to the AN-SOF main menu > Tools > Preferences > Units tab.
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It's worth mentioning that the resulting network Q for L-type networks is determined only by
the impedances connected to the load and source side of the network. Therefore, the
minimum Q specified in the Tuner Parameters box has no effect for L networks.

Tuner Input and Load Impedances

The resulting input impedance to the tuner will be displayed in both real and imaginary
parts, along with a polar representation showing its magnitude in Ohms and phase in
degrees. If the source impedance, Rg + jXg, connected to the tuner has a non-null
reactance, jXs, this will be absorbed by the impedance matching network. Consequently, the
displayed tuner input impedance represents the impedance seen towards the tuner just
after R, as illustrated in the diagram on the left side of the Tuner tab (Fig. 8).

|::q'E H st i':Etrsl'g,l 1:n Antenna

. —

T

Impedance =]

Matching o A 7, => :)

Metwork F

o
T —&

Source ' Load

Fig. 8: Tuner diagram showing that the input impedance, Z,, is seen towards the tuner
after the source resistance, R, since the source reactance, jX;, is absorbed by the
impedance matching network.

The load impedance connected to the tuner output terminals will also be shown, which can
be the antenna input impedance, a feeder + antenna combination, or a user-entered
impedance in the Tuner Parameters box on the left side of the Tuner tab.

For both the tuner input and load impedances, the reflection coefficient (Rho), VSWR, and
return loss in dB will be displayed. These values are referred to the reference impedance
for VSWR, which has been configured in the Settings panel of the Setup tab.

Powers Delivered and Lost

At the bottom of the Results box, the following powers are calculated:
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Power at Load: This is the power effectively delivered to the tuner load impedance.
Note that the tuner consists of the impedance matching network + stray
capacitance + transformer sequence. Therefore, the power at the tuner load
represents the power delivered at the transformer output terminals. If an antenna
impedance is chosen as the tuner load, the “Power at Load” is the power delivered to
the antenna terminals. If a feeder + antenna is chosen as the tuner load, the
“‘Power at Load” is the power delivered to the feeder terminals. To apply this power to
the antenna model in the Workspace tab, check the checkbox next to the “Power at
Load” label.

Power Lost in Network: This is the total power lost in the network components,
including inductors and capacitors, due to the losses related to the specified quality
factors, Q. In the impedance matching network, a resistance, R = X/Q, representing
component losses, is added in series to the inductor and capacitor reactance, X.

Power Lost in Tuner Trafo: This is the power lost in the impedance transformer due
to the specified insertion loss.

Total Tuner Loss: This is the sum of the network and transformer losses.

Radiated Power: If an antenna impedance is set as the tuner load, this is the power
effectively radiated by the antenna after discounting losses in the antenna system. If a
feeder + antenna is set as the tuner load, this is the power radiated by the antenna
after discounting losses in the feeder and the antenna system.

Total Feeder Loss: If a feeder + antenna is chosen as the tuner load, this is the
power lost in the feeder system.

Total System Loss: This is the sum of the power lost in the tuner (network +
transformer), antenna (conductors, transmission lines, and ground plane), and feeder
(feeding line + transformer), if specified.

Displaying Smith Charts

The input impedance as a function of frequency can be plotted in a Smith chart by clicking
the Smith button in the Input List > dialog box. Follow the procedure described in Listing
the Input Impedances > for listing the input impedances versus frequency, and then click
the Smith button in the opened dialog box.

Left click on the impedance curve in the Smith chart to see the frequency, input impedance
(Zin), reflection coefficient (Rho) and VSWR in a hint message, Fig 1. Go to the AN-Smith
main menu > Plot > Admittance to plot the input admittance curve. Go to Edit >
Preferences to change the visualization options in AN-Smith.
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BB ~N-Smith - Plot1 - m] x
File Edit Plot

Freq = 19 MHz

‘. Zin = 68.7 - j79.8 Ohm
" Rho = 0.487 (-65.5%)

VSWR. = 2.9

Fig. 1: Input impedance curve in the Smith chart plotted by AN-Smith.

Antenna Feeder Calculator

Adding a Feed Line and Transformer

In this article, you will learn how to add a feed line and transformer to your AN-SOF project.
These components are essential for connecting your antenna structure to the external
circuitry and impedance matching.

In the case of a transmitting antenna with a single feed port, the feeder used to connect the
transmitter to the antenna terminals can be modeled in the Feeder tab, as shown in Fig. 1.
The feeder consists of a transmission line, or feed line, and an impedance transformer.
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Fig. 1: Feeder tab where the feed line and transformer used to feed a transmitting antenna can be
configured.

Setting the Impedance Transformer

The transformer, also known as trafo, can represent a balun or unun that connects directly
to the antenna terminals to divide its input impedance by a factor, n. In the Feeder
Transformer box, three parameters can be specified:

Impedance Factor 1:n

Here, “n” is the factor by which the antenna input impedance will be divided. For example, if
we have a folded half-wave dipole, which typically has an input impedance on the order of
300 Ohms, we can set n = 4 to get 300/4 = 75 Ohms of input impedance after the
transformer (i.e., a 1:4 balun). If the input impedance is complex, both its real and imaginary
parts will be divided by n.

If the transformation factor is in the range 0 < n <1, the transformer input impedance will be
greater than the antenna impedance. By setting n = 1, we can represent a 1:1 transformer,
also known as a common-mode choke or line isolator, used to transform a balanced or
symmetrical antenna to an unbalanced feed line.

Note that “n” is the impedance transformer factor, not the voltage transformation factor.
In a transformer, which is composed of a primary winding (inductor or coil) and a secondary
winding, the voltage transformation factor is n"12.
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Nominal Impedance

All actual impedance transformers, whether baluns or ununs, are fabricated for a nominal
impedance, for which the manufacturer warranties the transformer performance in terms of
bandwidth and insertion loss. So, if a lossy transformer is going to be modeled, we should
set its nominal impedance according to the manufacturer’s datasheet.

Insertion Loss

The insertion loss of the transformer can be set in decibels to represent the actual loss
given in its datasheet. The insertion loss is defined as the power lost, in decibels, inside the
transformer, so that its output power will be lower than its input power due to losses in the
transformer materials (coil resistivity, magnetic core losses, etc.).

Note: If no transformer is needed, just set n =1 and an insertion loss of 0 dB.

Setting Feed Line Parameters

In AN-SOF, various real-life transmission line types are available, each with matched loss
parameters adjusted according to the cable datasheets. These cable types are organized by
part numbers and include the manufacturer’s name.

For example, entering “RG-8” in the Cable Type option will display this part number for
different manufacturers, as shown in Fig. 2. Selecting RG-8 Belden 8237 will reveal a set of
KO0, K1, and K2 parameters. These constants have been adjusted to match the loss curve
as a function of frequency, based on the matched loss vs. frequency table published in the
cable datasheet. K0 relates to the DC losses in the transmission line conductors, K1 to the
skin effect losses dependent on the square root of frequency, and K2 to dielectric losses
increasing linearly with frequency. These losses are then considered in the standard RLGC
model of a lossy transmission line.

The nominal values of the cable characteristic impedance Z0 and velocity factor will also
be shown for the chosen part number and manufacturer. After selecting the cable type, you
can set the operating frequency and input power to the feed line. The frequency can be
chosen from a list that displays the frequencies set in the Setup tab.
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Feeder = Feed Line + Transformer

Length 1n Antenna
b
Z, = Z, ,-")
FeedLine TRAFO Y
Feed Line Parameters
Feeder Transformer
Cable Type RG-3 Belden 8237 e

RG-8 Belden 8237 ~ el L
Nominal 20 RG-3 Belden 9251 .
RG-5 Belden 9913 Mominal Impedance Chm
RG-3 Belden 9913F7
Velodty Factor |RG-8 Belden 9914 Insertion Loss ICI

RG-8 CommScope 2927k
RG-8 Comm&coope 3227
Length RG-8 Wireman CO102 + | Loss Curve

KO | 0.0003459442

1.515313 A

K1 |6.03799E-5
546,528 deg

K2 |4.4521E-11

Load Impedance
Load Impedance

(@ Antenna Impedance
Ohm

Frequency | 300 vl MHz Imput Power 1000 W

() Custom Load

Fig. 2: Cable Type option where the type of transmission line can be chosen.

Next, you can set the length of the cable, entered according to the length unit used for
drawing wires in the workspace. To change the length unit, go to Tools > Preferences in the
main menu. As you type the cable length, the length measured in wavelengths (A) and
electrical degrees will be automatically displayed. In fact, all feed line results are calculated
automatically by modifying any of the feed line parameters.

You can then choose the load impedance of the feed line. The default option considers the
Antenna Impedance as the load impedance of the transmission line, automatically
displaying the antenna input impedance at the chosen frequency as the load for the line.
However, you can enter any value for the line load impedance by selecting the Custom
Load option. This allows you to use the Feed Line tabsheet as an independent
calculator for transmission lines.

Feeder Results: Input Impedance and Losses
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After specifying the feeder parameters in the left side of the Feeder tab, the following

results will be obtained in its right side (Fig. 1):

Results

Characteristic Z0 |Il"5. 2927 -] 0.279421

Matched Loss |9.96459

At Feeder Input

Input Impedance |62.261 -j 3.00803

62,3654 Chm  at |-3.31664

Rho 0.0977477

VSWR 1.21667

Return Lass 20,1979

[ ] Power at Load 74.6937

Power Laost in Feed Line 20.3804

Power Laost in Trafo 4,42583

Total Feeder Loss 25,3063

= = =

=

True Velodity Factor |n. 776969

Total Matched Loss |IZI.EI'964E'EI d8

At Feeder Load

Load Impedance |333.453+j62.6534 |Dhm

338,288 Ohm at |10.6414 deg

Fho 0.642645

VSWR 4,59668

Return Loss |3.84058 dB

Radiated Power W
Antenna Loss W
Antenna Effidency %%
Feeder + Antenna Loss W

Fig. 1: Results panel on the right side of the Feeder tab. All results are automatically calculated
as parameters in the left side of the Feeder tab are modified.

Characteristic Z0

This is the “true” characteristic impedance of the feed line obtained from the RLGC
model via the KO, K1, and K2 constants. The real part of Z0 may differ somewhat from the
nominal Z0 depending on frequency and losses in the transmission line. An imaginary part
will always appear in Z0 due to non-zero losses. So, note that the true characteristic Z0
will generally differ from the “Nominal Z0” (Z0 in the cable datasheet).
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True Velocity Factor

This is the “true” velocity factor obtained from the RLGC model of the transmission line,
where the wavenumber (and wavelength inside the line) is affected by losses. The velocity
factor will be modified relative to its nominal value accordingly. Therefore, the true velocity
factor is a function of frequency and losses in the line.

Matched Loss

Any cable datasheet contains a table of matched loss values expressed in dB/100 feet or
dB/100 m as a function of frequency. These values correspond to the attenuation of the line
when it is matched (the line has a load impedance equal to Z0). So, the Matched Loss value
shown in the Results panel is the attenuation of the line corresponding to the selected
frequency.

Total Matched Loss

This is the matched loss that would be obtained for the specified length of the cable.
Therefore, the Total Matched Loss equals the Matched Loss (dB/100 feet or dB/100 m)
multiplied by the cable length.

At Feeder Input

The input impedance of the feeder (feed line + transformer) will be shown as well as the
reflection coefficient (Rho), VSWR, and return loss, all referred to the true characteristic
impedance of the feed line. This is the impedance at the feed line end opposite to the end
where the load or antenna is connected.

At Feeder Load

The load impedance connected to the feeder (feed line + transformer) will be shown as
well as the reflection coefficient (Rho), VSWR, and return loss, all referred to the true
characteristic impedance of the feed line. The load impedance will be the antenna input
impedance if the Antenna Impedance option was selected as a parameter for the feed line
in the left side of the Feeder tab. If a “Custom Load” was selected, then the load impedance
will be that entered by the user.

Power at Load

This is the power in Watts consumed at the feeder load impedance or effectively
delivered to the antenna terminals. This power will be less than the input power specified
as an input parameter for the feed line if the transmission line has losses. The power at the
load will be equal to the input power in the case of a lossless transmission line. Check the

https://antennasimulator.com/index.php/an-sof-user-guide/ 207/303


https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/

12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

Power at Load option to automatically set this power as the input power delivered to the
antenna terminals. Otherwise, the antenna input power will be that set manually in the
Excitation panel of the Setup tab.

Power Lost in Feed Line

This is the power lost along the transmission line in Watts.

Power Lost in Trafo

This is the power lost in the feeder transformer in Watts.

Total Feeder Loss

This is the sum of the powers lost in the feed line and in the transformer.

Radiated Power

This is the power in Watts radiated by the antenna when it is fed using the Power at Load,
which is the power effectively delivered to the load impedance of the feeder. The
radiated power will be different from the power delivered by the feeder if the antenna itself
has its own losses. The radiated power will be shown if the option Antenna Impedance was
selected as a load impedance for the feeder in the left side of the Feeder tab.

Antenna Loss

This is the power lost in the antenna structure. It will be shown if the option Antenna
Impedance was selected as a load impedance for the feeder in the left side of the Feeder
tab.

Antenna Efficiency

This is the ratio of the antenna radiated power to the antenna input power (the power
delivered by the feeder). It is expressed as a percentage as it is usual. It will be shown if the
option Antenna Impedance was selected as a load impedance for the feeder in the left side
of the Feeder tab.

Feeder + Antenna Loss

This is the sum of the powers lost in the feeder (feed line + transformer) and antenna.
Custom Feed Line Options

In addition to the manufactured cables listed in the Cable Type option, the following custom
line options can be chosen, as shown in Fig. 1:
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Feed Line Parameters

Feeder Transformer
Cable Type Custom lossless line e
Custom lossless line SRR L :
Nominal Z0 Custom line low loss model _
Custom line RLGC madel Nominal Impedance Chm
50 Ohm lossless line
Velodty Factor |75 Ohm lossless line Insertion Loss 0.25 dB
12" 50 Ohm Hardline
1/2° 75 Ohm Hardline
Length 7/3" 50 Ohm Hardline « | Loss Curve

3,33564 W 0 dB/100m 0 dB/100 m
t t
1200.83 deg s @
i MHz 100 MHz

Fig. 1: Custom line options.

Custom lossless line

This option represents an ideal transmission line with zero losses. Only the nominal Z0
and velocity factor can be specified in this case.

Custom line low-loss model

This option allows the specification of the nominal Z0, velocity factor, and matched loss
curve. To define the matched loss curve, two values of attenuation must be entered at two
different frequencies, with the second frequency being greater than the first one. AN-SOF will
adjust a low-loss model to obtain a curve of attenuation vs. frequency for subsequent
calculations. While the real part of the characteristic Z0 will be equal to the nominal Z0 in the
low-loss model, which is a good approximation in many cases, especially for higher
frequencies, the characteristic impedance will have an imaginary part that depends on the
line losses and frequency. The “true” velocity factor is also assumed to be equal to the
nominal velocity factor.

Custom line RLGC model

This option represents a transmission line model where losses are accurately considered by
adjusting a matched loss curve to the table of attenuation vs. frequency in the cable
datasheet. The KO, K1, and K2 constants must be entered in this case. The definition of KO,
K1, and K2 considers that the frequency is in Hz and lengths are in meters (SI metric units).
This option allows the entry of KO, K1, and K2 obtained from other transmission line
calculators.
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Load Impedances

Listing Load Impedances

Follow these steps to select a wire segment that has a load and to tabulate the load
impedance versus frequency,

A OWODN -

. Right click on a wire that has a load to display the pop-up menu >.

. Click on the List Currents command to display the List Currents toolbar >.

. Move the slider and select the segment where the load is placed.

. Click on the Load List button to display the Load List dialog box, where the list of

currents, voltages, and powers in the load impedance versus frequency is shown.
Select an item from the list in the upper right corner of the window and then press the
Plot button to plot the selected item versus frequency.

Internal Impedance of a Source

Follow these steps to select a wire segment that has a source and to tabulate the source
internal impedance versus frequency,

A OWODN -

. Right click on a wire that has a source to display the pop-up menu >.

. Click on the List Currents command to display the List Currents toolbar >.

. Move the slider and select the segment where the source is placed.

. Click on the Source List button to display the Source List dialog box, where the list of

currents, voltages, and powers in the internal impedance of the source versus
frequency is shown. Select an item from the list in the upper right corner of the window
and then press the Plot button to plot the selected item versus frequency.

Far Field

Plotting 2D Far Field Patterns

The radiation pattern can be visualized as a 2D rectangular plot by selecting Results > Plot
Far-Field Pattern > 2D Rectangular Plot from the main menu. This action will open the
Radiation Pattern Cut dialog box (Fig. 1), where two plot types are available:

Conical Plots: Generated with a fixed Theta and variable Phi.
Vertical Plots: Created with a fixed Phi and variable Theta.
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Radiation Pattern Cut pod
Cut Options
(®) Fixed Theta SrEx 1=
90 "
() Fixed Phi
QK Cancel

Fig. 1: The Radiation Pattern Cut
dialog box.

Select a radiation pattern cut and click OK to launch the AN-XY Chart application (Fig. 2),
where the radiation pattern is plotted against Phi for conical plots (fixed Theta) or against
Theta for vertical plots (fixed Phi).

[ AN-XV Chart - Plat1 - ] X

File  Edit  Plot Polarization Components

E B E = {9'}||Tnt VP HF RH LHI

Radiation Pattern (Total) at 300 MHz - Theta = 90 deg

0.95
0.9

0.8
0.75
0.7
0.65
0.6
0.55
0.5
0.45
0.4
0.35
0.3
0.25
0.2
0.15
0.1
0.05

Rad. Pattern

Phi [deg]

Fig. 2: A Radiation Pattern Cut plotted in AN-XY Chart in a rectangular chart.

Within the AN-XY Chart app, access the Plot menu to graph various parameters, including
Power Density, Directivity, Gain, E-field, and Axial Ratio. This menu also allows you to
represent these metrics in decibels (dBi for directivity and gain) and decompose them into
linearly polarized components: Theta (VP: Vertically Polarized) and Phi (HP: Horizontally
Polarized), as well as circularly polarized components: Right (RHCP: Right-Handed
Circularly Polarized) and Left (LHCP: Left-Handed Circularly Polarized). The app’s toolbar
features buttons: Tot, VP, HP, RH, and LH for quick switching between the total field metric
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and its corresponding polarization components. For instance, you can plot the total gain in
dBi or decompose it into its Theta (VP), Phi (HP), Right (RHCP), or Left (LHCP) components
to analyze antenna polarization characteristics. In the case of plane wave excitation, where
the antenna is receiving or the metallic structure is scattering electromagnetic waves, the
Radar Cross Section (RCS) will be plotted instead of directivity and gain.

The Axial Ratio is defined as the ratio of the minor axis to the major axis of the polarization
ellipse. It ranges from 0 to 1 in absolute value and can also be plotted in decibels. A circularly
polarized field exhibits an axial ratio of £1 (or 0 dB), while a linearly polarized field has an
axial ratio of zero. A positive (negative) axial ratio indicates a right-handed (left-handed)
polarized field.

The far-field pattern can also be visualized in a 2D polar chart by selecting Results > Plot
Far-Field Pattern > Polar Plot 1 Slice from the AN-SOF main menu (refer to Fig. 3). This
action will launch the AN-Polar app, which displays information such as maximum radiation,
beamwidth, and front-to-rear/back ratios.

ER 2AN-Polar - Plot1 o - O *®
fie Edit Plot Polarization Components
E B B = @“Tm VP HP RH LHI
Radiation Pattern (Total) [dB] at 300 MHz - Theta = 90°

Max: 0 dB @ 90° o0° ) AN-SOF
Phi: 0: 2.5 : 360° yaxis Antenna Simulator

1207 60°

150° 30°
180° 0° x-axis
30 020015 100 05 0

Beamwidth: 40° 20
@ 70°, 1107
Rear: -15.75 dB @ 270"
Front/Rear: 15.75 dB

240 300°
Back: -15.75 dB @ 270°

270°

Front/Back: 15.75 dB

Fig. 3: A radiation pattern cut plotted in AN-Polar.
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The AN-Polar app also features a toolbar with buttons: Tot, VP, HP, RH, and LH that enable
the decomposition of the plotted metric into its polarization components.

To plot two slices of a 3D far-field pattern on the same polar chart, navigate to Results >
Plot Far-Field Pattern > Polar Plot 2 Slices in the AN-SOF main menu. A dialog box will
appear, allowing you to select the two slices. You can choose from two vertical slices, two
conical slices, or vertical-conical combinations (see Fig. 4).

ER 2N-Polar - Plot1 - O *
Eile  Edit  Plot
E B ' = ;3;| Tot VP HP RH LH
Radiation Pattern (Total) [dB] at 300 MHz - Thetal = 90°, Phi2 = 90°
Max: 0 dB @ 90° - AN-SOF
Phit1: 0 : 2.5 : 360° Antenna Simulator
Theta2: 0 : 2.5 : 360° 120° 60°
150° 30°
180° 0°
30 20015 10 5 0

210° 3300

240° 300°
270°

Fig. 4: Two slices of the radiation pattern plotted in AN-Polar.

Clicking on a point in the polar curve will display the corresponding value of the represented
metric and the polar angle.

Plotting 3D Far Field Patterns

The far-field can be visualized as a 3D plot by selecting Results > Plot Far-Field Pattern >
3D Plot from the AN-SOF main menu. This action will open the AN-3D Pattern application,
where the radiation pattern is displayed in a 3D view, showcasing the radiation lobes with
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their intensities represented by a color scale.

Within the AN-3D Pattern application, access the Plot menu to select the Power Density,
Directivity (numerical and in dBi), Gain (numerical and in dBi), Radiation Pattern
(normalized to unity and to 0 dB), E-field, and Axial Ratio (dimensionless and in dB) (see
Fig. 1). Each field metric can be decomposed into its linearly polarized components Theta
(VP: Vertical Polarization) and Phi (HP: Horizontal Polarization), as well as its circularly
polarized components Right (RHCP: Right-Handed Circular Polarization) and Left (LHCP:
Left-Handed Circular Polarization). If the simulation involves plane wave excitation, the
Radar Cross Section (RCS) can be plotted instead of directivity and gain.

The Axial Ratio pattern is defined as the ratio of the minor to major axis of the polarization
ellipse. It equals 0 for a linearly polarized field and 1 for a circularly polarized field. While
lobes in a 3D polar plot can only represent absolute values, the sign of the axial ratio, which
determines whether the field is RHCP or LHCP, cannot be directly visualized here but can be
observed in a 2D rectangular plot. However, the toolbar in the AN-3D Pattern application
features buttons: Tot, VP, HP, RH, and LH for quick switching between the total field and its
polarization components, facilitating polarization analysis.
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B AN-3D Pattern - Plotl — O *
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Fig. 1: 3D far-field pattern (Gain in dBi) plotted in AN-3D Pattern.

The 3D graph can be rotated and moved by clicking the “3D Rotation” or “Move” buttons on
the toolbar and then dragging the mouse with the left button pressed. Use the mouse wheel
to zoom in or out. The AN-3D Pattern toolbar also includes an option to change the
frequency and dynamically observe the changes in the radiation pattern lobes as a kind of
animation (use the up-down arrow buttons next to the displayed frequency value).

Note

 If discrete sources were used as the excitation of the structure, the plotted far-
field represents the total field.

+ If an incident plane wave was used as the excitation, the plotted far-field
represents the scattered field.

To access the Preferences dialog box in the AN-3D Pattern main menu, click on Edit >
Preferences (refer to Fig. 2). This dialog box allows you to customize various options for the
colored surface and mesh of the radiation lobes (see Fig. 3). Additionally, you can
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superimpose the wire structure onto the radiation pattern by selecting the Wires option in the
“Show” box. You also have control over the graph’s scale and can display the main axes.

The radiation pattern cannot be directly exported from the AN-3D Pattern application.
However, the far-field pattern for a specific frequency can be tabulated by navigating to the
AN-SOF main menu > Results > List Far-Field Pattern and then pressing the “Export”
button next to the displayed table to export the data to a CSV (Comma Separated Values)
file.

Preferences hod

Options  Axes [ Background

Title
Gain (Total) [dEi] at 300 MHz

Surface Options

Surface and Mesh 1 Color
Color Scale Show
Unit | dBi “ Color Bar

Max Wires

—

Fig. 2: Preferences dialog box of the AN-3D
Pattern application.
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Total E-Field af 300 MHz

Total E-Figld at 300 MHz

Total E-Field af 300 bMHz
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Total E-Figld a1 300 MHz

Total E-Figld at 300 MH:

Total E-Figtd at 300 MHz

ity

ALY,

Fig. 3: Different options available for plotting radiation lobes.
Plotting the Far Field Spectrum

Far-field frequency spectra are obtained when a simulation is performed by specifying a list
of frequencies or conducting a frequency sweep. For each frequency, the far-field is
calculated at various directions determined by the zenith (Theta) and azimuth (Phi) angular
ranges, and the distance specified in the Far-Field panel of the Setup tabsheet. Therefore,
you must select a fixed direction (Theta, Phi) to plot the far-field versus frequency.

Go to Results > Plot Far-Field Spectrum in the main menu to plot the far-field spectrum.
This command will display the Select Far-Field Point dialog box (see Fig. 1), where you can
select the fixed Theta and Phi angles. After clicking the OK button, the AN-XY Chart
application will display the frequency spectrum of the total E-field (refer to Fig. 2).

Select Far-Field Point ot

Theta [deg] Phi [deg]

Fig. 1: Select Far-Field Point dialog
box for selecting a fixed direction
(Theta, Phi).
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Fig. 2: Far-field frequency spectrum plotted by AN-XY Chart.

You can also plot the linearly polarized field components, E-theta and E-phi, as well as the
circularly polarized components, E-right and E-left, in amplitude, phase, real, and imaginary
parts by selecting these options under the Plot menu in the AN-XY Chart application.
Additionally, you can plot the Axial Ratio, defined as the minor to the major axis ratio of the
polarization ellipse, as a function of frequency.

The far-field spectrum for a selected far-field point can also be tabulated. To do this, go to
Results > List Far-Field Spectrum in the AN-SOF main menu. This action will display the
Select Far-Field Point dialog box where you can select fixed values for Phi and Theta.
Afterward, a list of the far-field components versus frequency will be shown, and you can plot
it by clicking the Plot button (as shown in Fig. 3).
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) Far-Field at Theta = 0 deg, Phi = 0 deg (Distance = 10 m) O *
No. Frequency Real (E-theta) Imagq (E-theta) Abs (E-theta)
- MHz Vim Vim

1 11,0537 2.01656 7.19126 7.46864
2 76 10,9809 -0.926379 -7.5581 7.61486

3 77 10,9008 -3.67827 6.73196 7.67131 Sl

4 78 10,8243 -5,82895 49971 7.67774

5 73 10,7505 7.16215 -2.70034 7.6543

& 80 10,672 761123 -0.186291 7.61351

7 81 10,6125 7.22544 224267 7.56548

8 82 10,5566 6.1321 4,35106 7.51894

9 83 10,5158 -4,49955 5.9761 7.48062

10 84 10,4831 -2,50992 7.0194 7.45464

11 85 10,4833 -0,344387 7.43419 7.44219

12 86 10,4985 1.61343 7.21602 7.44188

13 87 10,5181 3.81495 6.39944 7.45028

14 88 10,5411 5.48688 5.05388 7.46312

<

Fig 3: Far-Field List showing the far-field components vs. frequency.
Power Budget

To access the Power Budget dialog box (see Fig. 1), go to Results > Power Budget/RCS in
the main menu. The following list of parameters versus frequency is displayed when discrete
sources are used for excitation:

https://antennasimulator.com/index.php/an-sof-user-guide/

The Input Power column shows the total input power provided by the discrete sources

in the structure.

The Radiated Power column shows the total radiated power from the structure.

The Structure Loss column shows the total consumed power, representing ohmic

losses in the structure.

The Efficiency column displays the radiated power-to-input power ratio. When the

structure is lossless, it results in an efficiency of 100%.

The Directivity columns display the peak directivity, dimensionless and in decibels

(dBi) with reference to an isotropic source.

The Gain columns display the peak gain, dimensionless and in decibels (dBi) with
reference to an isotropic source.
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The Av. EIRP (Effective Isotropic Radiated Power) columns display the time-averaged
EIRP in Watts and dBW. This value is calculated by factoring in the duty cycle of the
selected transmit mode in the Tuner tab, as well as the Time Transmitting
percentage.

The Peak EIRP (Effective Isotropic Radiated Power) columns display the peak EIRP in
Watts and dBW, calculated directly from the Peak Envelope Power (PEP), without
factoring in the duty cycle or time transmitting percentage.

The Av. Power Density column is the average power density. This value is calculated
averaging the power density over all directions in space.

The Peak Power Density column is the maximum value of the radiated power density.

The Theta (max) and Phi (max) columns are the zenith and azimuth angles,
respectively, in the direction of maximum radiation.

The FIR H and F/B H columns are the front-to-rear and front-to-back ratios,
respectively, in a horizontal slice of the radiation pattern given by Theta = Theta
(max).

The FIRV and F/B V columns are the front-to-rear and front-to-back ratios,
respectively, in a vertical slice of the radiation pattern given by Phi = Phi (max).

The Error column is the error in the power balance of the system. A necessary, but not
sufficient, condition for a model to be valid is that the input power must be equal to the
sum of the radiated and lost powers, so the Error is defined as follows:

Error % =100 x (Input — Lost — Radiated) Power / (Input — Lost) Power

The Average Gain Test (AGT) column represents a similar indicator to the Error
column. To validate a model, AGT should be close to 1, as it is calculated using the
formula:

AGT = (Radiated + Lost) Power / Input Power

Select an item from the list in the upper right corner of the window and then press the Plot
button to plot the selected item versus frequency. Click on the Export button to export the list
to a CSV file.
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B Power Budget . . - O x
Double-click to display plots
Mo, F Input P Radiated P c3
4] requency nput Fower adia awer TiE ——
— MHz W W Structure Loss
. ) Efficiency
1 ‘148 { 0.0233308 0.0238308 Directivity
E ; Directivity [dBi]
. 146.,5 0.0224517 0.0224617 Gain
Gain [dEi] A
3 147 0.0207329 0.0207399
4 147.5 0.0120314 0.01%0314 Plat
5 143 0.0175008 0,0175008 v
< > Export
Fig. 1: The Power Budget dialog box.
Notes

A power budget error of about #10% is permissible from the engineering point of
view.

When a real ground plane is used, the Error column shows the percentage of
power lost in the ground due to its finite conductivity.

When a substrate slab is used, this column shows the percentage of power
transferred to the dielectric material in the substrate.

AGT =1 means that the power balance is exact. An AGT between 0.99 and 1.01
is comparable to achieving an error of £1%.
Radar Cross Section

To access the Radar Cross Section dialog box (see Fig. 1), go to Results > Power
Budget/RCS in the main menu. The following list of parameters versus frequency is
displayed when an incident field is used for excitation:

The RCS [m?] column shows the Radar Cross Section in square meters.
The RCS [lambda?] column shows the Radar Cross Section in square wavelengths.

The RCS [dBsw] column shows the Radar Cross Section in decibels with reference to
a square wavelength.

The Radiated Power column shows the total scattered power from the structure.

The Structure Loss column shows the total consumed power, representing ohmic
losses in the structure.
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The Av. Power Density column displays the average power density scattered from the
structure. This value is computed by averaging the scattered power density over all

directions in space.

The Peak Power Density column shows the maximum value of the scattered power
density.

The Theta (max) and Phi (max) columns represent the zenith and azimuth angles,
respectively, in the direction of maximum radiation.

Select an item from the list in the upper right corner of the window and then press the Plot
button to plot the selected item versus frequency.

B Radar Cross Section - O X
No. Frequency RCS RCS ~ | [ -
RCS [lambda?]
MHz m? lambdaz RCS [dBsw]
............................................................... : Radiated Power
1 100 i 5.88613 0.65492 -1 Structure Loss
: : Pav
2 120 0.771097 0.123546 -9 Pmax
Theta (max) bt
3 140 0.209668 0.0457243 -1
4 160 0.356429 0.101525 -9 Plot
5 180 0.834139 0.300706 -5
6 200 1,97549 0.879212 o, 2oL
< >

Fig. 1: The Radar Cross Section dialog box.
Exporting the Far Field

The far field patterns and spectra can be tabulated and exported by going to the following
commands in the Results menu >:

List Far-Field Pattern
List Far-Field Spectrum

A table with the results will be displayed after executing any of these commands, Fig. 1. The
tabulated values can be exported to a CSV (Comma Separated Values) file by clicking the
Export button.
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B Fer-Field at 300 MHz - O X
No. Theta Phi E-total A Export
deg deg V/m

1 i) ‘o 0.123571 0

2 2.5 0 0.126141 -5

3 5 0 0.128989 -1

4 7.5 0 0.132088 -1

5 10 0 0.135409 -1

6 12.5 0 0.138924 -2

7 15 0 0.142602 2

8 17.5 0 0.146415 3,

< >

Fig. 1: Tabulated values of the far-field pattern. Click on the Export button to
export the list to a CSV file.
Front-to-Rear and Front-to-Back Ratios: Applying Key Antenna Directivity Metrics

Two commonly used metrics for quantifying the directional properties of an antenna radiation
pattern are the front-to-rear ratio (F/R) and the front-to-back ratio (F/B). Both F/R and F/B
are crucial parameters for evaluating antenna performance, especially in applications
requiring high directivity and low interference, such as point-to-point communication links
and satellite systems.

F/R is the ratio of the maximum power radiated by the antenna in the forward
direction to the maximum power radiated in the backward direction. It indicates the
antenna’s directional gain in the forward direction relative to its backward radiation. A
high F/R signifies strong forward radiation and low backward radiation.

F/B is the ratio of the maximum power radiated by the antenna in the forward
direction to the power radiated in the opposite direction. It measures the power
difference between the front and the directly opposing side of the antenna. A high F/B
also implies strong forward radiation and low radiation in the opposite direction.

Both F/R and F/B are typically expressed in decibels (dB).

Metric Definition

F/R (Worst-case Front-to- Ratio of maximum forward power to maximum backward
Back) power

F/B (180°-Front-to-Back) Ratio of maximum forward power to power at 180 degrees

Definitions of Front-To-Rear and Front-To-Back Ratios.
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Figure 1 illustrates the difference between F/R and F/B, assuming a 360-degree radiation
pattern slice.

Ed 2N-Polar - Plot1 - O *

File  Edit Plot
Radiation Pattern [dB] at 95 MHz - Phi = 0°

Max: -0.04488 dB @ 0°

Theta: 0: 2.5 : 360° o Front
330° 30°
300° 60°
270° 90°
A0 5 ]
Rear
Back
240° 120°
Beamwidth: 45°
@ 337.5°, 22.5°
Rear: -11.64 dB @ 240°
| Front/Rear: 11.59 dB | 2100 150°

Back: -15.56 dB @ 180°

IFronﬁBack: 15.52 dBI 180

Fig. 1: Vertical slice of a radiation pattern in a polar diagram, illustrating the Front-to-Rear (F/R) and Front-
to-Back (F/B) ratios.

In summary, the primary distinction between F/R and F/B lies in the direction of backward
radiation. F/R compares the maximum forward power to the maximum backward power,
while F/B compares the maximum forward power to the power radiated in the opposite
direction.

These definitions are applicable to both horizontal (6 = const.) and vertical (¢ = const.)
radiation patterns in free space. However, the presence of a ground plane introduces
complexities. For horizontal patterns, F/R and F/B calculations remain unchanged as the
angular range spans 360 degrees. Conversely, for vertical patterns, the angular range is
limited to 180 degrees. In this case, F/R is redefined as the front-to-side ratio, comparing
the maximum signal to the maximum signal in the opposite quadrant (as depicted in Fig. 2).
F/B becomes irrelevant due to the absence of a ‘back’ direction for an infinite ground plane,
resulting in a zero value from AN-SOF.
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ER AN-Polar - Plotl
File  Edit Plot
Radiation Pattern [dB] at 10 MHz - Phi = 45°

Max: -3.97 dB @ 48° .
Theta: 90 : 1: 90° 0° z-axis

-3o° 30°

Front
60° 60~

Side

-90°

90° xy-plane
402419 014 9 4

1200 120°

Beamwidth: 17°

@39°. 56 -150° 150°

Side: -5.629 dB @ -70° 180°
| Front/Side: 1.66 dB |

Fig. 2: Definition of Front-to-Side ratio for a vertical pattern in a polar plot when there is a ground plane.

Understanding F/R and F/B is crucial for effective antenna design. The Results tab in the
AN-SOF main window presents F/R and F/B values in dB as a function of frequency for both
vertical (V) and horizontal (H) radiation pattern slices. The Plots tab offers a visual
comparison of F/R and F/B over the frequency range.

Note:

To ensure proper calculations of F/R and F/B, select the Full 3D, Vertical or
Horizontal options in the Far-Field panel.

Selecting the Custom option in the Far-Field panel will lead to variations in the

calculation of F/R and F/B as they will depend on the specific angular ranges that
have been configured.

Golden Engineering
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Near Field

Plotting Near Field Patterns

The grid of points where the near field is calculated can be specified in the Near-Field panel
of the Setup tab. There, the points can be entered in Cartesian, Cylindrical, or Spherical
Coordinates. The near electric (E) and magnetic (H) fields can be calculated separately.
Of course, the near fields can be calculated in any region of an antenna, very close to it or
far away. In the far-field region, the near fields will tend to the known behavior of far-fields: E
and H are perpendicular to each other and perpendicular to the radial direction from the
antenna, they oscillate in phase, and their magnitudes have a constant ratio: E/H = 377
Ohms (often also approximated as 1201 Ohms) in free space. This behavior can be verified
by performing calculations of the “near” E and H fields far from an antenna.

When both E and H fields have been calculated, the power density (S) will also be available
in tables and plots. The total rms power density is calculated as S = |E x H|. This metric is
particularly important for assessments to evaluate electromagnetic field compliance with
radiation exposure limits published by regulatory authorities.

To plot the near electric field as a 3D graph with a color scale, go to Results > Plot Near E-
Field Pattern > 3D Plot in the main menu. This command executes the AN-3D Pattern
application (Fig. 1). To display a 3D plot of the near magnetic field or power density,
respectively, go to Results > Plot Near H-Field Pattern > 3D Plot or Results > Plot Power
Density Pattern > 3D Plot.
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Fig. 1: 3D plot of the near E-field in the AN-3D Pattern application just in front of an aircraft receiving a
vertically polarized plane wave from behind.

Near-field 3D plots will be shown according to the type of coordinate system chosen in the
Near-Field panel of the Setup tab: Cartesian, Cylindrical, or Spherical. If near-fields were
calculated for more than one frequency, a dialog box asking for a fixed frequency will be
shown before plotting the near-field pattern.

The near electric field can also be plotted as a 2D rectangular plot by going to Results >
Plot Near E-Field Pattern > 2D Plot in the main menu. The near magnetic field can be
plotted by going to Results > Plot Near H-Field Pattern > 2D Plot, and the power density
by going to Results > Plot Power Density Pattern > 2D Plot. These commands execute
the AN-XY Chart application, where the total rms electric field, magnetic field, or power
density is plotted in a 2D chart (Fig. 2). The components of the near E and H fields can be
plotted individually by going to the Plot menu in the AN-XY Chart and selecting the desired
component.
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Fig. 2: Near E-field plotted in AN-XY Chart as a function of the y-coordinate corresponding to the
horizontal line that passes just in front of the nose of the aircraft in Fig. 1.

The near-field patterns for a given frequency can also be tabulated by going to Results >
List Near E-Field Pattern, Results > List Near H-Field Pattern, or Results > List Power
Density Pattern in the AN-SOF main menu.

Regarding the E and H Field Components

If Cartesian coordinates have been set in the Near-Field panel of the Setup tab, the
Ex, Ey, and E; electric field components and the Hy, Hy, and H, magnetic field
components will be calculated in a rectangular grid of points in space with coordinates

(x, Y, 2).

If Cylindrical coordinates have been set in the Near-Field panel of the Setup tab, the

E:, Epni, and E; electric field components and the H,, Hppi, and H, magnetic field

components will be calculated in a cylindrical grid of points in space with coordinates (r,

phi, z).

If Spherical coordinates have been set in the Near-Field panel of the Setup tab, the

Er, Etheta, and Epp electric field components and the Hy, Hineta, and Hppj magnetic field
components will be calculated in a spherical grid of points in space with coordinates (r,

theta, phi).
Plotting the Near Field Spectrum
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Near-field frequency spectra are obtained when a simulation is performed by specifying a list
of frequencies or a frequency sweep. For each frequency, the near field is calculated at the
points specified in the Near-Field panel of the Setup tab. Therefore, a fixed point in space
must be selected to plot the near field versus frequency (the near field spectrum).

To plot the near E-field, near H-field, or power density spectrum, go to Results > Plot Near
E-Field Spectrum, Results > Plot Near H-Field Spectrum, or Results > Plot Power
Density Spectrum in the main menu. These commands display the Select Near-Field
Point dialog box, where a fixed observation point can be selected (Fig. 1). The AN-XY Chart
application will then show the frequency spectrum of the selected field (Fig. 2). The E and H
field components can be plotted in amplitude, phase, real, and imaginary parts by choosing
these options under Plot in the AN-XY Chart main menu.

Select Mear-Field Point ot

X [m] ¥ [m] Z [m]

o] i ]
coce

Fig. 1: Select Near-Field Point dialog box for selecting a
fixed observation point.
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Fig. 2: Near E-field spectrum in amplitude and phase plotted in AN-XY Chart.
Exporting the Near Field

Near field patterns and spectra can be tabulated and exported by going to the following
commands in the Results menu >:

List Near E-Field Pattern
List Near E-Field Spectrum
List Near H-Field Pattern
List Near H-Field Spectrum

A table with the results will be displayed after executing any of these commands. The
tabulated values can be exported to a CSV (Comma Separated Values) file by clicking the
Export button.

Transmission Lines

Adding Transmission Lines

Adding a transmission line to a model has an impact on the entire calculation, affecting
current distribution, input impedance, and near and far fields. AN-SOF allows for the addition
of lossy or lossless transmission lines and has a list of preloaded lines with parameters
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adjusted to the attenuation curves published in the data sheets of real cables. This list of
cables includes both two-wire and coaxial transmission lines.

After drawing and segmenting the wire structure that will represent an antenna or an object
that will scatter electromagnetic waves, the recommended first step is to create a list of the
transmission lines that will be connected to the structure. This is described below.

The ends of a transmission line in AN-SOF are called Port 1 and Port 2 since a line can be
considered as a two-port network. Each end or port of a transmission line can be
connected to a segment of the wire structure, as Fig. 1 shows. A transmission line is defined
by its characteristic impedance, Z0, velocity factor, VF, a loss model or attenuation curve,
and shunt admittances, Y1 and Y2, connected across each port. Each transmission line
must be connected between two different wire segments (the i-th and j-th segments in Fig. 1
should not be the same segment). In the calculation engine model, a gap is opened in the
center of each segment to allow a transmission line to be connected there.

i~th segment
== j-th segment

Transmission Line

Port 1 i Y1 20, VF, loss model Y2 i Port 2

Fig. 1: A transmission line connected between two wire segments. It is
defined by its characteristic impedance, Z0, velocity factor, VF, a loss
model, and shunt admittances Y1 and Y2.

Transmission lines are modeled in an implicit way, meaning that the lines don’t scatter
electromagnetic waves in space, but rather interact with the wire structure by establishing
boundary conditions on the voltages and currents at the connected segments. Implicit
modeling is adequate when the disturbance in the electromagnetic field caused by the
physical presence of the transmission line can be neglected, e.g., for twisted-pair lines in
most cases. On the other hand, explicit modeling involves drawing the two parallel wires of
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a two-wire line in the workspace and dividing them into segments, like the rest of the
structure. For coaxial lines, a “hybrid” modeling approach can be used, which is explained in
Modeling Coaxial Cables.

To add transmission lines, go to the AN-SOF main menu > Draw > Transmission Lines
(Ctrl + L). A table will be displayed where a transmission line can be entered on each row.
Follow the procedure below to enter the lines:

1. Select a row by clicking on the row number of your choice in the first column labeled

‘ ) H
No.’, Fig. 2.
B Transmission Lines — O >
Mo. Port 1 Port 2 Type 0 VF Length 000 - Custom lossless line
001 - Custom line low loss model
— — — — Ohm — m df 002 - Custom line RLGC model

003 - 50 Chm lossless line
005 - 127 50 Chm Hardline

006 - 1/2° 75 Ohm Hardline

007 - 7/8" 50 Chm Hardline

003 - 78" 75 Ohm Hardline

009 - 5DFB

010 - 7D-FB

011-8DFB

5 012 - 10D-FE

013 - 12D-FB

< > 014 - 551 Wireman Ladder Line W

b LA pa

Fig. 2: Table for entering transmission lines. Rows are numbered. Click on a row number to select the
entire row.

2. On the right-hand panel, choose a type of transmission line and double-click on your
chosen type. The selected row will be automatically completed, Fig. 3.

n Transmission Lines Double-click here - g X

Ma. Port 1 Port 2 Type 0 VF Length 091 - RG-6/CATV Belden 9115 A
092 - RG-6 Radioware

—_ — — = Chm — m 0‘33 F‘.G—S Belden 8237

DEI? F‘.G—B BElden 9314

098 - R.G-8 Comm5Scope 2427

099 - R.G-8 CommScope 3227

100 - R.G-8 Wireman CQ102

101 - RG-8 Wireman CQ 106

102 - RG-8 Wireman CQ 1000

5 103 - RG-8X Belden 9253

104 - RG-8X Radioware

< > 105 - RG-8¥ Tandy Cable "

$ | pa

Fig. 3: On the right panel, double-click on the chosen line type to automatically complete the selected row.

3. From type 3 onwards, the parameters correspond to real cable datasheets. If you wish
to enter your own parameters, choose types 0, 1, or 2. To edit the value in a cell,
double-click on the cell.
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Note that in this procedure, the ports of the transmission lines have not been connected to
the wire segments yet. This is explained in Connecting Transmission Lines.

The parameters that define a transmission line are:

1) Type: On the right-hand panel of the Transmission Lines window, there is a list of lines
with the cable part number and the manufacturer in some cases. The first three types are
used to input user-customized lines. The line type simply refers to its position in this list.

2) Z0: Nominal characteristic impedance, in Ohms. If a negative value is entered, the
transmission line will be “crossed” with a 180° phase reversal with respect to the reference
directions of the segments (the characteristic impedance of the line will of course be |Z0|).

3) VF: Velocity factor (dimensionless). The allowed range is 0 < VF <=1,

4) Length: Length of the line, in the unit selected in the Preferences window (see Section
“3.3 Preferences”). If a length of zero is entered, the length of the transmission line will be
equal to the linear distance between the two wire segments connected at the ends of the
line.

5) The K0, K1, K2, and K3 columns define the line losses for the so-called RLGC model.
These four columns will change to Att. 1, Freq. 1, Att. 2, Freq. 2 when the chosen line
model is that of low losses. These cells allow entering the attenuation curve of a real
transmission line from its datasheet.

6) Real(Y1) and Imag(Y1) are the real and imaginary parts of the shunt admittance through
Port 1 of the transmission line, in Siemens [S].

7) Real(Y2) and Imag(Y2) are the real and imaginary parts of the shunt admittance through
Port 2 of the transmission line, in Siemens [S].

A transmission line without shunt admittances (Y1 = Y2 = 0) will always be symmetrical in
the sense that if it is connected in reverse, i.e., by swapping ports 1 and 2, the same results
will be obtained in a simulation. Ports 1 and 2 are identified so that the locations of the shunt
admittances can be distinguished when they are not zero.

If you enlarge or maximize the Transmission Lines window, you will be able to see the
columns corresponding to the loss model parameters and shunt admittances, Figs. 4 and 5.
Initially, this window only displays cells up to the ‘Length’ column so that the user does not
have to worry about the loss parameter values since these are automatically loaded when
selecting a line type from the list. Adding an attenuation curve when modeling a cable that is
not on the list is explained in Adding a Custom Lossy Line.
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B Trensmission Lines RLGC loss model Shunt Admittances - b X

Port 1 Part 2 Type 0 VE Length | Ko K1 K2 K3 | IReaI(‘(l} Imag (Y1) | Real (¥2) Imag(‘(z}l

096 - RG-8 Belden 9913F7
- - - COhm = m — = — — 5 5 2 5 097 - RG-8 Belden 9914

098 - RG-8 CommScope 2427K

099 - RG-8 CommScope 3227

100 - RG-8 Wireman CQ102

5 50.2 0.81 0 0.2 1 2,754 100 1] 0 o 1} 101 -RG-8 Wireman CQ106

102 - RG-8 Wireman CQ1000

103 - RG-8X Belden 9258

104 - RG-8X Radioware

105 - RG-8X Tandy Cable

106 - RG-8X Wireman CQ116

107 - RG-8X Wireman CQ117 v

No
2
3
4
9

Fig. 4: Enlarge the Transmission Lines window to view the loss model parameters and shunt admittances.
In this example, the KO, K1, K2, and K3 columns of the RLGC model are displayed since a line has been
chosen whose attenuation curve is adjusted to this model.

] Transmission Lines Low Loss model Shunt Admittances - o *
Mo, Port 1 Port 2 Type 0 VF Length I At 1 Freg. 1 Att. 2 Freg. 2 I I Real (Y1) Imag (Y1) = Real {¥2) Imag (Y2) I
006 - 1/2" 75 Ohm Hardline
= = = = Ohm = m dB/100 m MHz dBf100 m MHz s 5 5 s 007 - 7/8" 50 Ohm Hardline
008 - 7/8" 75 Ohm Hardline
iy 95 50 0.84 0 0.0131927 4.24452E-6 7.31627E-120 1] 0 o 1] 009 - 5DFB
010 - 7DFEB
5 50.2 0.81 0 0.2 1 2,754 100 0 0 ] 0 011-8DFB
012 - 10DFB
3 013 - 12DFB
014 - 551 Wireman Ladder Line
4 015 - 551 Wireman LL icefsnow
016 - 552 Wireman Ladder Line
5 017 - 552 Wireman LL icefsnow v

Fig. 5: Enlarge the Transmission Lines window to view the loss model parameters and shunt admittances.
In this example, the Att. 1, Freq. 1, Att. 2, and Freq. 2 columns of the low loss model are displayed since a
line has been chosen whose attenuation curve is adjusted to this model.

Custom Transmission Lines

If you want to add “custom” transmission lines with your own parameters, you have types 0,
1, and 2 available, Fig. 1, which are explained below.

B Transmission Lines — O >

Mo, Fort 1 Fort 2 Type Z0 VF Length
001 - Custom line low loss model
— — = — Ohm --- m 002 - Custom line RLGC model
{50 1 a0 004 - 75 Ohm lossless line

005 - 127 50 Ohm Hardiine

1 50 0.65 0 006 - 1/2° 75 Chm Hardline

007 - 7/8" 50 Chm Hardline

50 0.66 0] 008 - 78" 75 Ohm Hardline

009 - 5D-FB

010 - 7DFE

011 - 3DFB

012 - 10DFB

013 - 12D-FB

114 - 551 Wireman | adder | ine 7

[E N L %]
%)

Fig. 1: The first three types of transmission lines, types 0, 1, and 2, are customizable lines.
Type 0: Custom Lossless Line

This is an ideal transmission line with zero losses, so only the nominal Z0 and velocity factor
must be specified.

Type 1: Custom line — low loss model
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This is a transmission line where the nominal Z0, velocity factor, and matched loss curve can
be specified. To define the matched loss curve, two attenuation values must be entered at
two different frequencies, with the second frequency being greater than the first. AN-SOF will
then adjust a low-loss model to obtain an attenuation vs. frequency curve for subsequent
calculations. This is the simplest way to enter parameters from the datasheet of a
manufactured real transmission line. Refer to Adding a Custom Lossy Line where it
explains how to add the parameters from an attenuation curve published in a datasheet of a
real cable.

Type 2: Custom line — RLGC model

This is a transmission line model that considers losses by adjusting a matched loss curve to
the table of attenuation vs. frequency in the cable datasheet. The KO, K1, and K2 constants
must be entered in this case. The definition of KO, K1, and K2 assumes that the frequency is
in Hz and the lengths are in meters (S| metric units). This option allows for the entry of KO,
K1, and K2 obtained from third-party transmission line calculators (K3 is an additional
constant that is zero for all available cables).

Connecting Transmission Lines

Any transmission lines added through the Transmission Lines command (Ctrl + L) under
the Draw menu will remain in the table until the user decides to remove or modify them.
During calculations, only transmission lines with both ports connected to respective wire
segments will be considered for simulation. Any lines with a single port connected or
both ports disconnected will be omitted in the calculations.

To connect a transmission line between two wire segments, follow these steps:

1. Right-click on the first wire to select it and choose the Source / Load / TL (Ctrl + Ins)
command from the pop-up menu. This will open a horizontal toolbar with a slider
control, Fig. 1.

https://antennasimulator.com/index.php/an-sof-user-guide/ 235/303


https://antennasimulator.com/index.php/knowledge-base/adding-a-custom-lossy-line/

12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

B AN-50F - Project1
File Edit Draw View Tocls Run  Results Help
NDEHE ¢ | & 8 [@| &k T N & fy & & |G| | xy yz 7K |

Setup Workspace  Feedline Results  Plots

€9 Source/Load/TL Ctrl+ins
#  Modify Ctrl+M
Wire Color

¢ Delete Ctrl+Del

Copy Start Peint
Copy End Point
Plot Currents
List Currents...
J  Wire Properties...  Ctrl+W

Draw

T
wi (I 4

Transmission Lines v
a @ & 3 Segment: 40f 7 Position: 50%
Wires: 2 Sources: 0 Loads: 0 Segments: 22 Connections: 0 GNDs: 0 Totak 22

Fig. 1: To display the horizontal toolbar at the bottom of the workspace window, right-click on a wire and
choose the “Source / Load / TL” command from the pop-up menu that appears. Then, move the slider to

select a segment.

2. Use the slider to select the specific segment of the first wire to which you want to

connect a port of the transmission line.

3. Once you’ve chosen the segment, click on the Transmission Lines button on the

horizontal toolbar to open the Transmission Lines table, Fig. 2.
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B Tansmission Lines - m} x
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8 75.2 0.81 o 012 - 10D-FB
013 - 12DFB
o 93 50 0.66 0 014 - 551 Wireman Ladder Line
015 - 551 Wireman LL ice/snow
112 78 0.86 0 016 - 552 Wireman Ladder Line

017 - 552 Wireman LL ice/snow
018 - 553 Wireman Ladder Line
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Enter an 'X' to connect a port to the selected segment | |020 - 554 Wireman Ladder Line
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Fig. 2: To display the Transmission Lines window, click on the “Transmission Lines” button located on the
horizontal toolbar. Then, enter the letter “X” (in either lowercase or uppercase, without quotes) in the cells
of the ports that you wish to connect to the selected segment.

4. Enter an “x” or “X” (without quotes) in the corresponding cell for the port you want to
connect to the selected segment (the cells located below the “Port 1” and “Port 2”
columns), Fig. 2. You can enter an “X” for all the ports that need to be connected to the
same segment as multiple transmission lines can be connected to it. Finally, close the
Transmission Lines window.

5. Select the second wire and repeat steps 1-4 to connect the second port of the
transmission line to another segment, Fig. 3. The transmission lines with both ports
connected will be graphically displayed as shown in Fig. 4.
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Fig. 3: Select the second segment and enter an ‘X’ in the ports that you want to connect there.
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Fig. 4: Transmission line in the workspace, connecting two segments located on different wires.
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While performing this procedure, you have the option to add more transmission lines directly
in the “Transmission Lines” dialog window. This saves you from having to follow the steps
outlined in Adding Transmission Lines. The advantage of adding transmission lines here is
that you can edit the connections of the lines in the “Port 1” and “Port 2” columns. However,
with the Draw > Transmission Lines (Ctrl + L) command, you can quickly edit the lines (Z0,
VF, length, etc.) if you don’t need to change the port connections.

A port that is already connected to a segment will show the status as “Connected,” while if
it is not connected to any segment, it will display the status as “FREE”. When we are on a
selected segment, a connected port will show the status as “Here,” which refers to the port
being connected specifically to that selected segment.

To disconnect a port from a segment, enter the word “FREE” (without quotes, in uppercase)
in the corresponding cell instead of an “X”. This allows you to use the “X” and “FREE”
commands to easily connect and disconnect ports on a selected segment.

The transmission lines that have both ports connected to segments are displayed as
straight dashed lines in orange color in the workspace, Fig. 4. An arrow will indicate the
direction of the line, which goes from port 1 to 2. Since the length of a line is another
parameter that is entered, such as its characteristic impedance and velocity factor, the length
of the line in the workspace may not represent the configured or “real” length of the line.

If you select a row by clicking on the row number in the Transmission Lines table, the
corresponding line will be highlighted in red in the workspace (if it has both ports
connected to segments), Fig. 5. This way, you can visually identify which line you are editing.
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Fig. 5: By selecting a row in the Transmission Lines table, you can easily identify the corresponding
transmission line in the workspace as it will be highlighted in red.

IMPORTANT Information

A transmission line with only one port connected to a wire segment will not be
considered in the calculations. Instead, it exists as a row within the table, which can be
used as a library of lines to select from and connect to the wire structure. Therefore,
when a port is FREE, it does not mean that the corresponding end of the
transmission line is open circuited, but rather that this line will simply be omitted in
the simulation. It is sufficient for only one port to be FREE for the line to be omitted. If
you need to connect a line with an open or short-circuited end, please refer to Open
and Short-Circuited Lines for detailed instructions.

A voltage or current source can be connected to any segment where one or more
transmission line ports are connected. In this case, the sources will always be
“ideal”, i.e., with zero/infinite internal impedance (zero for voltage sources and infinite
for current sources), unlike in an ordinary segment without a port connected, where
sources may have non-zeroffinite internal impedance (in AN-SOF, current sources
should always have a finite internal impedance because this impedance is connected
in parallel with the current source).
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In each segment, only transmission line ports or a load impedance are allowed,
but not both. If a port is connected to a segment where a load impedance already
exists, this impedance will be eliminated, and vice versa. If you need to connect a load
impedance in series with the port of a transmission line, connect the impedance in an
adjacent segment to the port.

When there are transmission lines in the model, the NGF (Numerical Green’s
Function) option will be automatically enabled in the Settings panel of the Setup
tabsheet. This way, calculations will be performed faster in the next simulation if only
the parameters of the transmission lines are modified while the wire structure remains
unchanged.

It is recommended to connect transmission lines after drawing and segmenting the
wire structure. If the number of segments changes, the lines may become
disconnected and need to be manually reconnected using the procedure described in
this section.

To ensure a smooth calculation process, AN-SOF will verify the correct connections
between the transmission lines and the wire segments. If AN-SOF detects any errors, it
will promptly remove the faulty connection by setting the corresponding port to FREE
state.

Open and Short-Circuited Lines

Due to the model used in the calculation engine, the transmission lines that are considered
to exist in the simulation are those that have both ports connected to wire segments.
Therefore, if you want to have an open-circuited line connected to a certain segment, the
opposite port must also be connected to another wire segment. Create a short wire with
only one segment that is no longer than 1% of the wavelength (its radius can be one-tenth
of its length) and connect it to the open circuit transmission line port. This short wire should
be disconnected from the rest of the structure, and the shunt admittance of the port it's
connected to should be zero, Fig. 1.
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Open-circuited
Il_'?nsmission Line

Port 2

T <00t

Y2=0

Fig. 1: Open circuit transmission line. The port that is open circuited is
connected to a short wire that has only one segment and has a null shunt
admittance.

On the other hand, if you need a transmission line with a short-circuited port, connect that
port to any other segment and set a shunt admittance at that end that is very large, for
example, 1E6 [S]. At this end, you could connect a short wire segment created for this
purpose, as is done for an open-circuited line, Fig. 2.
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Short-circuited
Il_'zilnsmission Line

Y2=1E6S

Fig. 2: Short circuited transmission line. The port that is short circuited is
connected to a short wire that has only one segment and has a large shunt
admittance.

When creating short wires to connect open or short circuit transmission line ports, it is
advisable to move these wires away from the rest of the structure to minimize interaction
with it. Enter the length of the transmission line as indicated in Adding Transmission Lines.
Remember that the length of the line is not necessarily related to the actual distance
between the segments where it is connected.

Editing Transmission Lines

The Transmission Lines table has a pop-up menu with keyboard shortcuts, Fig. 1. To
access this menu for editing cells and rows, right-click on the table. The available commands
are:
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Fig. 1: Pop-up menu in the Transmission Lines table.

1. Standard Cut (Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V) options are available
for cells. A single cell can be selected by left clicking on it or by using the TAB and
arrow keys on the keyboard.

2. To select a row, click on the row number in the left column (the “No.” column). Use
the mouse or the up and down arrow keys on the keyboard to select a single row.
Double-click on a single cell to exit row selection mode.

3. Cut (Ctrl + X), Copy (Ctrl + C), and Paste (Ctrl + V) options also apply to a selected
row. In addition, Insert (Ins key) and Delete (Del key) options can be used to add or
remove rows.

4. The Clear Contents (Ctrl + Del) command clears the content of a selected cell or row.

5. The Move Rows (Ctrl + M) command allows you to enter a mode where rows can be
moved up or down to order them as desired. To exit this mode, click Move Rows (Ctrl +
M) again.

6. The Update Ports (Ctrl + U) command checks and updates the status of the
transmission line ports. Use this command to verify that the lines have their ports
connected to wire segments when you have made any modifications to the
segmentation or geometry of the wires where there are transmission line ports.

Modeling Coaxial Cables

Coaxial transmission lines can be modeled implicitly, as explained in previous articles. To
define a coaxial cable, one needs to know its characteristic impedance (Z0), velocity factor
(VF), length, parameters that model losses (KO, K1, K2, etc.), and the shunt admittances at
each end (Y1 and Y2). Additionally, each end or port of the line must be connected to the
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center of a wire segment. In this implicit model, the electromagnetic interaction between
the coaxial cable shield and the wire structure is neglected, and the line ends impose
boundary conditions on the voltage and current in the connected segments. However, in
certain scenarios, a current can be induced that flows through the outside of the coaxial
cable shield, known as common-mode current, and this current cannot be neglected. To
address this, a hybrid model is used, which is explained in detail below.

In the hybrid model, the internal behavior of a coaxial cable is implicitly modeled using its
parameters such as Z0, VF, length, etc. On the other hand, the outer shield is modeled by
adding a wire that must be divided into segments like the rest of the structure, Fig. 1. This
additional wire considers the current induced outside the coaxial cable shield.

= - r
£
? &
m 3
@
=
Transmission Line e -
g‘! Port 1 Y1 Z0, VF, loss model Y2 B Port2 3
m -
m [ ] -
-
Coated wire to model the shield §
: 3
g 3
E =
f=2]
°’ |
’ - T ==== -

Fig. 1: An additional wire is connected between two ends of the ports of a coaxial transmission line to
model the cable shield. This wire needs to be divided into segments just like the rest of the structure.

The wire representing the shield should be connected between two ends of the segments
where the cable is connected, Fig. 2. Unlike transmission lines that connect in the center of
the segments, wires are connected at their ends. Hence, the additional wire representing
the shield will be a segment offset from the actual position of the cable. This is not a
significant concern since the segments should be small compared to the wavelength.
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Transmission Line

. ___._____-=_| Port 2

hield

Coated wire to model the s

Fig. 2: Visualization of the sketch in Fig. 1 in the AN-SOF workspace.

The short wires, each consisting of one segment, that are required to

connect the wire representing the coaxial cable shield are highlighted
in red.

Please be reminded that to connect one wire to another and connect the ends of the
coaxial cable shield, you will need to manually divide the wires involved, as explained in
Connecting Wires.

To simulate the dielectric coating of actual coaxial cables, an outer insulation can be added
to the wire representing the shield, and its thickness can be input as well.
Adding a Custom Lossy Line

AN-SOF provides parameters for modeling the losses of more than 160 types of
transmission lines. These parameters have been obtained by adjusting the loss model to the
attenuation curves published by manufacturers. In case a particular type of cable is not listed
or if the manufacturer has updated the parameters, a custom transmission line can be
created using the following procedure:

https://antennasimulator.com/index.php/an-sof-user-guide/ 246/303


https://antennasimulator.com/index.php/knowledge-base/connecting-wires/

12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

1. Open the Transmission Lines window by going to the main menu > Draw >
Transmission Lines (Ctrl + L) or follow the procedure in Connecting Transmission

Lines to open this window by selecting a wire.

2. Select a row from the table by clicking on the row number (under the first column
labeled No.).

3. In the panel on the right, double-click the Custom line low loss model option.

4. All manufacturers publish the nominal characteristic impedance, Z0, and the
velocity factor, VVF. Enter these values as well as the length of the line. If you enter “0”
in the length cell, the linear distance between the ends of the cable will be calculated.

5. Manufacturers also publish an attenuation table as a function of frequency. Here is an
example for the Belden 8237 cable, type RG-8/U:

Nom. Characteristic Impedance:

r—

Nominal Velocity of Propagation:

Nom. Attenuation:

1 2
10 6
50 13
100 19
200 2.8
400 42
700 59
900 6.9
1000 7.4
4000 232

6. In the cells corresponding to Att. 1, Freq. 1, Att. 2, and Freq. 2, enter the values from
the attenuation table so that the simulation frequency range is included between
Freq. 1 and Freq. 2. For example, if you are running a calculation between 150 and
170 MHz, enter Att. 1 = 1.9 dB/100 ft, Freq. 1 = 100 MHz, Att. 2 = 2.8 dB/100 ft, Freq. 2
= 200 MHz, as indicated in the table for the Belden 8237 cable, Fig. 1.
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ﬂ Transmission Lines = O x
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— -— — — Ohm - ft dB/100 ft MHz dB/100 ft MHz - Custom line R d
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: 005 - 1/2° 50 Ohm Hardline
006 - 1/2" 75 Ohm Hardline
007 - 7/8" 50 Ohm Hardline
003 - 7/8" 75 Ohm Hardline
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< > 014 - 551 Wireman Ladder Line hd

Fig. 1: Entering the values of nominal characteristic impedance, velocity factor, and attenuation for a
Belden 8237 cable, type RG-8/U, when the frequency sweep of the simulation is within the range of 100 to
200 MHz.

Be careful with the units of attenuation and frequency, as they will be displayed in the units
chosen in the Preferences window. Go to main menu > Tools > Preferences > Units tab to
change the units for frequency and length.

Step By Step

Download Examples

In the directory where AN-SOF was installed there is a folder called “Examples” which
contains many examples of antennas and wire structures. The default directory is

C:\AN-SOF X\Examples
where X is the AN-SOF version.
You can also download the examples from here >.

We constantly upload files with examples on our website. You will find downloadable
examples on our Resources and Blog pages.

At the bottom of our website there are Categories and a Search bar to facilitate the search
for information.

We also invite you to subscribe to our Newsletter here > and to follow us on our social
media channels.

From this link you can download 5 examples of antenna models that have less than 50
segments, so the calculations can be run with the trial version of AN-SOF:

e 2 Element Quad

e 2 Element Delta Loop
o HF Skeleton Slot

e Inverted V
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e 5 Element Yagi-Uda

Download 5 Examples
Explore 5 Antenna Models with Less Than 50 Segments in AN-SOF Trial Version

Discover 5 antenna models with less than 50 segments in AN-SOF Trial Version. These
examples showcase the capabilities of our software for antenna modeling and design,
allowing you to evaluate its features for your projects.

lllustration of 5 antenna models with less than 50 segments in AN-SOF Trial Version.

The trial version of AN-SOF is fully-featured and never expires. It allows users to open all
pre-calculated example files to view tables and display various graphs and plots. The only
limitation is that it can run calculations with up to 50 “unknowns”. An unknown refers to the
electric current value to be determined by the AN-SOF calculation engine in each segment,
segment-to-segment connection, and a connection to a ground plane, if any. Therefore,
the total number of unknown currents equals the number of segments + number of
connections + number of connections to ground. This number must not exceed 50 to run a
calculation in AN-SOF Trial version.

The purpose of the trial version is to evaluate the AN-SOF features and capabilities for
antenna modeling or design projects. The pre-calculated models can be found in the AN-
SOF “Examples” folder typically located in the installation directory, such as C:\AN-SOF
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X\Examples, where “X” represents the version of the program. Additionally, many model
examples with descriptive articles can be found in the Models section of our Knowledge
Base. These models are categorized according to the antenna type, ranging from simple
wire antennas to antennas in complex environments.

For more complex antennas, the 50 unknowns limit may be quickly exceeded. Modifications
to pre-calculated examples with more than 50 segments + connections + ground
connections cannot be re-run with the trial version of AN-SOF. However, for simple antenna
projects or small antenna sizes in terms of the wavelength, the trial version can be a
useful tool for simulations.

Download the following 5 examples with less than 50 segments to make modifications to the
antenna structures:

2 Element Quad

2 Element Delta Loop
HF Skeleton Slot
Inverted V

5 Element Yagi-Uda

Download Models

To achieve reliable results, at least 10 segments per wavelength of wire should be used in
a model. For antennas sensitive to element lengths, like Yagis, about 50 segments per
wavelength should provide results comparable to VSWR measurements.

Explore more examples and articles in the Validation section of our Knowledge Base.
Additionally, AN-SOF trial version includes embedded tuner and feeder calculators, allowing
users to synthesize impedance matching networks, add transformers, and calculate tuner
and feed line parameters for measured or given load impedance.

In conclusion, AN-SOF Trial Version offers a comprehensive platform for antenna simulation,
enabling users to evaluate its features and capabilities for their projects. With access to pre-
calculated examples and embedded tools like tuner and feeder calculators, users can
explore antenna designs with ease.

See Also:

Complete Workflow: Modeling, Feeding, and Tuning a 20m Band Dipole Antenna
Modeling a Center-Fed Cylindrical Antenna with AN-SOF

Learn how to simulate a center-fed cylindrical antenna using AN-SOF software. This step-by-
step guide covers setup, geometry creation, simulation, and result analysis. Understand
dipole characteristics through practical examples.

https://antennasimulator.com/index.php/an-sof-user-guide/ 250/303


https://antennasimulator.com/index.php/knowledge-base/?top-category=models
https://antennasimulator.com/examples/5Examples.zip
https://antennasimulator.com/index.php/knowledge-base/?top-category=validation
https://antennasimulator.com/index.php/knowledge-base/tuner-for-impedance-matching/
https://antennasimulator.com/index.php/knowledge-base/adding-a-feed-line/
https://antennasimulator.com/index.php/knowledge-base/complete-workflow-modeling-feeding-and-tuning-a-20m-band-dipole-antenna/

12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

Introduction: Center-Fed Cylindrical Antenna Simulation

The center-fed cylindrical antenna serves as a fundamental example for simulation.
Essentially a straight wire with a central excitation, it transitions into a half-wave dipole when
its length aligns with half the wavelength of the operating frequency. The following steps
outline the simulation process using AN-SOF.

Step 1: Configuring the Simulation Environment

To initiate, navigate to Tools > Preferences within the main menu to establish appropriate
units for frequency (MHz) and length (mm). Subsequently, access the Setup tab. Within the
Frequency panel, select Sweep and configure the Frequency Sweep parameters as
depicted in Fig. 1. The calculations will be performed at the frequencies: 50, 55, ..., 295, 300
MHz. Crucially, ensure that None (free space) is chosen in the Environment panel‘s
Ground Plane box and Discrete Sources is selected under the Excitation panel.

¥ Frequency
Options Frequency Sweep
O single @ Lin Olog
O Start [0 | MHz
Step [:l MHz
@ Sweep Stop MHz

Fig. 1: Frequency sweep parameters setup.

Step 2: Creating the Antenna Geometry

To initiate the antenna geometry creation, right-click within the workspace and select Line
from the ensuing pop-up menu. The ‘Line’ dialog box will appear. Populate the Line and
Attributes pages as outlined in Figs. 2 and 3 to generate a straight wire comprising 17
segments and a 5 mm radius within the workspace. The wire will be drawn starting from
point (0,0,-750) [mm] and ending at point (0,0,750) [mm], aligning with the z-axis and
spanning a length of 1500 mm, equivalent to a half-wavelength at 100 MHz. Press F7 to
visualize the primary axes.

Subsequently, right-click on the wire and choose Source/Load/TL from the context menu.
Adhering to the procedures detailed in “Adding Sources,” introduce a voltage source at
the wire’s center (segment 9). Set the source voltage to 1 (0°) V. The resulting center-fed
cylindrical antenna is visually represented in Fig. 4.
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[Line /| Attrbutes | Materials |

Options: [2 Points

From Point [mm]

X10 Y10

To Point [mm]
X20

Fig. 2: Line dialog box for defining the antenna
geometry.

Fig. 3: Line attributes configuration.

https://antennasimulator.com/index.php/an-sof-user-guide/ 252/303



12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

AN-50F - Projectt - o b4
File Edit Draw View Tools FRun Results Help

= | % ] ¢ B3 N fx Sy £z g | %y w2 ozx | 3R @ | B B L |

Setgp  Workinaie  Feedline  Results

‘Wires: 1 Seurces: 1 Loads: 0 Segments: 17 Connections: 0 GNDs: 0 Totalk 17

Fig. 4: Center-fed cylindrical antenna geometry.

Download Model

Step 3: Simulation Execution and Result Analysis

To initiate the simulation process, click the Run Currents and Far-Field (F11) button on the
toolbar. Upon completion, right-click on the wire and select Plot Currents from the context
menu, specifying the desired frequency. The resulting current distribution along the wire is
graphically represented in Fig. 5. To access additional parameters of interest, refer to the
procedures outlined in “Displaying Results.”

As an illustrative example, Figures 5, 6, and 7 depict the current distribution at 100 MHz
(amplitude in Fig. 5(a) and phase in Fig. 5(b)), input impedance versus frequency (real
part in Fig. 6(a) and imaginary part in Fig. 6(b)), gain in dBi (Fig. 7(a)) at 100 MHz, and E-
field pattern (Fig. 7(b)) at 100 MHz.

Given that the antenna length (1500mm) equals half a wavelength at 100 MHz, the
observed current distribution in amplitude approximates a half-cycle sine function, aligning
with the expected behavior of a half-wave dipole. A slight decrease in the amplitude and a
sharp increase in the phase can be seen at the antenna center, due to the presence of the
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voltage source just there. The presence of the voltage source at the center disrupts the
continuity of the current’s slope (derivative) at that point, while the current itself remains
continuous.

B AN-XY Chart - Plot1 - o X

File Edit View Plot

Fig. 5(a): Amplitude of the current distribution along the cylindrical antenna at
100 MHz.

[ AN-XY Chart - Plot1 - u] X
File Edit View Plot

Fig. 5(b): Phase of the current distribution along the cylindrical antenna at 100
MHz.
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If we look closely at Figure 6(b), which shows the input reactance (imaginary part of the
input impedance), we can see that the curve crosses zero just before 100 MHz, with a
positive slope (series resonance), then crosses zero again just above 170 MHz, with a
negative slope (parallel resonance), and then crosses zero again just below 300 MHz with
a positive slope (series resonance). These three points where the reactance vanishes
correspond to when the physical length of the dipole approaches: A/2, A, and 3A/2. The
resonances do not occur exactly at integer values of half wavelength because the thickness
of the dipole is not infinitesimal. In Figure 6(a) we can see that the input resistance is
maximum at the frequency that corresponds to the parallel resonance. All these are the
expected and classical behaviors of a dipole of finite thickness.

B AN-XV Chart - Plot1 - O X
File Edit View Plot

Input Imped e vs. Freq v

Real Part [Ohm]
g 8
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Frequency [MHz]

Fig. 6(a): Real part of the input impedance vs. frequency.
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Regarding the gain pattern in Fig. 7(a), it is donut-shaped as expected for a half-wave
dipole, with a maximum of 2.18 dBi. We should remember that the theoretical peak gain of
an infinitesimally thin half-wave dipole in free space with a perfect sinusoidal current
distribution is 2.15 dBi (corresponding to a numerical gain of 1.64). The obtained gain in AN-
SOF is 0.03 dBi higher than the theoretical value due to the finite radius of the cross-section
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Fig. 6(b): Imaginary part of the input impedance vs. frequency.

of the dipole.
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Fig. 7(a): Gain pattern (dBi) at 100 MHz.
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Fig. 7(b): Total E-field pattern at 100 MHz.

Conclusion

This tutorial provided a step-by-step guide to simulating a center-fed cylindrical antenna
using AN-SOF software. By following the outlined procedures, users can efficiently model
this fundamental antenna type and analyze its key characteristics.

The simulated results align with the expected behavior of a half-wave dipole, demonstrating
the software’s accuracy in predicting current distribution, input impedance, gain, and
radiation patterns. The influence of the antenna’s finite thickness on the resonance
frequencies and gain was also highlighted.

This example serves as a foundation for more complex antenna designs. By understanding
the simulation process for this simple geometry, users can apply similar principles to model
and analyze a wide range of antenna structures.

See Also:

Linear Antenna Theory: Historical Approximations and Numerical Validation
Modeling a Circular Loop Antenna in AN-SOF: A Step-by-Step Guide

This step-by-step guide empowers you to simulate circular loop antennas in AN-SOF. We'll
configure the software, define loop geometry, and explore how its size relative to wavelength
affects radiation patterns and input resistance. Gain valuable insights into this fundamental
antenna type!
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This article provides a step-by-step guide to modeling a circular loop antenna using AN-
SOF software. Circular loops are a common antenna type, and their analysis requires
curved segments within the simulation environment. The guide will detail the configuration
process, including defining the loop geometry, setting up the frequency sweep, incorporating
a voltage source, and analyzing the key parameters like radiation pattern and input
resistance. This guide is valuable for RF engineers, ham radio enthusiasts, students, and
antenna design professionals seeking to utilize AN-SOF for circular loop antenna
simulations.

1. Specifying the Simulation Setup

This section outlines the initial setup steps required to model a circular loop antenna in AN-
SOF. We'll configure a frequency sweep to analyze the antenna’s behavior across a
specified range.

Frequency Sweep:

1. Choose Lin for a linear frequency sweep. This allows for evenly spaced data points
across the desired range.
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2. Define the sweep parameters:
o Start frequency: 3 MHz
o Step: 1 MHz (adjust as needed based on desired resolution)
o Stop frequency: 30 MHz

These settings establish a linear sweep from 3 MHz to 30 MHz with 1 MHz increments
between each data point (as shown in Fig. 1).

¥ Frequency
Options Frequency Sweep
O single @ Lin Olog
Start |3 MHz
O st

=
= s [0 |

Fig. 1: Configuring the Frequency Sweep in AN-SOF.

Additional Settings:

e Environment: Ensure that None is selected in the Ground Plane box within the
Environment panel. This removes any ground plane influence from the simulation,
which might not be relevant for a free-space loop antenna.

o Excitation: In the Excitation panel, verify that Discrete Sources is selected. This
indicates that we’ll define a lumped source (voltage or current) to excite the antenna
later in the modeling process.

By following these steps, we’ve established the foundation for our loop antenna simulation
by configuring the frequency sweep and essential simulation settings in AN-SOF. The next
section will delve into defining the geometry of the circular loop itself.

2. Defining the Circular Loop Geometry

This section focuses on creating the circular loop geometry within the AN-SOF workspace:
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1. Specify Loop Parameters: The Draw dialog box for the circle will appear (Fig. 2).
Define the following parameters for your loop antenna using the provided tabs:
o Center: (Cx, Cy, Cz) = (0, 0, 0) (Circle tab)
Radius: 0.5 meters (Circle tab)
Segments: 8 (Attributes tab)
Cross-section type: Circular (Attributes tab)
Cross-section radius: 5 millimeters (Attributes tab)

[¢]

[¢]

[¢]

o

Draw

{Crrde | Orientation Attributes Materials

Options: Center - Radius - Orientation
Center [m]
cx|0 | cy|o cz|0

Radius [m] 0.5

oK Cancel

Fig. 2(a): Setting loop dimensions in AN-SOF Draw
dialog (Circle tab).
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OK Cancel

Fig. 2(b): Defining loop segmentation and wire cross-
section in AN-SOF Draw dialog (Attributes tab).

Download Model

Segment Selection: The number of segments used to discretize the loop circumference is
crucial for accurate simulation results. While 8 segments are a reasonable starting point, a
convergence study might be necessary to ensure sufficient accuracy, especially for
electrically large loops. As a rule of thumb, aim for 10-20 segments per wavelength at the
highest frequency of interest.

Electrical Size Considerations: It's important to consider the loop’s electrical size relative
to the wavelength. At 30 MHz (the highest frequency in your sweep), the wavelength (A) is
indeed 10 meters, and the loop’s circumference (0.314A) is close to one-third of a
wavelength. This suggests the loop might not be electrically small at the high end of the
frequency range. This characteristic will affect the antenna input impedance and radiation
pattern.

Assigning the Excitation Source:

1. Right-click on the circular loop within the AN-SOF workspace.
2. From the pop-up menu, select Source/Load.
3. Choose to add a voltage source and position it at the first segment of the loop.

For detailed instructions on source placement and parameter definition, refer to the
AN-SOF documentation’s ‘Adding Sources‘ section.
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3. Running the Simulation and Analyzing Results

This section guides you through initiating the simulation process and analyzing the obtained
results in AN-SOF:

1. Run Simulation: Locate the Run Currents and Far-Field (F11) button on the toolbar
and click it. This initiates the simulation, calculating the current distribution on the loop
and its far-field radiation pattern across the defined frequency sweep.

2. Visualizing the Radiation Pattern: Once the simulation is complete, click the Far-
Field 3D Plot button on the toolbar. This will display the radiation pattern of the loop
antenna in a 3D format (AN-3D Pattern application similar to Fig. 3).

3. Frequency-Dependent Analysis: The AN-3D Pattern toolbar offers functionalities to
explore the radiation pattern’s behavior at different frequencies within the sweep range.

o Frequency selection dropdown menu: This menu allows you to directly choose
a specific frequency point to view its corresponding radiation pattern.

o Frequency navigation buttons: Utilize the up and down arrow buttons on the
toolbar to navigate through the calculated frequencies and observe the dynamic
changes in the radiation pattern. As expected for a circular loop antenna, the
pattern should exhibit a doughnut-like shape at lower frequencies.

4. Input Resistance Analysis: Navigate to the Results tab within AN-SOF. Here, you
should observe a very low input resistance value, likely around 0.000195 Ohm at 3
MHz.

5. Comparison with Theoretical Radiation Resistance: The well-known formula for the
radiation resistance, R;, of an electrically small loop antenna is R, = 31,200 (A/A%)2.
Applying this formula with the loop’s area (A) and the wavelength (A) at 3 MHz, you
obtain a theoretical value of R, = 0.000192 Ohm. The close agreement between the
simulated and theoretical values at 3 MHz demonstrates that the loop behaves
according to the small loop antenna model at lower frequencies within the sweep
range.

Important Note:

It's important to remember that the formula used for radiation resistance applies to
electrically small loops. As mentioned earlier, the chosen loop dimensions might not be
electrically small across the entire frequency sweep (especially at 30 MHz). This will lead to
deviations between the theoretical and simulated results at higher frequencies.

Figure 3 illustrates the frequency dependence of the loop antenna’s 3D radiation pattern.
Subfigures (a), (b), and (c) depict the patterns at 3 MHz, 15 MHz, and 30 MHz, respectively.

By following these steps, you’ve successfully run the simulation, analyzed the radiation
pattern, and compared the input resistance with theoretical expectations.
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Fig. 3(a): Doughnut-shaped radiation pattern of the

loop antenna at 3 MHz.
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Fig. 3(b): Radiation pattern of the loop antenna at

16 MHz, showing a transition from the low-

frequency pattern.
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Fig. 3(c): Radiation pattern of the loop antenna at
30 MHz.

Monopole Over Real Ground

A monopole is a vertical element connected to a ground plane and with the feed point at its
base. In this example we will simulate a radio mast on an imperfect ground, which is used for

broadcasting in the LF and MF bands.

Step 1 | Setup

Go to the Setup tabsheet and set an operating frequency of 3 MHz in the Frequency panel.

Then, go to the Environment panel > Ground Plane box and select Real, Fig. 1. Select

Radial wire ground screen and the Poor ground options. Note that the soil conductivity will

automatically be set to 0.001 S/m and the permittivity (dielectric constant) to 5.

Finally, set the number of radials, their length and radius as shown in Fig. 1. In radio masts it

is customary to use a constant input power as a reference, for example 1 kW. Go to the
Excitation panel, select Discrete Sources, Set Input Power and enter 1,000 W, Fig. 2.
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Fig. 1: Setting a radial wire ground screen.
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Fig. 2: Setting discrete sources as the excitation with 1,000 W of input power.
Step 2 | Draw
Right click on the workspace and select Line from the displayed pop-up menu >. Specify a
vertical wire 25 m in height (1/4 of a wavelength at 3 MHz) and with a triangular cross
section as shown in Fig. 3. Although the recommended minimum number of segments is 3,
we will divide the wire into 10 segments to obtain greater resolution in the current

distribution. Note that the wire will be automatically connected to the ground at the origin
(0,0,0).

Right click on the wire, select the Source/Load command from the pop-up menu and put a

voltage source on the first segment, so the source will be connected to the base of the mast.
Refer to Adding Sources >.
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Fig. 3(a): Specifying a vertical wire in the Line page.
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Fig. 3(b): Specifying a triangular cross section.
Step 3 | Run
Click on the Run Currents and Far-Field (F11) button on the toolbar. After the calculations
are complete, click on the Far-Field 3D Plot button on the toolbar to display the radiation
pattern. Choose Radiation Pattern under the Plot menu in AN-3D Pattern to plot the
normalized radiation pattern (dimensionless). Then, choose the Radiation Pattern [dB]
option to see the pattern in decibel scale. Note that the far field has a null on the xy-plane
due to the losses in the ground plane, Fig. 4.

The antenna efficiency is the radiated to the input power ratio. Go to the Results tabsheet to
see the input impedance, VSWR, Directivity, Gain, and Efficiency, Fig. 5. Note that the
efficiency is low and therefore the gain too since most of the input power is lost to the
ground. In this example we have chosen a Poor soil. Try different soils and increasing the
number of radial wires and their length to improve the antenna efficiency.
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Fig. 4: Radiation pattern of a quarter-wave monopole over a radial wire ground screen.
Download Model
Setup Workspace Feedline Results

No. Freq. Rin Xin VSWR Dir. Gain Eff.

MHz Ohm Ohm dBi dBi %

1 3 522151 30.0568 1.78892 5.17579 -2.39475 17.4963

Fig. 5: Results tabsheet for a quarter-wave monopole over a radial wire ground screen.
Helix Antenna in Axial Mode

The helix is a good example where we need curved segments to describe the geometry of
the antenna. When the length of the helix is of the order of or greater than the wavelength, it
can work in the so-called “axial mode”. To do this, we need to add a ground plane as a
reflector.

Step 1 | Setup

Go to the Setup tabsheet and set an operating frequency of 100 MHz in the Frequency
panel. Then, go to Environment panel > Ground Plane box, select Perfect, and set the
ground plane position at Z = 0 (xy-plane), Fig. 1. Make sure the Discrete Sources option is
selected in the Excitation panel.
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¥ Frequency
Options
(® Single Single Frequency
100 MHz
(O List
2.99792 m
O Sweep
Fig. 1(a): Setting the operating frequency for the helix antenna.
Ground Plane

Type

(O None

Position [m]
@) Perfect 7 [o

O Real

() Substrate

Fig. 1(b): Setting the ground plane for the helix antenna.

Step 2 | Draw

Go to the Workspace tab, right click on the screen, and select Helix from the displayed pop-
up menu >. The Draw dialog box for the Helix will be shown, Fig. 2. The helix will start
above the ground plane, at the point (0,0,0.3) m, and run along the Z axis. We will then add
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a vertical wire that will connect the helix to the ground plane and where we will place the
source.

The recommended helix dimensions for the axial mode can be obtained from any antenna
book. Here we will set the helix radius, pitch (spacing between turns), and number of turns
shown in Fig. 2. In the Attributes tab, we will leave the recommended number of segments
of 103. The wire cross-section will be circular with 3 mm in radius

Draw

HElIX Orientation Attributes Materials

Options: Start - Radius - Pitch - Turns
Start Point [m]

x1[0 | vilo z1/0.3

Radius [m] 0.477

Pitch [m] 0.692

Number of Turns 10

oK Cancel

Fig. 2(a): Specifying the helix dimensions.
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Draw

Helix  Orientation {Attributes | Materials

Number of Segments 103

Cross Section Circular e

a [mm] |3

oK Cancel

Fig. 2(b): Specifying the helix segmentation and cross-
section.

Download Model

After drawing the helix, right click on the helix and choose the Start Point to GND command
from the pop-up menu. The Draw dialog box for a Line will be displayed, where the
coordinates of the ends of the wire are already set to connect the helix to the ground plane,
Fig. 3. Set up 2 segments and a radius of 3 mm for this vertical wire. Finally, right click on the
vertical wire, choose the Source/Load command, and connect a voltage source to the
segment that is closest to the ground plane. Refer to Adding Sources > to add the source.
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Draw
fLine ! Attributes Materials
Options: 2 Points ot
From Point [m]
x10 | vajo | 21)0.3 |
To Point [m]
x2|0 v2(0 | 220
oK Cancel

Fig. 3(a): Specifying the vertical wire that connects the
helix to the ground plane.

Draw

line  [Attributes | Material

Number of Segments 2

Cross Section Circular A

a [mm] (3

oK Cancel

Fig. 3(b): Specifying the segments and cross-section for
the vertical wire.
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Step 3 | Run

Click on the Run Currents and Far-Field (F11) button on the toolbar. After the calculations
are complete, click on the Far-Field 3D Plot button on the toolbar to display the radiation
pattern, Fig. 4(a). The main lobe is on the axis of the helix, hence the name “axial mode”.

Because the helix is right-handed, the radiated field is circularly polarized, and the right-
handed component predominates. Go to the AN-3D Pattern Plot menu and choose E-right
or E-left to see the difference between both components, Figs. 4(b) and 4(c). To make the
comparison between the color scales meaningful, go to Edit > Preferences in AN-3D
Pattern and set the maximum of E-left to the same value as the maximum of E-right.

To draw a left-handed helix, specify a negative number of turns. Repeat the calculations and

compare the E-right and E-left components.

I AN-3D Pattern - Plot1

Radialion Pattern
Max 1

Min: 2.762e=05
Distance [m]: 1

Zc [Ohm]: 376.73
Theta [deg]: 0: 2.5: 90
Fhi [deg]: 0:5: 360

.

File Edit View Plot
BE = 3| & & fz%| A xy vz ozx | gy | 007

Radiation Pattern at 100 MHz

Fig. 4(a): Normalized radiation pattern of the helix.
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Fig. 4(b): Right-handed circularly polarized
component of the far-field.
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Fig. 4(c): Left-handed circularly polarized
component of the far-field.

https://antennasimulator.com/index.php/an-sof-user-guide/

275/303



12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

After learning how to simulate a Cylindrical Antenna >, we are ready to build a dipole array.
A 3-element Yagi-Uda antenna, consisting of a reflector, a driven element, and a director, is
shown in Fig. 1, where the coordinates of the wire ends are indicated in meters.

(€0.25,0,0) (0.238,0.15, 0)

(-0.226, 0.3, 0)

0.25,0,0
( ) (0.238,0.15,0)  (0.226,0.3,0)

®

Fig. 1: Geometry definition for the Yagi-Uda array. The coordinates are in meters.

Download Model

Step 1| Setup

Go to the Setup tabsheet and set an operating frequency of 300 MHz in the Frequency
panel. None must be selected in Environment panel > Ground Plane box and Discrete
Sources in the Excitation panel.

Step 2 | Draw

Follow the procedure described in Cylindrical Antenna > to draw one wire at a time. Set the
coordinates of the ends of the wires indicated in Fig. 1. Set 15 segments for each wire and a
radius of 5 mm. Then, right click on the driven element, select the Source/Load command,
and connect a voltage source at the middle segment. Refer to Adding Sources >.

Step 3 | Run

Click on the Run Currents and Far-Field (F11) button on the toolbar. Fig. 2 shows the table
in the Results tabsheet, where a peak gain of 8.9 dBi is obtained. This can also be seen in
the gain pattern of the Yagi-Uda array shown in Fig. 3. Click on the Far-Field 3D Plot button
on the toolbar to plot the 3D radiation pattern.
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Fig. 2: Results tabsheet, where a peak gain of 8.9 dBi is obtained for the Yagi-Uda array.

Two-wire transmission lines can be modeled explicitly in AN-SOF. In this example, the line
will have a single wire but there will be a ground plane below it, so we have the mirror image

Run
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Fig. 3: Gain pattern [dBi] for the Yagi-Uda array of Fig. 1 at 300 MHz.
A Transmission Line

of the wire as the return of the line.

Step 1| Setup

Go to the Setup tab and select Single in the Frequency panel >. Set a frequency of 100
MHz. Then, go to the Environment panel > and set a perfect ground plane at Z = 0, Fig. 1.
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¥ Frequency
Options
(@ Single Single Frequency
100 MHz
() List
2.99792 m

(O Sweep

Fig. 1(a): Setting up the frequency for the transmission line.

Ground Plane
Type

() None

Position [m]

O Real

() Substrate

Fig. 1(b): Setting up the ground plane for the transmission line.

Step 2 | Draw

Go to the Workspace tab, right click on the screen, and select Line from the pop-up menu
>. Draw a horizontal line with the coordinates indicated in Fig. 2. Next, connect the ends of
the line to the ground plane by drawing two vertical wires. You can right click on the line and

https://antennasimulator.com/index.php/an-sof-user-guide/ 278/303


https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1
https://antennasimulator.com/index.php/knowledge-base/selecting-a-wire/#articleTOC_1

12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

select the commands Start point to GND and End point to GND to connect the ends to

ground.
Z
W 500 mm
— i
(0,0,40) (0,500,40)
1y cross-section radius = 2 mm i 40 mm

(0,0,0) (0,500,0) — ¥

Fig. 2: Transmission line dimensions.

Set 40 segments for the horizontal wire and 1 segment for each of the vertical wires. Note
that dimensions in Fig. 1 are in millimeters. To change the unit of length, go to Tools menu >
Preferences > Units tab >.

Right click on the vertical wire at (0,0,0), select Source/Load from the displayed pop-up
menu and put a 1 Volt voltage source on it. Refer to Adding Sources > to add the voltage
source.

Step 3 | Run

Go to the Run menu and click on Run Currents. Since we are only interested in the current
distribution and the input impedance, it is not necessary to calculate the radiated field (you
can do it to check that it is practically negligible). Click on the Zin (List Input Impedances)
button on the toolbar to display a table where the input impedance is shown as a function of
frequency, Fig. 3. Refer to Listing Input Impedances >.

Input Impedance List - m] e

o, Frequency Real (Zn) Imag (Zn)

oo 1161803 511816 5118 |Tra

Fig. 3: Transmission line in the workspace and table of input impedances.

The impedance obtained is practically reactive, j512 Ohm. The small real part is the radiation
resistance, since the line radiates a small amount of power, which is negligible but not zero.
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This is a short-circuited line. Now right click on the vertical wire at (0,500,0) mm and select
Delete from the pop-up menu to remove it. You will get an open-circuited line in this way.
Rerun the calculations with the Run Currents command in the Run menu. The input
impedance will now be -j105 Ohm.

Summarizing, we have,

in (short-circuited line) = j512 Ohm.

Z
Zin (open-circuited line) = -j105 Ohm.

According to transmission line theory, the characteristic impedance can be calculated as the
geometric mean of the short-circuit and open-circuit line input impedances, hence

Z.=+vV512 X 105 =232 Ohm

On the other hand, the expression for the characteristic impedance of a line above a ground
plane is given by:

2h 2 X 40
Z.=138 log( ) = 138 log( ) = 221 Ohm

a
where a is the wire cross-section radius and h is the line height above the ground plane. As
we can see, the agreement between the characteristic impedance obtained from AN-SOF
and that from theory is quite good. The difference is since the theory neglects the radiation of

the line, and the logarithmic formula is an approximation that is valid when h >> a.
An RLC Circuit

The ability of AN-SOF to simulate at extremely low frequencies can be demonstrated with a
model of an RLC circuit that will resonate at only 800 Hz, so the wavelength is 375 km!

Step 1| Setup

Go to Tools > Preferences > in the main menu and select Hz, mm, mH and uF as the units
for frequency, length, inductance, and capacitance, respectively. Then, go to the Setup tab
and select Sweep in the Frequency panel >. Choose Lin for a linear sweep and set the
Start, Step, and Stop frequencies. The frequency sweep will start at 600 Hz and end at
1,000 Hz, incrementing by 10 Hz for each calculation, Fig. 1. In the Environment panel >,
set a perfect ground plane at Z = 0.
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Step 2 | Draw

Go to the Workspace tab, right click on the screen, and select Line from the pop-up menu
>. Draw the three wires with the coordinates indicated in Fig. 2 using the Line dialog box.
The left vertical wire has 1 segment, the horizontal wire has 1 segment, and the right vertical

Options

Q single

O List

(® Sweep

Frequency Sweep

@®Lin Olog

Start |600 Hz
Step |10 Hz
Stop |1000 Hz

Fig. 1(a): Setting up frequencies for the RLC circuit.

Ground Plane

Type

() None

(@ Perfect

() Real

() Substrate

Position [m]
Z \u

Fig. 1(b): Setting up the ground plane for the RLC circuit.

wire has 2 segments. The wire radius is 0.5 mm.
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Z
R = 10 Ch
0,0.50) m (0,50,50)
L = 20 mH
v ()
C=2uF
- - -
= = Y
(0,0,0) (0,50,0)

Fig. 2: RLC circuit dimensions. The coordinates are in millimeters.

Right click on the left vertical wire, select the Source/Load command from the pop-up menu
and put a 1 Volt voltage source. Then, right click on the horizontal wire, select Source/Load
from the pop-up menu and connect a load impedance with R = 10 Ohm. Finally, right click on
the right vertical wire, select Source/Load from then pop-up menu and put an inductance L
= 20 mH on the first segment and a capacitance C = 2 uF on the second segment. Refer to
Adding Sources > and Adding Loads > for adding sources and load impedances.

Step 3 | Run

Go to the Run menu and click on the Run Currents command. Since we are only interested
in the input impedance, it is not necessary to calculate the radiated field (you can do it to
check that it is practically negligible).

Right click on any of the three wires composing the circuit, select the List Currents
command and click on the Current on Segment button of the displayed toolbar >. A table
will be shown, where the current is tabulated vs. frequency. Next, press the Plot button to
the right of the table to plot the current versus frequency, Fig. 3.
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Fig. 3: Current amplitude vs. frequency in the RLC circuit.

Since this is a series RLC circuit, the current flowing must be the same in all three wires
(check this). As can be seen, resonance occurs at a frequency near to 800 Hz. Repeat the
calculation for frequencies around 800 Hz, with a step of 1 Hz, and verify that the resonant
frequency is 796 Hz. On the other hand, according to circuit theory, the resonance frequency
is given by

1 1

_ = =796 Hz
2nVLC  2mV20 X 10-3 x 2 X 10-6

fr

The agreement between AN-SOF and theory is remarkable!

Background Theory

The AN-SOF Calculation Engine

The AN-SOF engine is written in the C++ programming language using double-precision
arithmetic and has been developed to improve the accuracy in the modeling of wire
antennas and metallic structures in general.

The computer code is based on an Electric Field Integral Equation (EFIE) expressed in the
frequency domain. The current distribution on wire structures is computed by solving the
EFIE using a Method of Moments (MoM) formulation with curved basis and testing functions,
called the Conformal Method of Moments (CMoM) >. In this method, curved wires are
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modeled by means of conformal segments, which exactly follow the contour of the structure,
instead of the traditional approximation based on straight wire segments. The linear
approximation to the geometry can be a very inefficient method in terms of unknowns or
computer memory. By using curved segments, the number of unknown currents, simulation
time and memory space can be greatly reduced, allowing for the solution of bigger problems.

Old MoM codes suffer from several drawbacks due to the linear approximation to geometry
and the use of the so-called thin-wire Kernel, such as: divergent input impedance, poor
convergence for curved antennas (helices, loops, spirals) and bent wires, and singularities
that appear when two parallel wires are close to each other or close to a lossy ground

plane. With the CMoM and an exact Kernel formulation we have removed these limitations
and obtained the following advantages:

e Decreased number of calculations and increased accuracy of results.
o Decreased simulation time and computer memory usage, allowing us to model larger
and more complex designs.
 Ability to simulate from extremely low frequencies (circuits at 60 Hz) to very high ones
(microwave antennas).
Electric Field Integral Equation

The current distribution on metallic surfaces with ideal conductivity can be found by solving
an Electric Field Integral Equation (EFIE) expressed in the frequency domain:

nxE,(r)=n xiﬂ 23 G, + div' (I Y grad (G r') HS'
e &

Eq. (1)
where:
E;: Incident Electric Field on the surface S.
n: unit vector at point r on the surface S.
k: wave number.
J: unknown electric current density flowing on the surface.

G: Green’s function, which in free space is given by:

oM
Gl:l',l'l) = m
Eq. (2)
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The EFIE is an expression of a boundary condition on the surface, namely zero tangential
electric field. When we are dealing with a wire structure, the EFIE reduces to:

TE =T iJ‘[»‘Czl'l:s']l.e’{(.'s',s')T'+dY(SI)
@E L ds'

grad(K(s,s'))]ds'

Eq. (3)

where T is the tangential unit vector describing the wire contour along its axis, /(s) is the
unknown electric current on the wire, and K(s,s") is the integral equation Kernel defined as:

1 2w
K(s,s) = [ |G r)dg
00

Eq. (4)

The EFIE is averaged about the wire circumference, resulting in the EFIE (3) with the Kernel
(4). The current distribution /(s) is then the average value of the current density J in the axial
direction; the current in the transversal direction is neglected. This is a good assumption
provided that the wire radius is small with respect to the wavelength.

The wire axis is defined by its parametric equations that can be written in the compact form:

ri(s)= x(s)i+ y(s)) +z(s)k
Eq. ()

which points from the origin to any point on the wire, Fig. 1. The parameter s varies over a
real interval. The tangent unit vector can be obtained from the first derivative of (5):

-1

dr(s)=ﬁi+d_yj+£k T2 4r|dr
ds ds ds ds ds |ds
Eq. (6)
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Fig. 1: Parametric description of a curved wire. The tangent unit vector is obtained
from the first derivative of the position vector r(s).

This parametric description is the key for the accurate modeling of wire structures. A straight
wire approximation to the geometry produces a loss of geometrical information that can
never be completely restored. However, this information is not lost if a parametric
representation is used to describe the wire locus. It is also possible to improve on the
straight wire approximation by using quadratic segments to model the geometry.

Thus, the definition of a wire must include its parametric description and its first derivative if
an exact representation of the geometry is required, as shown in Fig. 1.

The Kernel (4) can be approximated by the following generalized thin-wire approximation:
- kR

Keshzl—  R=f@-r@)f +a’

Eq. (7)

where a is the wire radius.

When the observation point r(s) and the source point r(s‘) are both in the same straight wire,
the distance R reduces to the usual thin-wire approximation:
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R= \1(3*~$')2 +a’
Eq. (8)

Thus, the EFIE and its Kernel are also valid for straight wires.

It is well known that the thin-wire approximation produces numerical oscillations in the
computed current distribution near wire ends and near the position of discrete sources when
wire segments are relatively thick. To avoid this undesired behavior and obtain the maximum
accuracy, the exact Kernel in (4) is used in AN-SOF by default instead of the thin-wire
approximation in (7). A closed-form expression for the exact Kernel has been found so its
use practically does not compromise the speed of the simulation. However, an extended
thin-wire Kernel has been calculated that also avoids the current distribution inaccuracies for
a thin-wire ratio (wire diameter/segment length) < 3, which is far better than the thin-wire
ratio < 1 that must be used when the standard thin-wire approximation is used.

In the Settings panel > of the Setup tabsheet check the Exact Kernel option to use the
exact Kernel in (4). Uncheck this option to use the extended thin-wire Kernel.

The existence of a PEC ground plane is modeled in AN-SOF by means of image currents.
This method can be easily implemented by adding an image term to the Green’s function,
resulting in an additional term for the Kernel.

The Exact Kernel

The kernel is the core of the integral equation that is solved in AN-SOF by means of the
Method of Moments (MoM) to obtain the current distribution on metallic wires. Since the
kernel cannot be calculated analytically in closed form, several approximations exist, among
which the best known and widely used is the so-called thin-wire approximation.

The integral equation kernel is given by
! 1 2n 21 ! !
K(s,s) =4—2f0 JG(r,r)dpdp (1)
T

where s and s are coordinates along a wire axis that represent an observation point and a

source point, respectively. G is the free space Green’s function, and ¢ and ¢' are angles that
determine points on the circumference of the wire cross-section. Thus, r = (s, ¢)

represents an observation point on the wire surface, and r o= ( s , ¢’ ) represents a source
point. With that said, we can see that the kernel is obtained by averaging the Green’s
function along the contour of the wire’s cross-section.

In the thin-wire approximation, the kernel is approximated as follows,
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where a is the wire radius, and R is the distance between the source and observation points.
When both points are on the same wire, the current will be represented by a filament on the
wire axis, as the expression for R shows. In particular, when both points coincide (r = r,),
which happens when calculating the electromagnetic interaction of a wire with itself, the thin-
wire kernel will vary as 1 / a, but the exact kernel will have an integrable singularity.

When a wire segment is thin, that is, its length is at least twice its diameter, the thin-wire
approximation works well. However, as we increase the number of segments and therefore
the segments get shorter, we will reach a threshold where the segments are too thick for
the thin-wire approximation to work. This situation is particularly restrictive when we are
investigating the convergence of some parameter or even when we want to fill the source
gap at the antenna terminals using a short wire.

In AN-SOF, we have implemented the exact kernel instead of the thin-wire approximation.
The solution involves separating the kernel into two terms: one containing an analytically
integrable singularity, and the other containing a remainder that can be numerically
integrated with minimal computational effort since it does not have any singularity. We have
also provided the option of using an “extended kernel,” similar to the one used in NEC
(Numerical Electromagnetics Code), where a series expansion of the kernel in terms of the

wire radius is utilized, and the a2 and a4 terms are retained.
Note

In summary, it should be noted that AN-SOF implements both the Exact Kernel and
the Extended Kernel, while NEC uses an extended kernel and the thin-wire
approximation.

Fig. 1 shows the current distribution in amplitude along a center-fed half-wave dipole
obtained using both the thin-wire approximation and the exact kernel. The antenna has been
divided into segments with a diameter three times greater than their lengths, resulting in very
thick wire segments in this case.
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Fig. 1: Current distribution along a center-fed half-wave dipole divided into segments having a diameter-
to-segment length ratio of 3.

The thin-wire kernel exhibits the well-known oscillatory effect on the current distribution
near the position of discrete sources and at wire ends for a segment diameter-to-length
ratio greater than 1. As we can see, these oscillations disappear when the exact kernel is
used instead of the thin-wire approximation.

The effect of not using the exact kernel can also be observed in the lack of convergence of
the input impedance when the number of segments increases, as shown in Fig. 2 for the
AN-SOF vs. NEC-2 results.

https://antennasimulator.com/index.php/an-sof-user-guide/ 289/303



12/19/24, 12:58 AM AN-SOF User Guide » AN-SOF Antenna Simulation Software

FINITE GAP DELTA GAP
180 140 \
Q Q <L
160 | A I 120 ?-‘@/ N\
N\ ' P R (AN-SOF)
. = \
140 _- - 100 - / '\"I
- -7 !
120 |
L7 R (AN-SOF) 80 - \
100 - 4—4’—_ 6o \
- ’1 X (NEO) _— X (AN-SOF) \‘
P o  T=o - \
60 - --=" X (AN-SOF T~ '
-~ ( ) 20 \(4’6‘0 \
/ Nd \
40 - Fi \ .
0 - - : N
20 0 50 100 150 N\ 200
-20 - \\
o 4
0 S0 100 150 N 200 -40

Fig. 2: Comparison between the AN-SOF and NEC-2 results for the input impedance of a center-fed half-
wave dipole as a function of the number of segments used in each dipole arm. Radius = 0.005A, gap =
0.025).

Note

In conclusion, we will achieve the highest possible accuracy in the calculation of the
current distribution and antenna input impedance by using the Exact Kernel.
Conformal Method of Moments

The Method of Moments (MoM) is a technique used to convert the EFIE into a system of
linear equations that then can be solved by standard methods. For simplicity, the integral
(linear) operator in the Electric Field Integral Equation > (EFIE) will be denoted by L. Then,
the EFIE takes the form:

L =E,
Eq. (1)

where Etis the tangential component of the incident electric field. The current distribution is
approximated by a sum of N basis functions with unknown amplitudes /,,, giving:

=317,

Eq. (2)

With this expansion and using the linearity of the operator L, we can write:
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> L L(F,) = B,

Eq. (3)

To obtain a set of N equations, the functional equation (3) is weighted with a set of N
independent testing functions w,,, giving:

1, [wu L(F,)ds = [ w,, Erds

Eq. (4)

where the integrals are calculated over the domain of L. Now we have as many independent
equations as unknowns, so (4) can be written as:

2] [7]=[U]

Eq. (5)
where

[Z]: impedance matrix with dimension NxN and the elements
Zp = [ W L(F,)ds

[N: current matrix with dimension Nx7 and the elements /,,.

[U]: voltage matrix with dimension Nx7 and the elements
U, = [ WoBypds

This fully occupied equation system must be solved for the unknown currents /,,. LU
decomposition is used in AN-SOF. The MoM is applied by first dividing the wire structure into
N segments, and then defining the basis and testing functions on the segments. Triangular
basis and pulse testing functions are used in AN-SOF, Fig. 1.
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Fig. 1: (a) Triangular basis functions, F;(u), and pulse testing functions, T;(u). (b) Current distribution
approximated by triangular functions.

When a curved wire is described parametrically by a vector function as in Eq. (5) here >, the
basis and testing functions are curved in the sense that their support is a curved subset of
the wire. Therefore, when curved basis and testing functions are used, the Conformal
Method of Moments (CMoM) is obtained.

To fill the impedance matrix [Z], an adaptive Gauss-Legendre quadrature rule is applied to
compute the involved integrals. After having solved the equation system, the currents /,, are
known and other parameters of interest, such as input impedances, voltages, radiated
power, directivity, and gain can be computed.

The MoM can also be used to calculate the electromagnetic response of metallic surfaces,
which are modeled using wire grids. In AN-SOF, with the CMoM the accuracy of the
calculation of wire grids is remarkably improved compared to the traditional MoM, as
demonstrated in this article > . Another extension of the calculation includes wires that do
not have a circular cross section. In AN-SOF an equivalent radius is calculated for these
wires.

Excitation of the Structure

If a discrete voltage source is placed at the i-th segment, the corresponding element in the
voltage matrix is simply equal to the voltage of the generator. Thus,

0

[U]= U:‘
L 0 =

Eq. (1)
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When an incident plane wave is used as the excitation, each wire segment is excited by the
incoming field, which has the form:

E,(r) = Ee ™"
Eq. (2)

where k is defined by the direction of propagation, so that |k| = k is the wave number, and r
is the evaluation point, Fig. 1. The elements of the voltage matrix are then defined by:

Up = |Eir(s) T(s)ds
S

Eq. (3)

where the integration is performed over the m-th segment, and the vectors r(s) and T(s) are
given by Egs. (5) and (6) here >.

Fig. 1: Incident plane wave exciting a wire.
Curved vs. Straight Segments

Many examples show the advantages of using curved segments with respect to the
stability and convergence properties of the solutions. Due to the improved convergence rate,
accurate results can be obtained with reduced simulation time and memory space.

Fig. 1 shows the dimensions of a center-fed helical antenna in free space (normal mode).
Figs. 2 and 3 show a comparison between AN-SOF, which uses curved segments, and a
straight wire approximation to the helix of Fig. 1. The convergence properties of the input
impedance and admittance versus the number of segments are investigated.
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Fig. 1: Helix radius = 0.0273A. Pitch =
0.0363A. Number of turns = 10. Wire
radius = 0.001A.
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Fig. 2(b): Reactance convergence plot for the helix of Fig. 1.
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Fig. 3(b): Susceptance convergence plot for the helix of Fig. 1.
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As can be seen from these results, by using curved segments significantly fewer unknowns
are needed to predict the input impedance. However, the admittance convergence is
questionable for the straight wire case, while it has a notorious convergent behavior for the
curved case.

The improvement depends on the geometry and frequency, but generally, if N straight
segments are needed to obtain a convergent value, then N/p curved segments are needed
to obtain the same value, with p = 2...10. For a straight geometry the improvement factor is
p = 1, as can be expected, because there are no curved segments in this case.

Frequently Asked Questions

Licensing FAQ
1. Do | need a key for the AN-SOF Trial version?

No, you don’t. Simply run AN-SOF and start using it. If prompted for a license, go to the AN-
SOF main menu > Help > Activation Key. Click the Trial Key button in the displayed
window, followed by the Activate button. AN-SOF will restart and be ready for use in trial
mode.

2. Is there a time limit for the Trial version?

No. There is only a limit of 50 unknowns (segments + wire connections + ground
connections) to run the calculations. All example files included in the installation directory
are pre-computed and can be opened with the trial version of AN-SOF to display tables and
graphs without limitations. Download examples that have less than 50 unknowns from this
link >.

3. Will AN-SOF stop working when my plan ends?

No, AN-SOF will continue to function even after your plan expires. However, you will lose
access to the following features:

 Download updates: You will no longer be able to download and install the latest
versions of AN-SOF, including bug fixes and security updates.

o Technical support: You will no longer be eligible to receive technical support from our
team.

 Installer access: Installers for discontinued versions of AN-SOF will only be available
for download for three years after their discontinuation. After this period, you will
need to purchase a new plan to access the installers.
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o Activation key: If you lose the activation key for a discontinued version of AN-SOF, we
will not be able to provide you with a new one after three years of
discontinuation.

Therefore, while AN-SOF will continue to function, it is recommended to renew your plan to
ensure access to all features and ongoing support.
4. What happens if | don’t renew my plan?

If you don’t renew your plan, you will experience the following:

o Continued functionality: AN-SOF will continue to function, but it will be limited to the
version you have installed.

» No updates: You will not receive any updates, including bug fixes, security patches, or
new features.

o Limited support: You will not have access to technical support from our team.

» Version discontinuation: Your currently installed version of AN-SOF will eventually be
discontinued. After three years of discontinuation, the installer and activation key
for that version will no longer be available.

To continue enjoying the full functionality and support of AN-SOF, it is important to renew
your plan before it expires.

5. What is the difference between the GOLD and PLATINUM plans?

The PLATINUM plan includes live chat support in addition to ticket and email support,
priority support, and early access to updates and exclusive content. PLATINUM
customers also gain Premier Membership, granting access to the Early Access Portal and
additional exclusive benefits.

In contrast, the GOLD plan offers ticket and email support only. However, customers who
renew the GOLD plan annually without interruption also qualify for Premier Membership.

6. Do you offer a refund for AN-SOF purchases?

Due to the availability of a fully functional trial version with no time limit, all sales of AN-
SOF software licenses are final and non-refundable. This policy helps us ensure that users
have a fair opportunity to try out the software before making a purchase. We encourage all
users to thoroughly evaluate the trial version before purchasing a license. You can find
detailed information about the conditions and process for exceptions to the non-refundable
policy on our dedicated Refund Policy page.

Technical FAQ

1. What are the minimum PC requirements?
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Windows Vista/7/8/10/11. 2GHz CPU, 2GB RAM, 1GB free disk space.
2. Can AN-SOF be run on a Mac computer?

The supported operating system is Microsoft Windows. We have no plans to release a Mac
version. Macintosh users can run a program called Parallels >. Parallels Desktop for Mac
is desktop virtualization software that allows Microsoft Windows applications to run on an
Apple Mac computer.

3. Is there a version of AN-SOF for Linux?

No. The supported operating system is Microsoft Windows. We have no plans to release a
Linux version. You can use a Windows emulator like Wine, CrossOver Linux, Vmware
Workstation or whatever you find on the market.

4. Does AN-SOF support parallel processing?

No, it doesn’t. AN-SOF has been developed to run on home computers running Windows(R)
OS, so numerical calculation strategies have been implemented to take care of the available
RAM memory and at the same time obtain reliable results.

5. What is the upper frequency limit?

There is no theoretical upper limit for the frequency since the structure size is measured in
wavelengths. So, we talk about a size limit in wavelengths instead of a frequency limit. The
simulation requires solving a matrix equation of increasing order as the structure size is
increased in wavelengths, so modeling large structures will require more computer memory
and time on a particular PC.

6. How does AN-SOF divide the wires into segments? Is a higher density of segments
needed in tapered wires?

By default, AN-SOF calculates the minimum recommended number of segments for each
wire depending on its length in wavelengths. Various convergence analyzes > show that 10
wire segments per wavelength is sufficient for most cases. Regarding tapered wires, in old
algorithms like NEC it was necessary to increase the density of segments near the
connections between wires when there is a radius jump. This is not necessary in AN-SOF as
it is not NEC based. See the advantages of AN-SOF here >.

7. Can arrays be built quickly by duplicating and copying parts of a structure?

Yes. Go to main menu > Edit > Copy Wires > to duplicate or make the desired number of
copies of the selected wires. There is also the Stack Wires command which allows us to
repeat a design along a given direction. By using this command in combination with the
Scale Wires > command we can quickly build Yagi-like arrays.
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8. Can parametric design be done with AN-SOF, that is, run simulations
with variable geometric parameters such as the separation between
dipoles in an array?

Yes. Parametric design is possible by running a Bulk Simulation >. We prefer that the user
chooses the programming language to generate a sequence of files in NEC format with one
or more variable parameters. Calculations on these files can then be run automatically in
bulk. Scilab > is a free numerical calculation software tool with which we can program
scripts that generate multiple descriptions of an antenna with variable parameters.
Download an example of a Yagi-Uda antenna with variable element spacing from this link >.

9. Is the wire grid model well suited for surfaces?

In addition to specializing in wire structures composed of wire grids, AN-SOF also allows the
modeling of solid metallic surfaces. Solid surfaces are viewed in the AN-SOF workspace
as if they were wire grids; however, they are actually made up of flat strips. These strips
have widths automatically calculated to completely cover a metal surface without leaving
holes. Currently, there is a limit in the size of the grid/surface that can be modeled (see FAQ
#10).

10. Can AN-SOF model electrically large antennas like horns and parabolic
dishes?

AN-SOF is equipped to model solid metallic surfaces, including parabolics and horns.
Currently, there is a limitation of approximately 10 square wavelengths of surface. As long as
your antenna’s surface area stays within this threshold, you can run simulations. This
limitation pertains to the surface area of the antenna measured in square wavelengths,
rather than a restriction on the frequency range. This limitation also applies to grids (patches,
plates, cylinders, spheres, etc.).

11. Does AN-SOF support load impedances?

Yes, it does. Resistance, inductance, and capacitance elements can be added to the
structure to model the connection of lumped load impedances.

12. Are near E- and H-fields available in tables and for exportation as Excel
or Google Sheets files?

Yes, they are. The computed near E and H fields can be visualized in 2D and 3D plots as
well as in tables and exported as CSV (Comma Separated Values) files. Cartesian,
cylindrical and spherical near field components can be obtained.

13. Is AN-SOF based on a NEC engine?
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No. AN-SOF is an independent implementation of the Method of Moments (MoM) for wire
structures. NEC is an old Fortran calculation engine that has a lot of limitations. Many of
these limitations have been removed in AN-SOF by implementing the so-called Conformal
Method of Moments with Exact Kernel > in a completely new object-oriented C++ code.
See further details here >.

14. Can NEC files be imported into AN-SOF?

Yes. Most of the NEC commands are supported. Download NEC example files to import into
AN-SOF from here >.

15. Can dielectric materials be modeled with AN-SOF?

Dielectric material can be added as insulation or coating to metallic wires, and microstrip
antennas can be patterned on a dielectric substrate. However, modeling volumes composed
entirely of dielectric materials is not currently supported.

16. What types of PCBs and microstrip antennas can be simulated with AN-SOF?

Although AN-SOF was developed to simulate wire structures, we have been able to extend
the calculation engine to also model PCBs and microstrip antennas that meet the following
requirements:

e The structure must have a single layer of dielectric substrate. Multiple layers are not

supported.

o When the substrate has a finite size, the traces must be separated from the edges
by at least 5 times the width of a trace.

» The dielectric substrate is backed up by a perfectly conducting ground plane that
cannot be removed. Vias that go through the substrate and connect traces to the
ground plane can be added to feed an antenna or PCB.

17. What types of DXF files can be imported into AN-SOF?

Only DXF files containing LINE objects can be imported into AN-SOF. See the description of
the LINE object and download examples from this link >.
Troubleshooting

1. 1 get the error “Current License file is not valid for this version. AN-SOF
will run in trial mode.”

You have entered an invalid activation key. Find the AN-Key app and launch it. Press the
“Trial Key” button and then “Activate”. Restart AN-SOF. Follow the instructions in the AN-Key
window to request a valid key corresponding to your serial number if you have purchased a
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license. Please note that the key you used to activate a previous version of AN-SOF may not
be valid for the latest version. Request a new key >.

2. | get the error “The License file does not exist. AN-SOF will run in trial
mode.”

Find the AN-Key app and launch it. Press the “Trial Key” button and then “Activate”. Restart
AN-SOF. Follow the instructions in the AN-Key window to request a valid key
corresponding to your serial number if you have purchased a license. Please note that the
key you used to activate a previous version of AN-SOF may not be valid for the latest
version. Request a new key >.

3. | have entered the correct activation key, but AN-SOF continues to run in trial mode.

Uninstall AN-SOF. Then go to C:\ and delete all the folders whose names start with “AN-SOF
Professional”. Reinstall AN-SOF. Find the AN-Key app and launch it. Follow the instructions
in the AN-Key window to request a valid key corresponding to your serial number if you
have purchased a license. If the problem persists, open a support case here >. Please note
that the key you used to activate a previous version of AN-SOF may not be valid for the
latest version. Request a new key >.

4. AN-SOF or one of its applications does not work.

Uninstall AN-SOF. Then go to C:\ and delete all the folders whose names start with “AN-SOF
Professional”. Reinstall AN-SOF.

5. When running AN-SOF or any of its applications nothing is displayed on the screen.

Press Ctrl + Alt + Del and run the Task Manager. Right click on the application that is not
working and choose “End Task”.

6. When | try to run AN-SOF, | get the error “The feature you are trying to
use is on a network resource that is unavailable”.

Navigate to the folder that you specified when using the installer. The default folder is
“C:\AN-SOF Professional X”, where X is the AN-SOF version. Then, launch ANSOF.exe
directly from that location. You can create a shortcut to this file on the Windows desktop if
you wish.

Disclaimer of Warranty

This Knowledge Base and associated software are provided “as is” without warranty of any
kind, expressed or implied. Golden Engineering Ltd. disclaims all warranties, including, but
not limited to, the implied warranties of merchantability, fitness for a particular purpose, and
non-infringement.
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Golden Engineering Ltd. does not warrant that:

e The technical descriptions, procedures, and software are free from errors or defects.

e The equations, programs, and procedures are consistent with any standard of
merchantability.

e The equations, programs, and procedures will meet your requirements for any
application.

Golden Engineering Ltd. is not liable for any damages arising from the use of the
Knowledge Base or associated software, including, but not limited to:

¢ Direct, indirect, incidental, consequential, or punitive damages.
o Damages for loss of profits, data, or use.
o Damages for personal injury or property damage.

Any use of the Knowledge Base or associated software is at your own risk.
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